typecatcher crashes on launch

Bug #1931193 reported by Tommy Trussell
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
typecatcher (Debian)
New
Unknown
typecatcher (Ubuntu)
Undecided
Unassigned

Bug Description

I recently upgraded to hirsute 21.04 and just discovered typecatcher doesn't launch. A couple of web searches implies some deprecated python issues; I don't know what version python I was running in Ubuntu 20.10.

This is what I see when trying to launch it from a terminal:

~$ typecatcher
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/typecatcher_lib/Application.py", line 30, in on_activate
    self.window = TypeCatcherWindow.TypeCatcherWindow()
  File "/usr/lib/python3/dist-packages/typecatcher_lib/Window.py", line 47, in __new__
    builder = get_builder('TypeCatcherWindow')
  File "/usr/lib/python3/dist-packages/typecatcher_lib/helpers.py", line 44, in get_builder
    builder.add_from_file(ui_filename)
  File "/usr/lib/python3/dist-packages/typecatcher_lib/Builder.py", line 86, in add_from_file
    ele_widgets = tree.getiterator("object")
AttributeError: 'ElementTree' object has no attribute 'getiterator'
~$
~$ python --version
Python 2.7.18
~$

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: typecatcher 0.3-1.2
ProcVersionSignature: Ubuntu 5.11.0-18.19-generic 5.11.17
Uname: Linux 5.11.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu65.1
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Mon Jun 7 22:40:36 2021
InstallationDate: Installed on 2018-10-20 (961 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: typecatcher
UpgradeStatus: Upgraded to hirsute on 2021-05-12 (26 days ago)

Revision history for this message
Tommy Trussell (tommy-trussell) wrote :
Revision history for this message
Tommy Trussell (tommy-trussell) wrote :

I read that font-manager had the feature I needed at the moment so I used the Software Center to install it. For some reason the flatpak version it chose worked at first then crashed. So I uninstalled the flatpak and used apt to install the version in hirsute, which has worked just fine.

I think it's possible I have some weird cruft in my local font caches or somewhere leftover from the upgrade from groovy 20.10.

I successfully used font-manager to install a font in local storage (and font-manager seeing the two Google fonts typecatcher had installed several months ago)

HOWEVER even after a couple of reboots, typecatcher is still crashing on launch.

Revision history for this message
Tommy Trussell (tommy-trussell) wrote :

Working on the local cache theory I tried running typecatcher in another user account on this system but which did NOT have any user account installed fonts. It crashes in the same way as shown at top; font-manager runs fine, and confirms no locally-installed fonts in the other user's account.

Revision history for this message
Tommy Trussell (tommy-trussell) wrote :

I just fired up a VM of 21.04 Hirsute and typecatcher crashes with the same error on a new VM

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I can confirm that typecatcher 0.3-1.2 crashes when I attempt to run it on Ubuntu 21.04. I found a similar bug report in Debian which lists the same stack trace so I have attached a bug watch.

Changed in typecatcher (Ubuntu):
status: New → Confirmed
tags: added: impish
Changed in typecatcher (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.