upgrade from hardy to lucid breaks getPlugins(IPlugin)

Bug #631486 reported by Loic Dachary on 2010-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
twisted (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce the problem do as follows:

* on a lucid installation
* pbuilder --create --distribution hardy --basetgz /var/cache/pbuilder/hardy.tgz
* pbuilder --login --basetgz /var/cache/pbuilder/hardy.tgz
* apt-get install python-twisted
* python -c 'from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin));' # succeeds
* perl -pi -e s/hardy/lucid/ /etc/apt/sources.list
* apt-get update
* apt-get dist-upgrade
* python -c 'from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin));' fails with:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/dist-packages/twisted/plugin.py", line 200, in getPlugins
    allDropins = getCache(package)
  File "/usr/lib/python2.6/dist-packages/twisted/plugin.py", line 162, in getCache
    (pluginModule.filePath.getModificationTime() >= lastCached)):
  File "/usr/lib/python2.6/dist-packages/twisted/python/filepath.py", line 504, in getModificationTime
    self.restat()
  File "/usr/lib/python2.6/dist-packages/twisted/python/filepath.py", line 468, in restat
    self.statinfo = stat(self.path)
OSError: [Errno 2] No such file or directory: '/usr/lib/python2.6/dist-packages/twisted/plugins/notestplugin.py'

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers