Sync twextpy 1:0.1~git20161216.0.b90293c-2 (universe) from Debian unstable (main)

Bug #1821130 reported by Rahul Amaram on 2019-03-21
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
twextpy (Ubuntu)
Status tracked in Eoan
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Low
Unassigned

Bug Description

Please sync twextpy 1:0.1~git20161216.0.b90293c-2 (universe) from Debian unstable (main)

A corresponding Ubuntu freeze exception request has already been filed:
https://bugs.launchpad.net/ubuntu/+source/twextpy/+bug/1821129

[Impact]
Continuous exceptions in log files when NSS directory service is enabled (See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925585). This was causing excessive log activity and impacting functionality when using NSS directory service.

The main problem is that there are constructors in NssUserRecord and NssGroupRecord classes, which have different definition compared to the constructions of the interface (parent class). To fix this, I have removed constructors for NssUserRecord and NssGroupRecord classes allowing them to fallback to the constructor of their parent class

[Test Case]
* Install calendarserver 9.2 and twextpy 1:0.1~git20161216.0.b90293c-1
* Set up NSS directory service as described in /usr/share/doc/calendarserver/README.Debian.gz
* Start calendarserver
* Access a calendar using caldav client. Username and password will be that of NSS user.
* You will see errors in calendarserver logs (/var/log/caldavd/error.log)

[Regression Potential]
Can't think of any potential regressions.

Changed in twextpy (Ubuntu):
importance: Undecided → Wishlist
Rahul Amaram (amaramrahul) wrote :

This fixes an important bug which causes excessive exceptions and possibly broken functionality with one of the modules of calendarserver. Could the latest version of twextpy from Debian unstable by synced to Ubuntu disco address this issue?

tags: added: upgrade-software-version
Changed in twextpy (Ubuntu):
importance: Wishlist → Low
Simon Quigley (tsimonq2) wrote :

Hello Rahul, apologies for the delay on this; it seems you didn't subscribe the Release Team, and thus this didn't get addressed on time for the release.

Please edit the bug description to follow the SRU bug template, which you can find here: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Once that's done, please resubscribe the Ubuntu Sponsors Team, and this can be uploaded to Disco. You might want to consider preparing uploads for Cosmic and Bionic as well, if it affects those.

Rahul Amaram (amaramrahul) wrote :

Done. Kindly upload to disco.

description: updated

sponsored in disco, please let us know if you need also cosmic/bionic, I don't know if this regression is caused by python or something else, and when it has started...

Changed in twextpy (Ubuntu):
status: New → Fix Released
Changed in twextpy (Ubuntu Disco):
status: New → In Progress

Hello Rahul, or anyone else affected,

Accepted twextpy into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/twextpy/1:0.1~git20161216.0.b90293c-1.19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in twextpy (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Rahul Amaram (amaramrahul) wrote :

I have tested with the newly uploaded python-twext package in disco-proposed and the issue is resolved. Tested version is: 1:0.1~git20161216.0.b90293c-1.19.04.1 .

Also, it has been more than 7 days since the package has been uploaded to disco. So I belive it should be now ready to be released to -updates.

Rahul Amaram (amaramrahul) wrote :

I am unable to update the tag to "verification-done-disco". Request you to do it on my behalf.

done, thanks for verifying and saying that bionic/cosmic are not affected

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Changed in twextpy (Ubuntu Cosmic):
status: New → Invalid
Changed in twextpy (Ubuntu Bionic):
status: New → Invalid

Quoting the email:
* Issue is fixed in disco

* Unable to reproduce it in cosmic or bionic

Probably bug occurs only with calendarserver 9.2 (the version in disco)?
bionic and cosmic have calendarserver 9.1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package twextpy - 1:0.1~git20161216.0.b90293c-1.19.04.1

---------------
twextpy (1:0.1~git20161216.0.b90293c-1.19.04.1) disco; urgency=low

  * Removed constructors for NssUserRecord and NssGroupRecord classes allowing
    them to fallback to the constructor of their parent class (Closes: #923230)
    LP: #1821130

 -- Rahul Amaram <email address hidden> Mon, 18 Mar 2019 01:00:34 +0530

Changed in twextpy (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for twextpy has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers