Ubuntu

mixer: Can't open device /dev/mixer, mixer volume and mute unavailable

Reported by Caleb Langeslag on 2010-09-28
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
tvtime (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tvtime

Can't get any audio, nor adjust it, not muted either. Stuck at 0. Able to get audio when using VLC. TV tuner card audio is through Line In ('audio out' port from the tuner card, bridged to a 'line in' port).

Worked out of the box just fine all versions prior to Ubuntu 10.10. My only difference is that I'm using an encrypted home partition, but that shouldn't matter.

And /dev/mixer doesn't exist.

Terminal output when using tvtime:
user@hostname:~$ tvtime
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/caleb870/.tvtime/tvtime.xml
mixer: Can't open device /dev/mixer, mixer volume and mute unavailable.
Thank you for using tvtime.

Super user (root) privileges also don't make a difference either.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: tvtime 1.0.2-6.1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Sep 28 17:29:34 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: tvtime

Caleb Langeslag (takyoji) wrote :
Bhupendra (bst-28) wrote :

I am having the same problem and for the time being I solved it by inserting audio system's cable in audio port of tv-tuner, instead in motherboard's port.This means that I can't listen to operating system but can listen to tv tuner.Mute(by pressing m) works in tv time when I do this, although volume control is not supported, because tv tuner is not sound card of mother board.

Andrés Alcarraz (alcarraz) wrote :

did someone find any workaround?

KTomek (tpk314) wrote :

1. Install the following packages: oss4-dkms, oss4-base, oss4-gtk.
2. Reboot the system.
3. To control a volume You can use ossxmix.
This workaround is not perfect. After reboot, You cannot control volume from within sound applet. In there, the sound card is replaced by 'dummy' device.

Bhupendra (bst-28) on 2010-10-20
tags: added: i386
Bhupendra (bst-28) wrote :

Hello, KTomek.

I did exactly what you said, but ossmixer says no mixers are available.In my opinion this problem is related to this bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/579300 in maverick.

KTomek (tpk314) wrote :

Hi.

You're right. This bug is a result of disabling OSS in maverick's kernel. The sound in my tvtime didn't work with newly installed maverick. But with oss4-* packages, the sound in tvtime started to work.

Bhupendra (bst-28) wrote :

Your workaround is working for mine too after restarting system.As you mentioned in #4 it has two drawbacks first volume applet is not useful, second we can't control volume with in tvtime but mute works.

Bhupendra (bst-28) wrote :

Update:- Audio don't work in gstreamer and similarly I can't listen to login and logout sound.In vlc I have to made oss mixer default device then audio worked.(If we follow #4)

Sarim Khan (sarim2005) wrote :

I'm also affected by this. I installed tvtime and surprised to see that sound in tvtime not working anymore :O :O. It worked flawlessly in lucid and before.

Is there any logical workaround available ?

Bhupendra (bst-28) wrote :

Just have a look at comment no. #28 at the location below

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/613809

After installing the tvtime package from ppa you need to launch tvtime with this command

tvtime --mixer=hw:0/Line

And mixer works.

Bhupendra about #10: Thank you!!! Flawless!!! That was the solution in Ubuntu 11.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tvtime (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers