saa7134 driver is not working on Lucid 2.6.32.19

Bug #559354 reported by smurf on 2010-04-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tvtime (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tvtime

I'm testing Lucid 2.6.32.19, everything is working fine except tvtime.
the problem resides in Saa7134 driver that is not working properly.
To obtain a full report of the problem I removed the driver with the command

sudo rmmod -f saa7134

then I reloaded the module with the command

sudo modprobe saa7134 card=59 tuner=56

in dmesg I find this

[ 4142.070028] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4142.170091] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4142.620022] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4142.720033] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4143.070027] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4143.170071] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4143.370032] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4143.470021] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4143.770048] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4143.880041] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4144.020027] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4144.120021] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4144.420022] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4144.470020] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4186.700030] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4186.800031] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4187.200024] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4187.300018] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4187.650027] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4187.700019] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4188.000031] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4188.100026] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4188.400022] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4188.450020] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4189.300025] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4189.400018] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 4189.550019] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=0
[ 4189.600017] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
[ 5937.830257] saa7130/34: v4l2 driver version 0.2.15 loaded
[ 5937.830469] saa7134[0]: found at 0000:01:08.0, rev: 1, irq: 19, latency: 64, mmio: 0xf9fffc00
[ 5937.830483] saa7134[0]: subsystem: 17de:7128, board: Kworld/Tevion V-Stream Xpert TV PVR7134 [card=59,insmod option]
[ 5937.830528] saa7134[0]: board init: gpio is c0407f
[ 5937.831552] input: saa7134 IR (Kworld/Tevion V-Str as /devices/pci0000:00/0000:00:08.0/0000:01:08.0/input/input7
[ 5937.831804] IRQ 19/saa7134[0]: IRQF_DISABLED is not guaranteed on shared IRQs
[ 5938.018224] saa7134[0]: i2c eeprom 00: de 17 28 71 10 28 ff ff ff ff ff ff ff ff ff ff
[ 5938.018234] saa7134[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018241] saa7134[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018247] saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018253] saa7134[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018259] saa7134[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018265] saa7134[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018270] saa7134[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018276] saa7134[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018282] saa7134[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018288] saa7134[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018294] saa7134[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018300] saa7134[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018306] saa7134[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018312] saa7134[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018318] saa7134[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 5938.018327] i2c i2c-1: Invalid 7-bit address 0x7a
[ 5938.060204] tuner 1-0060: chip found @ 0xc0 (saa7134[0])
[ 5938.060281] tea5767 1-0060: type set to Philips TEA5767HN FM Radio
[ 5938.130177] saa7134[0]: registered device video0 [v4l2]
[ 5938.130209] saa7134[0]: registered device vbi0
[ 5938.130238] saa7134[0]: registered device radio0
[ 5938.135462] saa7134_alsa: disagrees about version of symbol snd_ctl_add
[ 5938.135468] saa7134_alsa: Unknown symbol snd_ctl_add
[ 5938.135579] saa7134_alsa: disagrees about version of symbol snd_pcm_new
[ 5938.135581] saa7134_alsa: Unknown symbol snd_pcm_new
[ 5938.136189] saa7134_alsa: disagrees about version of symbol snd_pcm_stop
[ 5938.136191] saa7134_alsa: Unknown symbol snd_pcm_stop
[ 5938.136410] saa7134_alsa: disagrees about version of symbol snd_ctl_new1
[ 5938.136413] saa7134_alsa: Unknown symbol snd_ctl_new1
[ 5938.136971] saa7134_alsa: disagrees about version of symbol snd_pcm_lib_ioctl
[ 5938.136973] saa7134_alsa: Unknown symbol snd_pcm_lib_ioctl
[ 5938.137385] saa7134_alsa: disagrees about version of symbol snd_pcm_set_ops
[ 5938.137387] saa7134_alsa: Unknown symbol snd_pcm_set_ops
[ 5938.137708] saa7134_alsa: disagrees about version of symbol snd_pcm_hw_constraint_integer
[ 5938.137710] saa7134_alsa: Unknown symbol snd_pcm_hw_constraint_integer
[ 5938.138277] saa7134_alsa: disagrees about version of symbol snd_pcm_period_elapsed
[ 5938.138279] saa7134_alsa: Unknown symbol snd_pcm_period_elapsed
[ 5938.138379] saa7134_alsa: disagrees about version of symbol snd_pcm_hw_constraint_step
[ 5938.138381] saa7134_alsa: Unknown symbol snd_pcm_hw_constraint_step
[ 5938.139035] saa7134_alsa: disagrees about version of symbol snd_ctl_add
[ 5938.139041] saa7134_alsa: Unknown symbol snd_ctl_add
[ 5938.139152] saa7134_alsa: disagrees about version of symbol snd_pcm_new
[ 5938.139154] saa7134_alsa: Unknown symbol snd_pcm_new
[ 5938.139761] saa7134_alsa: disagrees about version of symbol snd_pcm_stop
[ 5938.139763] saa7134_alsa: Unknown symbol snd_pcm_stop
[ 5938.139983] saa7134_alsa: disagrees about version of symbol snd_ctl_new1
[ 5938.139985] saa7134_alsa: Unknown symbol snd_ctl_new1
[ 5938.140545] saa7134_alsa: disagrees about version of symbol snd_pcm_lib_ioctl
[ 5938.140547] saa7134_alsa: Unknown symbol snd_pcm_lib_ioctl
[ 5938.140960] saa7134_alsa: disagrees about version of symbol snd_pcm_set_ops
[ 5938.140962] saa7134_alsa: Unknown symbol snd_pcm_set_ops
[ 5938.141321] saa7134_alsa: disagrees about version of symbol snd_pcm_hw_constraint_integer
[ 5938.141324] saa7134_alsa: Unknown symbol snd_pcm_hw_constraint_integer
[ 5938.141892] saa7134_alsa: disagrees about version of symbol snd_pcm_period_elapsed
[ 5938.141894] saa7134_alsa: Unknown symbol snd_pcm_period_elapsed
[ 5938.141994] saa7134_alsa: disagrees about version of symbol snd_pcm_hw_constraint_step
[ 5938.141996] saa7134_alsa: Unknown symbol snd_pcm_hw_constraint_step
[ 5938.830038] saa7134 IR (Kworld/Tevion V-Str: unknown key: key=0x03 raw=0x03 down=1
luca@luca-desktop:~$

nothing works and tvtime crash suddenly when I try to see tv.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: tvtime 1.0.2-5ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 14d3c04c3faff90c66867581a0006b2d
CheckboxSystem: da9af3b901b5569a389df6337f3d812f
Date: Fri Apr 9 10:42:07 2010
InstallationMedia: Error: [Errno 13] Permiso denegado: '/var/log/installer/media-info'
ProcEnviron:
 LANG=es_PE.utf8
 SHELL=/bin/bash
SourcePackage: tvtime

smurf (luca-dgh) wrote :
Daniel T Chen (crimsun) wrote :

Note the following note about saa7134_alsa:

$ grep saa7134 /etc/modprobe.d/*
/etc/modprobe.d/alsa-base.conf:# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
/etc/modprobe.d/alsa-base.conf:install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
/etc/modprobe.d/alsa-base.conf:options saa7134-alsa index=-2

smurf (luca-dgh) wrote :

Daniel, can you explain what does it means?

Changed in tvtime (Ubuntu):
status: New → Confirmed
Bogoljub Popovic (bp21000) wrote :

I confirm this bug, after network upgrade from Karmic to Lucid RC1. On Karmic everything was OK

$ dmesg | grep saa7134
[ 18.491614] saa7134 0000:01:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 18.491942] input: saa7134 IR (V-Stream Studio TV as /devices/pci0000:00/0000:00:1e.0/0000:01:00.0/input/input6
[ 22.737107] saa7134 ALSA driver for DMA sound loaded

My TV card is recognized, however, tvtime output is not good:

$ tvtime -d /dev/video1
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/bogoljub/.tvtime/tvtime.xml
Found "USB Device 0x46d:0x802 : USB Audio (hw:1,0)"
Channels count non available

This USB device is integrated micrphone on Webcam Logitech C200 (Webcam is attached on /dev/video0)

Wheh launch tvtime I can hear sound but there is no any pictures.

Bogoljub Popovic (bp21000) wrote :

$ uname -r
2.6.32-21-generic

Problem isn't solved yet

Same problem i see on i386

Bogoljub Popovic (bp21000) wrote :

definitely, somethings wrong with saa7134 video driver, beacuse FM tuner on my card works just fine. we still waiting for workaround, or complete bugfix relase.

Bogoljub Popovic (bp21000) wrote :

Problem is bad tvtime package in lucid repositories.

I was manually dowloaded & instalied tvtime from here http://packages.ubuntu.com/karmic/x11/tvtime

And now on my machine tvtime works whitout problems.

Bogoljub Popovic (bp21000) wrote :

 I know what is the exact cause of my problem. Look here:
https://bugs.launchpad.net/ubuntu/+source/tvtime/+bug/552060

smurf (luca-dgh) wrote :

well, you marked this like a duplicate, but bug #552060 concerns about a problem with tvtime and usb audio devices, but I was reporting a problem with saa7134_alsa driver, that is not solved with the ppa tvtime package that is mentioned in thos bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers