Odd Flickering

Bug #1347394 reported by Evan Langlois on 2014-07-23
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tvtime (Ubuntu)

Bug Description

This is likely a bug in the au0828 driver since all tv apps I've tried show it. It sometimes fixes itself, but generally, its constant. The "glitch" (for lack of better term) happens every few seconds at irregular intervals. It looks like the TV is trying to scramble itself for a quick millisecond - sound goes out, too. Its viewable, but really annoying. I've tried all sorts of different kernels, tried moving it to another USB port and all sorts of stuff. Wish I could describe the bug better - I could likely make a video - don't think I'm fast enough to screen shot it when it messes up.

Its an HP branded Hauppage device:
Jul 22 21:24:26 Taro kernel: [ 19.570407] Registered device AU0828 [Hauppauge HVR950Q]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: tvtime 1.0.2-10ubuntu10
Uname: Linux 3.16.0-031600rc6-lowlatency x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jul 23 00:00:32 2014
InstallationDate: Installed on 2014-06-12 (40 days ago)
InstallationMedia: Ubuntu-Studio 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.3)
SourcePackage: tvtime
UpgradeStatus: No upgrade log present (probably fresh install)

Evan Langlois (uudruid74) wrote :

Now tvtime wait 3 seconds to next frame before deciding it's a driver problem. Not all devices (au0828) can free wheel, so tvtime should support such devices without blocking the GUI. A solution would be if no frame arrives within 100 ms (instead of 3 sec), then timeout and give the GUI the chance to update itself.

Later, next week I will correct this problem.

Evan Langlois (uudruid74) wrote :

Whats the status on this? Is there a GIT tree for patches or anything? The problem went away for a long time and I recently had the bug hit again. I'm wondering if it is a conflict with the video card. I'm using an ATI Radeon Mobile (one of those embedded into the CPU things) and I was using the ATI binary drivers for a long time ... so maybe they don't have this problem and the open-source do?

I was trying to test this by installing the binary drivers, but my current distro has some issues with the install (won't compile against latest kernel). So .. when the ATI drivers are fixed, I'll get this tested.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers