Ubuntu

Ace game not working when localized

Reported by Geir Hauge on 2008-04-21
6
Affects Status Importance Assigned to Milestone
Tuxmath
Undecided
auto-tuxmath-devel
tuxmath (Debian)
Fix Released
Unknown
tuxmath (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: tuxmath

When run with "LANG=nb_NO.utf8 tuxmath", nothing happens when "Spill" -> "Romsjef" is selected ("Play Arcade Game" -> "Ace" in english). When run in terminal, "MC_StartGame() failed!" is output when that menu choice is selected.

Running with "LANG= tuxmath" works as expected.

This is tuxmath version 1.5.8 on ubuntu 8.04rc

Geir Hauge (geir-hauge) on 2008-04-21
description: updated
Caroline Ford (secretlondon) wrote :

I can't reproduce, but I guess I need to have nb_NO language pack installed.

What actually happens? Does the game just not do anything, or does it crash?

Does it do this for any other menu options?

Caroline Ford (secretlondon) wrote :

I can confirm this, and it only seems to do it for that option.

I get this in the console:

MC_StartGame() failed!
game_initialize() failed!

The screen blinks, and stays on the menu.

Changed in tuxmath:
importance: Undecided → Medium
status: New → Confirmed
Geir Hauge (geir-hauge) wrote :

I got the same result when I tried with one of the other languages tuxmath is transleted to, czech. So it's not limited to norwegian.

Changed in tuxmath:
status: Unknown → New
Caroline Ford (secretlondon) wrote :

Upstream can't reproduce and hence presume it is fixed in their version.

They are planning on making a new release which I'll try and get backported.

Changed in tuxmath:
status: New → Fix Released
kache (sergiopadure) wrote :

Same problem with the italian localization.

LaserJock (laserjock) wrote :

Fixed in Intrepid since 1.6.3-3

Changed in tuxmath:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.