can not upgrade to version 1.2-8ubuntu1

Bug #811096 reported by Marco Biscaro on 2011-07-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Medium
Micah Gersten

Bug Description

Running oneiric, fully updated (except by tuxguitar).

Tuxguitar version 1.2-8ubuntu1 depends on package libswt-mozilla-gtk-3.6-jni, which is not available in ubuntu repository.

A workarrund is manually install that package (and its dependencies) from debian sid and then upgrade tuxguitar.

Related branches

Micah Gersten (micahg) wrote :

I just filed bug #817817 to sync tuxguitar from Debian that will fix this issue.

Changed in tuxguitar (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: New → Triaged
Micah Gersten (micahg) wrote :

Actually, the version from sid just added a broken dependency on xulrunner-1.9.1, will upload a fix shortly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 1.2-9ubuntu1

---------------
tuxguitar (1.2-9ubuntu1) oneiric; urgency=low

  * Add back changes from 1.2-8ubuntu2 that were accidentally dropped
    - add debian/patches/04-no-mozilla.patch
    - drop xulrunner-1.9.1 from Depends
  * This also finally fixes the installation issue mentioned in
    (LP: #811096)
 -- Micah Gersten <email address hidden> Mon, 15 Aug 2011 16:49:39 -0500

Changed in tuxguitar (Ubuntu):
status: Triaged → Fix Released

On Mon, 15 Aug 2011 21:49:25 -0000, Micah Gersten wrote:

> Actually, the version from sid just added a broken dependency on
> xulrunner-1.9.1,

I guess you are referring to 1.2-9?

> will upload a fix shortly.

Or try 1.2-9.1 from sid :)

Cheers,
gregor

--
 .''`. Homepage: http://info.comodo.priv.at/ - PGP/GPG key ID: 0x8649AA06
 : :' : Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `' Member of VIBE!AT & SPI, fellow of Free Software Foundation Europe
   `- NP: Fleetwood Mac: Sara

Micah Gersten (micahg) wrote :

1.2-9.1 just adds a better xulrunner dependency for Debian, but Ubuntu no longer has xulrunner, so I skipped it

gregor herrmann (gregoa) wrote :

On Mon, 15 Aug 2011 22:11:19 -0000, Micah Gersten wrote:

> 1.2-9.1 just adds a better xulrunner dependency for Debian, but Ubuntu
> no longer has xulrunner, so I skipped it

Oh, I missed that piece; sorry for the noise.

Cheers,
gregor

--
 .''`. Homepage: http://info.comodo.priv.at/ - PGP/GPG key ID: 0x8649AA06
 : :' : Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `' Member of VIBE!AT & SPI, fellow of Free Software Foundation Europe
   `- NP: Pink Floyd: Time

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers