not everything is display correctly

Bug #455615 reported by Marcin Niechcial on 2009-10-19
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tuxguitar (Debian)
New
Unknown
tuxguitar (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: tuxguitar

in polish
podczas uruchamiania programu splashscreen nie jest wyswietlany w całości, a następnie sciezki instrumentów również się nie wyświetlają, oprócz kilku taktów pierwszego instrumentu, nie wiem co jest za to odpowiedzialne ale w poprzedniej wersji w jaunty 9.04 problem nie występował

I do not know how to describe it in English but will try to help translate.google.com

when I start tuxguitar splashscreen isnot displayed in its entirety, then the path of instruments do not show all tracks, except for a few bars of the first instrument, I do not know what is responsible for it but the previous version of the jaunty 9.04 issue does not occur

now i'm using karmic after dist-upgrade from jaunty, i'm tryin reinstall but with no effect

ProblemType: Bug
Architecture: i386
Date: Mon Oct 19 19:23:00 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: tuxguitar 1.1-1ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: tuxguitar
Uname: Linux 2.6.31-14-generic i686

Marcin Niechcial (bastard79) wrote :
MasterProg (masterprog) wrote :

I'm experiencing the same problem since the time I upgraded my Ubuntu to Karmic beta.

Julian (julian-casadesus) wrote :

It happens with SWT and GTK versions higher than 2.17.
SWT team fixed this problem on 3.6 develpment version.

You can try download swt 3.6M2 for linux-gtk-[your_arch]
from http://www.eclipse.org/swt/
uncompress the downloaded file and exec on a terminal:

export CLASSPATH=/Folder_Where_Is_SWT/swt.jar
tuxguitar

The problem with the splash screen may still be there, but the other issues will be solved.

MasterProg (masterprog) wrote :

Thanks, it works as expected now (including splash screen).

Changed in tuxguitar (Ubuntu):
status: New → Confirmed
Onkar Shinde (onkarshinde) wrote :

@Julian,

Do you have pointer to the upstream svn revision that fixed this bug? I will try to backport the change to karmic version of swt-gtk.

Julian (julian-casadesus) wrote :

@Onkar,
No i don't have idea at what SVN revision was it fixed.
I can only tell you that the bug is fixed at GC class:

org.eclipse.swt.graphics.GC.java, At "initCairo()" method
where cleary, there is an IF condition checking if GTK version is lesser than 2, 17, 0
I have tested override this methood content to 3.5 version of SWT, and the problem was gone.

However after write this post, i saw that there are other problems than graphics, ( also fixed on 3.6 )
but not sure where are they fixed.

These other problems, are also reproducible in eclipse (not only in tuxguitar).
some buttons just don't works with mouse clicks. ( yes with keyboard )

In tuxguitar you can reproduce the problem:
* Menu: Tools -> Plugins
* Select any plugin, and click "Info" button.
It only gain focus, but listeners are not fired, but if you press SPACE or ENTER listeners work.

In eclipse ( may depend the version, i don't have it from repositories )
* Just open a source file, and press "Ctrl + F"
* Type a search text, and click "Find" button..

I found problems on some other eclipse buttons too. but it's hard to give you steps to reproduce them.

I had planned to release tuxguitar 1.2 this weekend but now i don't have idea what to do with this problem..
It seems that SWT versions lesser than 3.6, just can't coexist with new GTK versions.

@MasterProg,
The splash screen sometimes works.... but sometimes don't, even in 3.6
i don't know exactly the reason, but i was able to fix it from tuxguitar code calling an update inmediatly after the windows opens.
and this fix yes works for lesser SWT versions of GTK.

Onkar Shinde (onkarshinde) wrote :

Subscribing Adrian. He is more familiar with swt-gtk than me.

Dave Roberts (drob-blueyonder) wrote :

I removed Tuxguitar 1.1 and installed Tuxguitar 1.2 from the Tuxguitar website.
All the above issues appear to be fine in 1.2, display, buttons etc.
I had all of the above problems with V1.1.
The only slight issue I had with 1.2 was with my netbook, the staff lines were not displaying ,I fixed from a thread on the Tuxguitar forums.
Tuxguitar 1.2 installed fine on my desktop.
I only use the program as a playback tool,but so far 1.2 is a solution for me.

Julian (julian-casadesus) wrote :

Dave, 1.2 deb package from official website, includes swt 3.6M3 library (just because this issue) as default
but i don't think that the future repository version will include it, because swt package already exists in repositories.
So in other words, this problem will not be solved until a swt package upgrade.

Dave Roberts (drob-blueyonder) wrote :

Julian don't know wether this is relavent but I did a search in Synaptic post install of TG1.2 for "swt"and the package listed as installed is libswt-gtk.3.4*.

Does the TG1.2 package I installed contain within it the 3.6M3 library and is this the library TG1.2 is using?

Julian (julian-casadesus) wrote :

Yes, it contains 3.6M3 inside.
To don't make conflicts with repository version of SWT, this .deb package have SWT library in a different place.

The file included in the package is at: "/usr/share/java/tuxguitar/swt.jar"
while repository version, is at "/usr/share/java/swt.jar"

You can check what swt.jar is used by running: tuxguitar -i

or you could uninstall libswt-* packages, and tuxguitar will still works.

Changed in tuxguitar (Debian):
status: Unknown → New
cyril (ivi610) wrote :

for me I did this :
and now notes heads are displayed correctly

http://tuxguitar.herac.com.ar/forum/5/1331/no-lines-for-notes-and-tabs/

"
Morii, this topic sames to be related to same problem that this one: http://www.tuxguitar.com.ar/forum/5/1437/1-2-fingerboard-no-strings/

Lets post new comments in this one.

I'll say same as my last post in the other topic.

Try to open with any text editor the file:
~/.tuxguitar-1.2/config.properties

(if somebody don't knows.. ~/ means the user's home folder.. e.g: /home/[username]/ )

* It's important to edit this file when tuxguitar is closed.

And try append this line:
painter.force-os-defaults=true

Save the file, and run the application..
so does it fix something ?"

anarsoul (anarsoul) wrote :

I've created PPA with updated version of libswt (it's cause of a problem), just upgrade libswt from my ppa and problem should gone away.

sudo apt-add-repository ppa:anarsoul/anarsoul
sudo apt-get update
sudo apt-get upgrade

Micah Gersten (micahg) wrote :

Marking this triaged since the issue is known, although, I don't think we can "fix" this until swt-gtk 3.6 is packaged.

Changed in tuxguitar (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
anarsoul (anarsoul) wrote :

Actually, problem is fixed in swt-gtk-3.5.2, so if it's possible to bump version in releases with swt-gtk-3.5.x it's better to do this. No need in swt-gtk-3.6 for these releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.