Please build tuxguitar with xulrunner 1.9.1 for karmic

Bug #424727 reported by Matt Drake on 2009-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tuxguitar

Right now tuxguitar depends on the old xulrunner 1.9 and should be updated to the new xulrunner 1.9.1 that will be released with karmic.

Related branches

Hippu (teemu-heinamaki) wrote :

Attached is a patch which fixes this and #311319

Changed in tuxguitar (Ubuntu):
status: New → Confirmed
Matt Drake (mattduckman) wrote :

very nice, thanks hippu. Your patch worked for me and solved both bugs.

Daniel Holbach (dholbach) wrote :

Hum... isn't the xul version "1.9.1.2" very explicit? Won't it break with whatever the next xul version is going to be?

Alexander Sack (asac) wrote :

- t="/usr/lib/xulrunner-1.9"
+ t="/usr/lib/xulrunner-1.9.1.2"
     test -r "$t/libxpcom.so" && d="$t"
- t="`dpkg -L xulrunner-1.9 |grep libxpcom.so|cut -d '/' -f-4`"
+ t="`dpkg -L xulrunner-1.9.1 |grep libxpcom.so|cut -d '/' -f-4`"

Thats kind of ugly approach. Better approach is:

 /usr/lib/xulrunner-`xulrunner-1.9.1 --gre-version`

Changed in tuxguitar (Ubuntu):
status: Confirmed → Incomplete
Alexander Sack (asac) wrote :

please re-subscribe ubuntu-universe-sponsors after addressing this.

Hippu (teemu-heinamaki) wrote :

Thanks for pointing out the mistakes, here is the fixed one.

Hippu (teemu-heinamaki) on 2009-09-19
Changed in tuxguitar (Ubuntu):
status: Incomplete → Confirmed
Alexander Sack (asac) wrote :

thx. sponsoring.

Changed in tuxguitar (Ubuntu):
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :

hmm .... your changelog was for jaunty not for karmic. fixed that locally before upload now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 1.1-1ubuntu1

---------------
tuxguitar (1.1-1ubuntu1) karmic; urgency=low

  * Use Java Sound API and Gervill by default (LP: #311319)
  * Changed maintainer to MOTU developers
  * Depend on xulrunner 1.9.1 instead of 1.9 (LP: #424727)

 -- Teemu Heinaemaeki <email address hidden> Wed, 5 Sep 2009 11:39:51 +0300

Changed in tuxguitar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers