TuxGuitar must be version 1.1

Bug #366476 reported by Pablo Estigarribia on 2009-04-25
2
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Undecided
Philippe Coval

Bug Description

Binary package hint: tuxguitar

Actually tuxguitar is not working fine in ubuntu since pulseaudio is working in Ubuntu, see:
https://bugs.launchpad.net/ubuntu/+source/timidity/+bug/210472

It makes Ubuntu too hard to get TuxGuitar working fine for some users, the best solution that we see is to include latest version of tuxguitar or at least leave a message in tuxguitar package to recomend users to download latest version from http://tuxguitar.com.ar/download.html
There users can get a .deb package that works fine for Ubuntu, important thing to note is users should remove tuxguitar-1.0 package before install tuxguitar 1.1 - I got error message trying to update because there are some differences in packaging I think.

Another note that should be wrote is, users should change midi port to Gervill inside Preferences -Sound after open TuxGuitar first time, It's necessary to get Tux Guitar working totally well.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: tuxguitar 1.0-1ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_UY.UTF-8
 SHELL=/bin/bash
SourcePackage: tuxguitar
Uname: Linux 2.6.27-11-generic x86_64

Related branches

Pablo Estigarribia (pablodav) wrote :
Philippe Coval (rzr) wrote :

I am working on this , there is a version in my PPA ... i plan to upload to debian 1st , but feedback on testing is welcome.

Changed in tuxguitar (Ubuntu):
assignee: nobody → rzr
Pablo Estigarribia (pablodav) wrote :

Ok, I'm testing it now. I installed from your PPA:
dpkg -s tuxguitar
Package: tuxguitar
Status: install ok installed
Priority: optional
Section: sound
Installed-Size: 5728
Maintainer: Philippe Coval <email address hidden>
Architecture: all
Version: 1.1-0ubuntu0~rzr1
Depends: openjdk-6-jre | java-gcj-compat | sun-java6-jre | sun-java5-jre | java-virtual-machine, libitext-java, libswt-gtk-3.4-java | libswt3.2-gtk-java, libswt-cairo-gtk-3.4-jni | libswt3.2-gtk-java, libswt-mozilla-gtk-3.4-jni | libswt3.2-gtk-java, xulrunner-1.9
Recommends: tuxguitar-alsa (= 1.1-0ubuntu0~rzr1), tuxguitar-oss (= 1.1-0ubuntu0~rzr1)
Suggests: tuxguitar-jsa (= 1.1-0ubuntu0~rzr1), lilypond
Description: Multitrack guitar tablature editor and player (gp3 to gp5)
 TuxGuitar is a multitrack Guitar tablature editor and player.
 It can open GP3, GP4, and GP5 files and exports in MIDI and PDF.
Homepage: http://www.tuxguitar.com.ar

But it's not working fine, from Preferences -> sound. Gervill option does not appears as a Midi Port, so I can't hear anything..

Philippe Coval (rzr) wrote :

I'll double check but IICR when I installed tuxguitar-jsa grevill was displayed too

Pablo Estigarribia (pablodav) wrote :

You are in true...

Now I installed tuxguitar-jsa and gervill is displayed and working fine with this...

So maybe to fix this tuxguitar-jsa should be a dependency and used by default for tuxguitar, or some note in Description for tuxguitar package should be added about this.

Philippe Coval (rzr) wrote :

Added in README.Debian for release in debian/incoming
I'll request a merge once tested in sid

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 1.1-1

---------------
tuxguitar (1.1-1) unstable; urgency=low

  * New Upstream Release (Closes: #489859) (LP: #366476)
  * Merged patch : tuxguitar_1.0.dak-1ubuntu1.patch
  * debian/README.txt
    - suggests to install tuxguitar-jsa

 -- Onkar Shinde <email address hidden> Mon, 11 May 2009 13:14:27 +0100

Changed in tuxguitar (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers