Print and Help options require SWT 3.3+

Bug #250137 reported by teledyn on 2008-07-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tuxguitar

The tuxguitar in the Hardy repositories is incomplete; the program will not print the tabs and cannot access the help files because Ubuntu "have an oldest (3.2) "swt" library on repositories, while GTK printer was implemented since swt-3.3" (http://www.tuxguitar.com.ar/forum/5/652/problem-printing-my-tabs/ ;) -- I'm not certain if the help-button exceptions printed to the console would be solved by this, but that is a small problem compared to having no print function :(

the workaround is to print via lilypond, but that output is non-configurable and ugly. the native typesetting does a much nicer job
(at least on my one try at using it)

according to the tuxguitar site, a potential fix is to rebuild the Ubuntu package from the current release package where the required SWT is included.

Philippe Coval (rzr) wrote :

Hi,

Yes we know that but swt3.2 was preferred at that time (swt 3.3 came with new
bugs) but now 3.4 is out, so I'll may drop 3.2 on next release ..

Regards

I figured there was a reason like this, but thought I'd post it anyway
so others might find it and know what to do.

do you recommend installing the original-source kit to fix this, or
will there be a hardy backport of 3.4?

--
Gary Lawrence Murphy <garym at teledyn.com> =============================
blog.teledyn.com -==- improvisato.blogspot.com -==- bandbook.blogspot.com
======================= the Universe is smarter than we are (Alan Watts)

Philippe Coval (rzr) wrote :

Current version in debian unstable may close this bug, can you double check before it is merged back in jaunty ?
--
http://rzr.online.fr/q/tuxguitar

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 1.0.dak-1ubuntu1

---------------
tuxguitar (1.0.dak-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable.
  * debian/control
    - Replace build dependency openjdk-6-jdk with default-jdk.
    - Remove unnecessary build dependencies gcj, java-gcj-compat-dev,
      sun-java5-jdk, icedtea-java7-jdk, libswt3.2-gtk-java.
    - Replace runtime dependency openjdk-6-jre with default-jre.
    - Remove unnecessary runtime java-gcj-compat, sun-java6-jre, sun-java5-jre,
      libswt3.2-gtk-java. Replaced java-virtual-machine with java2-runtime.
      (LP: #250137)
  * debian/rules
    - Set JAVA_HOME to the value corresponding to default-jdk.
  * misc/tuxguitar.sh
    - Ubuntu specific change for correct path of xulrunner-1.9 installation.

 -- Onkar Shinde <email address hidden> Tue, 13 Jan 2009 00:52:49 +0530

Changed in tuxguitar:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers