TuxGuitar cannot find Java

Bug #212207 reported by Lex
16
Affects Status Importance Assigned to Milestone
tuxguitar (Debian)
Fix Released
Unknown
tuxguitar (Ubuntu)
Wishlist
Hippu

Bug Description

Binary package hint: tuxguitar

Users are getting following messages and TuxGuitar won't start.

/usr/bin/tuxguitar: 21: /usr/local/opt/java/jre/bin/java: not found

Found on Ubuntu 8.04 [Hardy]

Related branches

Revision history for this message
Hippu (teemu-heinamaki) wrote :

Do you use Sun Java 6 or something else?

Revision history for this message
Philippe Coval (rzr) wrote :

Hi,

Have you installed other software than those packaged in hardy ?

Please can you report :
  which java
  locate java
  etc

BTW, there is a uptodate version of tuxguitar in my PPA repository,
please try it and report :
 $ DEBUG=1 tuxguitar

Thanks

Revision history for this message
Lex (lexx) wrote :

I haven't install any Java manually, so I am using default installed version.
There should be package dependency if TuxGuitar requires Sun Java 6.

$ which java

/usr/bin/java

$ java --version

java version "1.5.0"

gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)

Copyright (C) 2007 Free Software Foundation, Inc.

This is free software; see the source for copying conditions. There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Revision history for this message
Lex (lexx) wrote :

I am able to run TuxGuitar but first I must manually install sun-java6-jre package.

I look at TuxGuitar (0.9.1.4ubuntu1) dependencies and it contains following:

sun-java6-jre | java2-runtime

I don't understand it, but this still don't enforce installation of Sun Java.(?)

Revision history for this message
Lex (lexx) wrote :

This is same as bug #183562.

Hippu (teemu-heinamaki)
Changed in tuxguitar:
assignee: nobody → teemu-heinamaki
status: New → In Progress
Revision history for this message
Philippe Coval (rzr) wrote : Re: [Bug 212207] Re: TuxGuitar cannot find Java

Lex wrote:
> I haven't install any Java manually, so I am using default installed version.
> There should be package dependency if TuxGuitar requires Sun Java 6.
>
well java5 is supported too and probally icedtea too

> gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)
>
>

Workaround :

  sudo aptitude install sun-java6-jre
  sudo update-alternatives --config java

I'll double check it on next release

--
 # mailto:rzr[a]users.sf.net -- gpg:0x467094BC
 # http://rzr.online.fr/contribs.htm -- Libre Software Addict
 # xmpp:rzr[a]jabber.fr -- sip:rzr[a]ekiga.net

Revision history for this message
Hippu (teemu-heinamaki) wrote :

It seems that you have for some reason gij (GNU interpreter for Java) installed.

The line in dependencies:

sun-java6-jre | java2-runtime

means that it will install sun-java6-jre, unless the computer has one of these packages installed: http://packages.ubuntu.com/hardy/java2-runtime, however tuxguitar doesn't work with some of those packages (gij for example).

I hope that made sense.

I'm working on a patch that fixes this.

Revision history for this message
Lex (lexx) wrote :

Yes, dependencies notation is making sense.

However I haven't installed package sun-java6-jre or package java2-runtime (could not find second one in repository at all), so dependency should be triggered and Sun Java should be installed. Is this right?

I am probably wrong with java2-runtime package.
How can I check if I have it? (I tried just Synaptic.)

Thanks for quick response and great help!

Revision history for this message
Hippu (teemu-heinamaki) wrote :

Java2-runtime is a virtual package and it "doesn't exist"

Quote from Debian policy (http://www.debian.org/doc/debian-policy/ch-binary.html#s-virtual_pkg):

"Sometimes, there are several packages which offer more-or-less the same functionality. In this case, it's useful to define a virtual package whose name describes that common functionality. (The virtual packages only exist logically, not physically; that's why they are called virtual.) The packages with this particular function will then provide the virtual package. Thus, any other package requiring that function can simply depend on the virtual package without having to specify all possible packages individually. "

This means you "have" java2-runtime if you have one of following packages:
gij-4.1
j2re1.4
java-gcj-compat
openjdk-6-jre
sun-java5-jre
sun-java6-jre

Revision history for this message
Hippu (teemu-heinamaki) wrote :

I've got the patch ready, subscribing ubuntu-universe-sponsors.

Revision history for this message
Hippu (teemu-heinamaki) wrote :

Thay debdiff also makes openjdk/icedtea tuxguitar's preferred interpreter and compiler.

Changed in tuxguitar:
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
Revision history for this message
Hippu (teemu-heinamaki) wrote :

Added a mention of this bug to the changelog.

Changed in tuxguitar:
assignee: teemu-heinamaki → nobody
Revision history for this message
Philippe Coval (rzr) wrote :

hi,

sun-java6-jre is prefered else I am afraid the sound synth will be disabled (it's missing from opensource jvm's)

Unless you use debian's 0.9.99~1.0rc2-1 w/ alsa or oss plugin

Thanks anyway

Revision history for this message
Hippu (teemu-heinamaki) wrote :

You're right, my mistake. I'll give this a another shot tomorrow.

Or should we try to get a feature freeze for 0.9.99~1.0rc2-1? It doesn't seem to have any problems.

Revision history for this message
Philippe Coval (rzr) wrote :

As you want , but let me tell you that upcoming version 0.9.99~1.0rc3 and more is relying on swt3.3 which is not present in hardy, so if it's not too late rc2 would be appreciated by users ...

Regards

Revision history for this message
Hippu (teemu-heinamaki) wrote :

Here is the new debdiff without the openjdk stuff.

And it would probably the best to just backport the new version once hardy comes out.

Morten Kjeldgaard (mok0)
Changed in tuxguitar:
assignee: nobody → mok0
importance: Undecided → Wishlist
status: Confirmed → In Progress
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

I get a FTBFS on this package on an sbuilder just updated. Here's the crucial bit from the log:

Selecting previously deselected package libswt3.2-gtk-java.
Unpacking libswt3.2-gtk-java (from .../libswt3.2-gtk-java_3.2.2-5ubuntu2_amd64.deb) .
..
Errors were encountered while processing:
 /var/cache/apt/archives/sun-java6-bin_6-05-0ubuntu1_amd64.deb
 /var/cache/apt/archives/sun-java6-jre_6-05-0ubuntu1_all.deb
 /var/cache/apt/archives/sun-java6-jdk_6-05-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt-get failed.
Package installation failed

Changed in tuxguitar:
assignee: mok0 → nobody
status: In Progress → Incomplete
Revision history for this message
Philippe Coval (rzr) wrote :

> Errors were encountered while processing:
> /var/cache/apt/archives/sun-java6-bin_6-05-0ubuntu1_amd64.deb

Is this a s/p/builder issue or a tuxguitar one ?

Maybe this workaround will help you :

  http://rzr.online.fr/q/pbuilder

Morten Kjeldgaard (mok0)
Changed in tuxguitar:
status: Incomplete → Confirmed
Changed in tuxguitar:
status: Unknown → Fix Released
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Debian has version 0.9.99~1.0rc4-1, so you should merge it instead (probably, you will want to wait for http://bugs.debian.org/481728 to be solved, if applicable). Please, resubscribe u-u-s when a new debdiff will be available for review, thanks!

Changed in tuxguitar:
assignee: nobody → teemu-heinamaki
status: Confirmed → In Progress
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Also, new Debian version will close bug #176979 too.

Revision history for this message
Philippe Coval (rzr) wrote :

Hi,

FYI, tuxguitar-1.0 is about to be released ...
At the same time debian import freeze is about to happend,

So here are my plans, I will upload a new revision to sid next week (RC or 1.0)
it will close http://bugs.debian.org/481728

Finally it can be imported back in intrepid

Please hold a few days, then import the current one

Later

ps: until that day you can also check the tuxguitar-snapshot version in my PPA and look for upstream bugs

Revision history for this message
Philippe Coval (rzr) wrote :

As promised 1.0 is now in debian and about to be synched too :

https://bugs.edge.launchpad.net/ubuntu/+source/tuxguitar/+bug/242416

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 1.0-1

---------------
tuxguitar (1.0-1) unstable; urgency=low

  * New upstream release (Closes: #481728) also (LP: #176979, #212207)

tuxguitar (0.9.99~1.0rc4-1) unstable; urgency=low

  * New Upstream release (1.0-rc4 retitled to 0.9.99~1.0rc4)
  * Fixed plugin loading bug by hardcoding path (Closes: #479668)

tuxguitar (0.9.99~1.0rc3-1) unstable; urgency=low

  * New Upstream release (1.0-rc3 retitled to 0.9.99~1.0rc3)
  * Updated startup script from upstream
  * debian/control now build with gcj by default not openjdk (Closes: #474410)

tuxguitar (0.9.99~1.0rc2-2) unstable; urgency=low

  * ADD: Support compilers and jvm's based on classpath
  * FIX: arch vs indep for non i386 arch (closes: #474410)

tuxguitar (0.9.99~1.0rc2-1) unstable; urgency=low

  * ADD: New Upstream release (1.0-rc2 retitled to 0.9.99~1.0rc2)
  * FIX: Only on sun-java6 supported (Closes: #466986)
  * FIX: Compile in 1.4 format (Closes: #466038)
  * ADD: plugins ALSA and OSS (natives JNI) (Closes: #439669)

 -- Philippe Coval <email address hidden> Thu, 26 Jun 2008 11:17:05 +0100

Changed in tuxguitar:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.