Tuxguitar isn't building, missing dependency

Bug #176736 reported by Hippu on 2007-12-16
8
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Medium
Emmet Hikory

Bug Description

http://launchpadlibrarian.net/10558450/buildlog_ubuntu-hardy-i386.tuxguitar_0.9.1-3_MANUALDEPWAIT.txt.gz (Link to the build log)

Tuxguitar isn't building because:
"E: Package libswt-gtk-3.2-java has no installation candidate
Package libswt-gtk-3.2-java is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
apt-get failed."

However, ubuntu has libswt3.2-gtk-java in it's repositories when i tried replacing it with that in debian/control the build fails because it can't import the swt libraries. I suspect that this happens because, the library installs itself to /usr/lib/java/ when make expects to find them in /usr/share/java.

I can't simply change the makefile because that would break the other dependency "libitext-java" which is in /usr/share/java as tuxguitar expects it to be

The relevant snip from GNUmakefile:
# dependencies
JAR_DIR?=/usr/share/java/
SWT_JAR?=${JAR_DIR}swt.jar
ITEXT_JAR?=${JAR_DIR}itext.jar

Hippu (teemu-heinamaki) wrote :

Here is a debdiff that changes the /debian/control dependencies

Changed in tuxguitar:
assignee: nobody → teemu-heinamaki
Hippu (teemu-heinamaki) wrote :

And here is the makefile

Jochen Kemnade (jochenkemnade) wrote :

Could you please modify the java depends to make it run with icedtea?

-Depends: sun-java6-jre | sun-java5-jre, libswt-gtk-3.2-java, libitext-java
+Depends: sun-java6-jre | sun-java5-jre | icedtea-java7-jre , libswt3.2-gtk-java, libitext-java

I checked that it runs fine using the icedtea jre. I'm not sure, whether it also builds using the icedtea jdk.

Maybe the dependencies could even be altered from the specific java distribution packages to java-runtime | java1-runtime | java2-runtime?

Jochen Kemnade (jochenkemnade) wrote :

I just tried building the package using the icedtea jdk, and it works. As to the Makefile, I hardcoded the location of the swt.jar:
-SWT_JAR?=${JAR_DIR}swt.jar
+SWT_JAR?=/usr/lib/java/swt.jar
Of course, this is a quick and dirty fix, but it makes the package build. Debdiff attached.

Jochen Kemnade (jochenkemnade) wrote :

oops, wrong file.

Hippu (teemu-heinamaki) on 2007-12-17
Changed in tuxguitar:
status: New → In Progress
Hippu (teemu-heinamaki) wrote :

Wohoo! It works, but using virtual packages would certainly make more sense.
I don't know much about Java but I would guess that it needs java2-compiler as a build dependency and java2-runtime as a general dependency. I'll test how this works.

Hippu (teemu-heinamaki) wrote :

Lintian and pbuilder complained about that, we need one real package too.

Hippu (teemu-heinamaki) wrote :

I finished the patch.

Adrien Cunin (adri2000) wrote :

I guess you are seeking sponsoring (even though ubuntu-universe-sponsors is not subscribed).
I have not checked if the patch actually works or not, but looking at the debdiff: should be hardy and not gutsy in debian/changelog; the changes should be described more accurately (what was changed and why, maintainer change) and a reference to this bug should be made (LP: #176736).
Please subscribe u-u-s when these issues are fixed. Thanks.

Hippu (teemu-heinamaki) wrote :

Got those fixed, let me know if there are more.

Hippu (teemu-heinamaki) on 2007-12-20
Changed in tuxguitar:
status: In Progress → Confirmed
assignee: teemu-heinamaki → nobody
Emmet Hikory (persia) on 2008-01-02
Changed in tuxguitar:
assignee: nobody → persia
importance: Undecided → Medium
status: Confirmed → In Progress
Emmet Hikory (persia) wrote :

Uploaded. Thanks. If the package could be modified to build without depending on anything in multiverse, that would be even better.

Changed in tuxguitar:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tuxguitar - 0.9.1-3ubuntu1

---------------
tuxguitar (0.9.1-3ubuntu1) hardy; urgency=low

  * Modified debian/control and GNUmakefile to make building work (LP: #176736)
  * changed mantainer to Ubuntu MOTU Developers.

 -- Teemu Heinaemaeki (Hippu) <email address hidden> Sun, 16 Dec 2007 00:02:48 +0200

Changed in tuxguitar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers