tuxguitar-oss installation conflict between osspd and oss-compat

Bug #1358235 reported by Adrien Loxq on 2014-08-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Undecided
Unassigned

Bug Description

I'm currently running 14.04.1 and I try to install tuxguitar (version 1.2-17) from official repository.
This package recommends tuxguitar-alsa and tuxguitar-oss.

The package tuxguitar-oss depends on package osspd which is marked as conflict with oss-compat but oss-compat recommends osspd. We have here a circular dependency/conflict.

By default, doing "aptitude install tuxguitar" fails with conflict on oss-compat.

On my computer I fixed the problem doing "aptitude install tuxguitar tuxguitar-alsa --without-recommends"

The default behaviour of aptitude is to install recommended packages which prevents the installation of the package tuxguitar without the --without-recommends option.

I think, tuxguitar-alsa and tuxguitar-oss shouldn't be both recommended.

Description: Ubuntu 14.04.1 LTS
Release: 14.04

packages versions:
tuxguitar: 1.2-17
tuxguitar-oss: 1.2-17
osspd: 1.3.2-5
oss-compat: 6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tuxguitar (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers