fluidsynth sound problem + freeze when stopping software

Bug #1242457 reported by olivier carbon on 2013-10-20
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tuxguitar (Ubuntu)
Undecided
Unassigned

Bug Description

Here are the 3 main bugs I encoutered since my upgrading to saucy :
1. The sound crackles after having writen notes, whereas before this operation the sound is great.
note : I use the fluidsynth plugin (the only one that work on my desktop).

2. When the previous bug arises, it becomes impossible to close the software. This one is frozen, and I have to kill the "java" process (killing the "tuxguitar" process is not sufficient).

3. this third bug have not link with those above. When selecting the "cancel' button of the parameter window, the software crashes on his own.

General note: The software worked fine under raring, but downgrading to tuxguitar 1.2-14 doesn't fix these bugs.

Thanks for your help

System : Kubuntu 13.10
Packages: tuxguitar 1.2-15

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tuxguitar (Ubuntu):
status: New → Confirmed
Zhart (zhart) wrote :

I use qsynth (gui for fluidsynth) and experiencing the same problem (the sound crackles) when trying to output the sound via fluidsynth (in vmpk or any other program).

Zhart (zhart) wrote :

Sorry, forgot to add:
System: Ubuntu 13.10 amd64
Packages: qsynth 0.3.6-2+fixed1, flyidsynth 1.1.6-2+nopulse1~raring1, vmpk 0.4.0-3+jack3~raring3.

In Ubuntu 13.04 everything worked perfectly, the problems started after upgrade.

Zhart (zhart) wrote :

The problem is partially solved after reinstalling the previously reported packages from the standard repositories. But in some programs that use the fluidsynth, there is still crackling.

Zach (zaglamir) wrote :

Confirm ZHart's comment. I've gotten FluidSynth to work with some programs, but with TuxGuitar in particular it is still failing at random for me. Sometimes it works, other times it fails and crackles and sounds like a broken speaker. This is tied to the upgrade for me as well. Working until 13.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers