Sync turtleart 98-1 (universe) from Debian unstable (main)

Bug #637735 reported by Luke Faraone on 2010-09-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
turtleart (Ubuntu)
Medium
Unassigned

Bug Description

Changes since version 96 currently sitting in NEW:

turtleart (98-1) unstable; urgency=low

  [ Matthew Gallagher ]
  * Don't modify other packages' files in maintainer scripts to adhere
    to Debian Policy. Closes: #596474.
  * Correct typo in debian/sugar-turtleart-activity.links so the activity
    icon is installed properly

  [ Luke Faraone ]
  * New upstream version.
  * Depend on libgtk2.0-bin to solve broken installation script.
  * Wrap tests in postrm in if statements to allow package removal when
    used commands are removed.

 -- Luke Faraone <email address hidden> Mon, 13 Sep 2010 22:02:36 -0400

Upstream changelog:

98

* fixed palette selection bug introduced by alpha-value checking

97

* recenter default turtle when dragged onto palette
* removed comment label from collapsible stacks
* made font smaller on the bottom-of-collapsible-stack block (#2305)
* rgs fixed resume problem in GNOME version (#2293)
* checking alpha value to block 'hit' detection (fixes problem with
  selecting the wrong block when blocks wrap around each other).
* trap and display math errors in python block (#2313)

Luke Faraone (lfaraone) wrote :

See bug 633401 for previously requested (and ACK'd) FFe. This does not need an addit'l FFe because it is bugfix-only.

Luke Faraone (lfaraone) on 2010-09-15
summary: - Sync turtleart 98-1 (main), replacing turtleart 96-1 (universe)
+ FFe: Sync sugar-turtleart-activity 98-1 (universe) from Debian unstable
+ (main)
summary: - FFe: Sync sugar-turtleart-activity 98-1 (universe) from Debian unstable
+ Sync sugar-turtleart-activity 98-1 (universe) from Debian unstable
(main)

No such package in debian

Changed in ubuntu:
status: New → Invalid
Luke Faraone (lfaraone) wrote :

Sorry, I meant "turtleart".

summary: - Sync sugar-turtleart-activity 98-1 (universe) from Debian unstable
- (main)
+ Sync turtleart 98-1 (universe) from Debian unstable (main)
Changed in ubuntu:
status: Invalid → New
Changed in ubuntu:
status: New → Confirmed
Luke Faraone (lfaraone) on 2010-09-18
affects: ubuntu → turtleart (Ubuntu)
Luke Faraone (lfaraone) wrote :

This fixes a bug where turtleart modified files owned by other packages.

Changed in turtleart (Ubuntu):
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

[Updating] turtleart (96-1 [Ubuntu] < 98-1 [Debian])
 * Trying to add turtleart...
2010-09-20 17:05:14 INFO - <turtleart_98-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-09-20 17:05:14 INFO - <turtleart_98-1.dsc: downloading from http://ftp.debian.org/debian/>
2010-09-20 17:05:14 INFO - <turtleart_98.orig.tar.bz2: downloading from http://ftp.debian.org/debian/>
I: turtleart [universe] -> sugar-turtleart-activity_31-0ubuntu1 [universe].

Changed in turtleart (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers