tumgreyspf crashes on startup, wrong library path

Bug #997946 reported by Sven Neuhaus on 2012-05-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tumgreyspf (Ubuntu)
Undecided
Unassigned

Bug Description

In /usr/bin/tumgreyspf in line 15
sys.path.append('/usr/local/lib/tumgreyspf')
should be changed to
sys.path.append('/usr/lib/tumgreyspf')
because that's where the library tumgreyspfsupp is located.

Without this change the script crashes at startup.

Also, the configuration file /etc/tumgreyspf/tumgreyspf.conf
refers to /var/local/lib/tumgreyspf instead of /var/lib/tumgreyspf/ in more than one place.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: tumgreyspf 1.36-1 [modified: usr/bin/tumgreyspf]
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Fri May 11 10:15:49 2012
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: tumgreyspf
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.tumgreyspf.tumgreyspf.conf: [modified]
mtime.conffile..etc.tumgreyspf.tumgreyspf.conf: 2012-05-10T17:17:30.881830

Sven Neuhaus (sven0) wrote :
Changed in tumgreyspf (Ubuntu):
status: New → Confirmed
description: updated
Nicolas DERIVE (kalon33) wrote :

Hi Sven, this problem is fixed in new Ubuntu versions since Ubuntu 12.10. If needed, I provide updated tumgreyspf (and dependencies) UNOFFICIAL packages in my PPA here : https://launchpad.net/~kalon33/+archive/gamesgiroll/+packages?field.name_filter=&field.status_filter=published&field.series_filter=precise. These are backported versions of latest versions available in Debian Unstable, and I'm using them every day on my server.

Hope that it helps.

Have a nice day.

Changed in tumgreyspf (Ubuntu):
status: Confirmed → Fix Released
Nicolas DERIVE (kalon33) wrote :

Mark as "Fix Released" as a fix was released in newer Ubuntu versions, and the bug reported against Ubuntu in general and not Precise in particular.

Sven Neuhaus (sven0) wrote :

Thanks for the fixed package Nicolas. It would be preferable to have the official package for precise fixed since I try to avoid PPAs as much as possible.
Is there a reason why there can't be a fixed official deb for precise?

Nicolas DERIVE (kalon33) wrote :

Probably because it's a universe package, and universe packages are not often backported or monitored for fixes.

Thomas Goirand (thomas-goirand) wrote :

Hi,

I'm the Debian package maintainer, and I confirm that the latest version of the package include patches to fix the path.

Thomas Goirand (zigo)

Sven Neuhaus (sven0) wrote :

Thanks, so who is the person to talk to get a new package for precise released?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers