Ubuntu

tumbler causes "Cannot unmount because file system on device is busy."

Reported by Ren on 2012-05-07
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
tumbler
Unknown
Unknown
tumbler (Ubuntu)
Undecided
Unassigned

Bug Description

Mounting USB Device in "thunar" and browsing lets "tumbler" generate thumbnails.
If there are video files, like .avi .mp4 etc. the thumbnailing fails (no thumbnails for this files).

Trying to umount the device causes the error "Cannot unmount because file system on device is busy.".

lsof shows, that the process "tumblerd" is active for every video file on the device.

After "pkill tumblerd" it is possible to umount the device.
Also deactivating thumbnailing comletely is a workaround.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: tumbler 0.1.24-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Mon May 7 13:53:44 2012
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423.1)
SourcePackage: tumbler
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Ren (milchmannag) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tumbler (Ubuntu):
status: New → Confirmed
Jochen Fahrner (jofa) wrote :

Same problem for me. Looks like tumblerd is hanging on certain kind of files. mkv files work without poblem, but mp4 don't have thumbnails and make tumblerd to hang forever.

Jochen Fahrner (jofa) wrote :

I found that tumblerd has this issue when it finds no codec for the video. It has nothing to do with the container format but with the contained video codec. I have some files which contain wmv3 and they cannot be played by Totem. Exactly these files cause tumblerd to not close them, so external media cannot be unmounted.

Is there a way to prevent tumblerd from scanning external media?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tumbler - 0.1.25-1ubuntu1

---------------
tumbler (0.1.25-1ubuntu1) quantal; urgency=low

  * debian/patches:
    - 01_guard-for-no-supported-vfs-schemas.patch: fix segfault when
      g_vfs_get_supported_uri_schemes() returns NULL. lp: #1032346
    - 02_set-gststate-on-error.patch: close file on error. lp: #995918
 -- Lionel Le Folgoc <email address hidden> Sun, 09 Sep 2012 11:56:20 +0200

Changed in tumbler (Ubuntu):
status: Confirmed → Fix Released
bwat47 (bwat47) wrote :

This should really be backported to 12.04 :( I'm experiencing the same issue there because I'm still in tumbler 1.24

Nur Kholis Majid (kholis) wrote :

I fix this bug by updating tumbler to version 0.1.25, as mention in comment #5 :
$ sudo dpkg -i tumbler_0.1.25-1ubuntu1_amd64.deb tumbler-common_0.1.25-1ubuntu1_all.deb libtumbler-1-0_0.1.25-1ubuntu1_amd64.deb

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.