tumblerd crashed with SIGSEGV in g_type_check_instance_is_a()

Bug #898336 reported by Ron Bakker on 2011-11-30
724
This bug affects 139 people
Affects Status Importance Assigned to Milestone
tumbler
Unknown
Unknown
tumbler (Fedora)
Won't Fix
Undecided
tumbler (Ubuntu)
Medium
Unassigned

Bug Description

Running Xubuntu, but I have also programs from gnome and KDE installed.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: tumbler 0.1.22-1build1
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Wed Nov 30 20:16:52 2011
ExecutablePath: /usr/lib/i386-linux-gnu/tumbler-1/tumblerd
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/i386-linux-gnu/tumbler-1/tumblerd
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
SegvAnalysis:
 Segfault happened at: 0x8c8ba0 <g_type_check_instance_is_a+144>: testb $0x4,0xe(%edi)
 PC (0x008c8ba0) ok
 source "$0x4" ok
 destination "0xe(%edi)" (0xfd17fd22) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: tumbler
StacktraceTop:
 g_type_check_instance_is_a () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 gst_element_seek_simple () from /usr/lib/libgstreamer-0.10.so.0
 ?? () from /usr/lib/i386-linux-gnu/tumbler-1/plugins/tumbler-gst-thumbnailer.so
 ?? () from /usr/lib/i386-linux-gnu/libtumbler-1.so.0
 tumbler_thumbnailer_create () from /usr/lib/i386-linux-gnu/libtumbler-1.so.0
Title: tumblerd crashed with SIGSEGV in g_type_check_instance_is_a()
UpgradeStatus: Upgraded to precise on 2011-11-26 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Download full text (13.0 KiB)

libreport version: 2.0.6
abrt_version: 2.0.4.981
backtrace_rating: 4
cmdline: /usr/lib64/tumbler-1/tumblerd
comment: No idea how to reproduce it. Machine was unattended when this segfault occurred.
crash_function: g_type_check_instance_is_a
executable: /usr/lib64/tumbler-1/tumblerd
kernel: 3.1.1-1.fc16.x86_64
reason: Process /usr/lib64/tumbler-1/tumblerd was killed by signal 11 (SIGSEGV)
time: Fri Nov 18 12:46:05 2011
uid: 8690
username: corsepiu

backtrace: Text file, 48448 bytes
maps: Text file, 37025 bytes

build_ids:
:1ddf6e597ba6f382f8490a52401f6905b9715abb
:80d1527bdbaa66a7f4467a3432a25332fb76758a
:5ffc709ae37f52d7d0743329a39f1b83e5493827
:1c6a95451ee19617be5abea3d121f0226d21ddda
:08325b64e0774167b3ade9126c3971ae6de9a4a6
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:98fa95d21e16075ada6df19748c6c133ee9165d0
:b5a67213cba87f4e37046b7b7728a1eb4e7aff07
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:dd09997b3723567329e48ecd0d4bac542c0a903c
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:72ea6ca9c81b71bba99cb18620abb9029a87927c
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:722092ce63f29994224c42970e34d60a30a80e46
:a70947162966aa69c7ac92b53dcd9e6748cffe35
:9e3a33f915a032d57db9e51c90f1b295fc9e425c
:a47e3764e7de48ace1ecfcfd8c2e0c49bd8cf1a3
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:3e08f14ed2767ff642c7477a25b63214050e42cb
:9af722e8d4717709aa49739efc0ed10d0f952e3e
:fa1cfd183d984f9b0a77a35f5da619fe71da5fe2
:48d3cff26c916dff6cbcb5e67d5cf6d391f6ccca
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:e7d37d7c1c48886f369bf4cc2eb07134faf900e0
:09834b108bacbb167847d374f4cd9965ce8c78f0
:b502249bcf2a4f465feeb8b9578c80cda6f4103d
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:921b64859b34786348daf376801c05efbf9bac81
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:106981fc8c382f3593c7326d039e026b11dd9ba5
:4953d1f613914126bccceb3cb96386647ffba9df
:db0921d37dbfcfc6115a7a4aeb0c6928c08abd1c
:0911ea7c180d733724f89037b8e8a34e64024aec
:6e7d3edc38bf427fb8cb8dd115b5e23b5b1b1854
:48aea888319e1848137073c9cbde54a4c2a731c9
:400aa053edc0e34645dd535201f1a1395573a681
:7055a3f0dc1ecedda325c75912ccb1fbe361013c
:bed3a3de569d0a8795d948f4630b7e6af3566d36
:a07d8451a42fb256942df953f790ded8f6b5b372
:2636afe466ed20d65ac6d8fc08f1b120974f9ceb
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:fe59af234d3adcdbdfc45a81c2099c3529d5b37d
:4c842320387ff7f6f91b7842b223c16518be909f
:c3df263f0b70a9fff51c727bd49c52f0794b9f9e
:68d260a8e19b5758a2ca3a8bf6a9e3a49a6d6bfd
:ec16722d991717e07e829bef2955435824df5083
:ebb2f0a89bbd1ef97f373a99cb44d4c968d2579f
:017a0c9c46d30256c1d6af189b4809146ef312f6
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:94e29139152ba767534403cf94a672fe6b3fe515
:ee03ac98c3ac61b47aa163886a17cc1e0c491906
:be507c791e34415e8f42f0e6030c889b2895cf9a
:33fcde0445e582dff00a8703873e1863ff1ca547
:3d22dd762f2430ac679e61c98e8d856e5f3423ed
:28f59ffca68245ca3e236e5a26db1e2a1d86e0d7
:437b7f944169cc3842441dd7b9be2973207ee72e
:632e2d2fe66298723101ff693447d3b3fc1af720
:b475123058f5a0538c0592eaf40ec27bac64a2d0
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:b453c88fcaacf75c19ab1c941fc008d7...

Created attachment 534378
File: backtrace

Created attachment 534379
File: maps

Package: tumbler-0.1.22-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Open an *.mpg in nautilus to play it with totem.

Are you sure it was nautilus and Thunar was not involved here? I am beginning to think that the problem is not in tumbler' GStreamer plugin but in GStreamer itself. We have reports of other applications (e.g. midori) crashing and freezing as soon as they are trying to use GStreamer.

(In reply to comment #4)
> Are you sure it was nautilus and Thunar was not involved here?
You are right on the spot - Though I was 100% sure to once have configured nautilus as my preferred "File Manager", I currently have Thunar :)

[No idea about the cause, but I am facing other "automagic"
Gnome3<->xfce switchers with gdm's "session"].

> I am beginning
> to think that the problem is not in tumbler' GStreamer plugin but in GStreamer
> itself. We have reports of other applications (e.g. midori) crashing and
> freezing as soon as they are trying to use GStreamer.
Hmm. I am currently pretty clueless, except that I only reported a very small numbers of the segfaults I actually have seen so far (I could flood you if I'd wanted to).

Looks like a systematic issue with some files I have on disk to me.

Also, as I don't actually know what thumbler does, I am not sure if it's actually launching totem on a particular video which causes the segfaults, but browsing a folder of videos - thumbnail creation?

(In reply to comment #5)
> (In reply to comment #4)
> > Are you sure it was nautilus and Thunar was not involved here?
> You are right on the spot - Though I was 100% sure to once have configured
> nautilus as my preferred "File Manager", I currently have Thunar :)

If you are using Xfce you can use exo-preferred-applications to select your favorite file manager. Not all GNOME apps honor this setting though and I don't know where to set the default file manager in GNOME 3.x

> Also, as I don't actually know what thumbler does, I am not sure if it's
> actually launching totem on a particular video which causes the segfaults, but
> browsing a folder of videos - thumbnail creation?

Bingo!

You can remove /usr/lib*/tumbler-1/plugins/tumbler-gst-thumbnailer.so if the crashes continue.

*** Bug 757641 has been marked as a duplicate of this bug. ***

Ron Bakker (r0n) wrote :

StacktraceTop:
 g_type_check_instance_is_a (type_instance=0xa9e191a0, iface_type=561159456) at /build/buildd/glib2.0-2.30.1/./gobject/gtype.c:3952
 gst_element_seek_simple (element=0xa9e191a0, format=GST_FORMAT_TIME, seek_flags=5, seek_pos=1455821333333) at gstutils.c:2417
 gst_thumbnailer_create (thumbnailer=0x2181da80, cancellable=0x21818000, info=0xa9ea3e00) at gst-thumbnailer.c:329
 tumbler_abstract_thumbnailer_create (thumbnailer=0x2181da80, cancellable=0x21818000, info=0xa9ea3e00) at tumbler-abstract-thumbnailer.c:244
 tumbler_thumbnailer_create (thumbnailer=0x2181da80, cancellable=0x21818000, info=0xa9ea3e00) at tumbler-thumbnailer.c:148

Changed in tumbler (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

*** Bug 759846 has been marked as a duplicate of this bug. ***

Thanks everybody for submitting this crash report. I have forwarded it to the developers at https://bugzilla.xfce.org/show_bug.cgi?id=8219

From now on, further investigation of this crash should take place in the Xfce bug tracker. I will get back to you if I need more info and let you know once this bug is resolved in Fedora.

*** Bug 759935 has been marked as a duplicate of this bug. ***

I am still facing this bug almost every day.

However BZ now refuses to accept reports about it, probably due to the fact you have closed this BUG "fixed upstream":

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Bug is already reported: 754961
Logging out
Status: CLOSED UPSTREAM https://bugzilla.redhat.com/show_bug.cgi?id=754961

=> This bug has not been fixed in fedora.
=> You are cheating.

(In reply to comment #13)
> => This bug has not been fixed in fedora.
> => You are cheating.

Please take a minute to read the bugzilla documentation and become familar with the workflow. CLOSED UPSTREAM does not imply the bug is actually fixed in Fedora but "bugs closed with this resolution are filed in the upstream bugs tracker or reported to the upstream mailing list".

More info is available at https://bugzilla.redhat.com/page.cgi?id=fields.html#status

Let me quote you from bug 757641 comment 10: "There is nothing I can do about these segfaults." - So what do you expect me to to or to track here?

If you really hit this bug every day, then please use the work around I have given you. TIA.

(In reply to comment #14)
> (In reply to comment #13)
> > => This bug has not been fixed in fedora.
> > => You are cheating.
>
> Please take a minute to read the bugzilla documentation and become familar with
> the workflow. CLOSED UPSTREAM does not imply the bug is actually fixed in
> Fedora but "bugs closed with this resolution are filed in the upstream bugs
> tracker or reported to the upstream mailing list".
>
> More info is available at
> https://bugzilla.redhat.com/page.cgi?id=fields.html#status
As long as Fedora exists, I have been discouraging maintainers to use CLOSED UPSTREAM. because it's a bold lie, which is only useful to violently play down the number of bugs Fedora suffers from.

Combined with the fact, abrt now "silently exits 0" once a bug was CLOSDED UPSTREAM, I am considering maintainers closing bugs "CLOSED UPSTREAM" to be doing so deliberately in hostile intentions.

> Let me quote you from bug 757641 comment 10: "There is nothing I can do about
> these segfaults."
Correct. These segfaults happen in the background, without any any immediate interaction attached and without abrt not providing any helpful information to reproduce them.

> - So what do you expect me to to or to track here?
At minimum, I am expecting maintainers to keep bugs open as long as they affect Fedora - What you are doing is cheating!

> If you really hit this bug every day, then please use the work around I have
> given you. TIA.
You mean to
"rm /usr/lib*/tumbler-1/plugins/tumbler-gst-thumbnailer.so"?

Certainly this stops the segfaults, ... because it's stops all thumbnailing.
== Suppressing symptoms

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tumbler (Ubuntu):
status: New → Confirmed
Changed in tumbler (Ubuntu):
status: Confirmed → Triaged
visibility: private → public
j2snowden (m8r-didia8) wrote :

WTF 12 days since first crash report, 16 days to LTS release and I am getting this stupid crash?!!!!!!!!

Lionel Le Folgoc (mrpouit) wrote :

You didn't use enough exclamation marks, I guess that's why.

Chascon (chascone) wrote :

I'm running Precise Beta with Unity and got this error.

j2snowden (m8r-didia8) wrote :

12 days to LTS and such a nusty crash Nobody assigned, nobody cares, been here for ages and assigned to medium?!!!!!!!!!

j2snowden (m8r-didia8) wrote :

Still crashing while copying files. WTF? Anyone fixing the shit?

j2snowden (m8r-didia8) wrote :

I'd like to use GUI to copy files not terminal. WTF????!!!!!

j2snowden (m8r-didia8) wrote :

fix the shit fix the shit fix the shit WTF WTF? Its an LTS and the system crashes while copying files??? WTF!!!!!!!!!!!!!!!!!!!!!!!!!!??????????????????????????????????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!???????????????????????????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!?????????????????????????????

col reilly (lupinehorror) wrote :

happening with me on 12.10 beta xubuntu.

Gary M (garym) on 2012-09-05
tags: added: quantal
tags: added: running-unity

keeps happening with 12.04 64-bit...

Paco Avila (monkiki) wrote :

Running Xubuntu 12.10 Beta under VirtualBox.

Petro (petrochemicals) wrote :

This bug was reported in 2011 and I am still seeing it in a LTS almost a year later. Why is this not fixed yet? I am on Ubuntu 12.04.1 with XFCE 4.10.

Chascon (chascone) wrote :

Replacing it might be an option as this seems to be an ongoing problem. Anyone know of a stand in?

LAZA (laza74) wrote :

Annoys me EVERY DAY i start Xubuntu 12.10 !!!

GroovyMotion (flywaver) wrote :

same issue with Ubuntu 12.10 64-bit

Dilutu (diluka44) wrote :

Very annoying , on 12.04 Xubuntu. Whish I could replace that pest with something that works.

shuerhaaken (shkn) wrote :

In 12.10 Xubuntu, there seems to be no problem any more.

shuerhaaken (shkn) wrote :

Sorry, in 13.04 Xubuntu, there seems to be no problem any more.

Cody Garver (codygarver) wrote :

Upstream XFCE bug tracker says this was fixed around 2013-05-05.

Changed in tumbler (Ubuntu):
status: Triaged → Incomplete
Changed in tumbler (Fedora):
importance: Unknown → Undecided
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.