Missing many Glyphs to support Uyghur (Uighur) Language

Bug #757540 reported by Burkut on 2011-04-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ttf-kacst-one (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ttf-kacst-one

Dear Ubuntu Package Maintainer,

Currently, there is NO single font on Ubuntu which supports Uyghur (Uighur) language. Uyghur (Uighur) uses modified Arabic-Persian script. All of the fonts on Ubuntu which support Arabic stil lack many additional codepoints and glyphs to support Uyghur properly.

I, as one of the Uyghurs who uses Ubuntu and promote it among us, contacted the KacstOne font maintainer and asked him to add the extraa codepoints and glyphs needed for Uyghur. And the maintainer gladly added the missing glyphs and updated the font. The current updated version is 4.0 and its sourse is at:
http://sourceforge.net/projects/arabeyes/files/kacst_fonts/kacst_one_4.0.tar.bz2

Ubuntu Natty (11.04) is still using the package of version 3.0. Please update this package to 4.0 shown above so that the Uyghur Ubuntu users can handle their script on Natty (11.04). Thank you very much.

Changed in ttf-kacst-one (Ubuntu):
status: New → In Progress
Scott Kitterman (kitterman) wrote :

I'm inclined to approve this for post-Beta2 upload, but I'd like confirmation from someone using Uyghur that this works correctly.

Ahmed: Could you publish this in a PPA or provide a .deb for Burkut to test with?

I already sent the deb file to Burkut, asking him to give his feedback here. Thanks.

Scott Kitterman (kitterman) wrote :

This is installed by default in all Ubuntu systems, so we need to worry about size. How much bigger does this make the .deb?

According to http://packages.ubuntu.com/natty/ttf-kacst-one, the current install size is 116 kB

For 4.0ubuntu1 it is:
 Installed-Size: 112

Scott Kitterman (kitterman) wrote :

OK. We just need to hear on testing then.

Burkut (burkut) wrote :

Dear All,

I am the original bug reporter and I am a Uyghur.

After installing the .deb package Mr. Ahmed El-Mahmoudy provided me, everything works great! Here I attached some screen shot pictures.

Scott Kitterman (kitterman) wrote :

FFe Approved. Subscribing sponsors.

Attached is the deb packaging.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ttf-kacst-one - 4.0-0ubuntu1

---------------
ttf-kacst-one (4.0-0ubuntu1) natty; urgency=low

  [ Ahmed El-Mahmoudy ]
  * New upstream release.
    + Add glyphs necessary to support Uyghur orthography (LP: #757540).
  * Added kern_class2pairs patch from upstream.

  [ Dustin Kirkland ]
  * Downloaded and repacked upstream tarball
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden> Sun, 10 Apr 2011 19:00:24 +0200

Changed in ttf-kacst-one (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers