ttf-indic-fonts need to be replaced with fonts-indic

Bug #958345 reported by Santhosh Thottingal on 2012-03-18
152
This bug affects 28 people
Affects Status Importance Assigned to Milestone
libreoffice-l10n (Ubuntu)
High
Ubuntu Desktop
Xenial
High
Ubuntu Desktop
ttf-indic-fonts (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

The Debian fonts team recently restructured the indic fonts. ttf-indic-fonts changed to fonts-indic. This is meta package and all packages ttf-[language]-fonts renamed to fonts-[script/foundry]. In addition to this all fonts were updated to latest versions from upstreams.
I request ubuntu maintainers to update the fonts to latest versions and consider following the debian package naming changes for fonts.

Refer: http://packages.debian.org/sid/fonts-indic

Micah Gersten (micahg) on 2012-03-18
tags: added: upgrade-software-version
Mark A. Hershberger (hexmode) wrote :

Is there anyway we can make this happen for precise?

Andre Klapper (a9016009) wrote :

Ping - could this be considered to get packaged, please?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ttf-indic-fonts (Ubuntu):
status: New → Confirmed
Anivar Aravind (anivar) wrote :

Also many fonts are updated to newer versions . and solves many existing bugs .
eg. ttf-malayalam-fonts (new name is fonts-smc) solves Bug no. #515607

absolutevoid (sebinajacob) wrote :

Please update the fonts. this issue affects many.

Jayesh M (me-jayesh) wrote :

This bug Affects me

Anivar Aravind (anivar) on 2013-03-21
summary: - Update ttf-indic-fonts package
+ ttf-indic-fonts: new changes from Debian require merging

after one year of reporting. this is still open?
seems like the users are no longer in control.
time to switch distros :-/

Anivar Aravind (anivar) on 2013-05-23
summary: - ttf-indic-fonts: new changes from Debian require merging
+ ttf-indic-fonts packages is not updated for last 2 years
Changed in ttf-indic-fonts (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist

This bug was fixed in the package ttf-indic-fonts - 1:0.5.14ubuntu1

---------------
ttf-indic-fonts (1:0.5.14ubuntu1) trusty; urgency=medium

  * Merge with Debian, remaining changes: (LP: #958345)
  * debian/control:
  * debian/*.install:
  * debian/*.links:
    - Split out a maximum of two fonts (the preferred fonts for serif and
      sans-serif) per language into a ttf-indic-fonts-core package, with the
      exception of Punjabi, which only ships the two preferred fonts for
      that language, so a split doesn't make sense.
    - Ship all fontconfig files (except for Punjabi) in the
      ttf-indic-fonts-core package, together with the fonts.
  * debian/control:
    - Change ttf-indic-fonts depends on fonts-pagul, fonts-gubbi and
      fonts-navilu to recommends since these are in Universe
 -- Robert Ancell <email address hidden> Tue, 14 Jan 2014 13:34:20 +1300

Changed in ttf-indic-fonts (Ubuntu):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

As far as I can tell the updated fonts are all available (e.g fonts-lohit-beng-bengali), it's just the ttf-indic-fonts package out of date. I've updated this to the latest Debian version now.

Also, we are missing the fonts-* metapackages, though I can't see any reason why they shouldn't be synced. When I tried to do that they were blocked for some reason though.

Robert Ancell (robert-ancell) wrote :

Some more looking into this...

The reason we are not using the standard Debian packages is we limit the number of fonts installed on the default image for size reasons. We did this by making a ttf-indic-fonts-core package which contained this minimal set of fonts (excluding Punjabi which we used the already small ttf-punjabi-fonts)

From the old ttf-indic-fonts-core package we have the following fonts and I've tried to track down which new packages these fonts contain. Fonts that no longer seem to exists are marked with ? and fonts packages that contain multiple fonts are marked with *. We can't use the packages that contain many fonts since they will be too large.

lohit_bn.ttf -> fonts-lohit-beng-bengali
MuktiNarrowBold.ttf -> fonts-beng-extra*
MuktiNarrow.ttf -> fonts-beng-extra*
gargi.ttf -> ?
lohit_hi.ttf -> fonts-lohit-deva
lohit_gu.ttf -> fonts-lohit-gujr
Rekha.ttf -> fonst-gujr-extra*
Kedage-b.ttf -> ?
Kedage-n.ttf -> ?
Malige-b.ttf -> ?
Malige-n.ttf -> ?
Meera_04.ttf -> fonts-smc*
Rachana_04.ttf -> fonts-smc*
utkal.ttf -> fonts-orya-extra
lohit_ta.ttf -> fonts-lohit-tamil
Pothana2000.ttf -> fonts-telu-extra
Vemana.ttf -> fonts-telu-extra

Robert Ancell (robert-ancell) wrote :

The above list shows we will have quite some trouble using the new packages to provide the same set of default fonts. BUT, I'm not sure what criteria was done for picking these and if this is still the best set of default fonts.

We currently use <3M for the current fonts (sizes are in kB):
ttf-indic-fonts-core 2464
ttf-punjabi-fonts 202
total - 2666

If we used just the "lohit" fonts, we would still be under this:
fonts-lohit-beng-assamese 199
fonts-lohit-beng-bengali 200
fonts-lohit-deva 134
fonts-lohit-gujr 122
fonts-lohit-guru 86
fonts-lohit-knda 256
fonts-lohit-mlym 127
fonts-lohit-orya 156
fonts-lohit-taml 124
fonts-lohit-telu 230
total - 1634

The question is, is the above an appropriate set of default fonts [1] for Ubuntu? If not, what alternative packages should we use?

In comment #4 Anival implies that fonts-smc might be more appropriate than fonts-lohit-mlym, but it is very large (1842kB). If we needed that package, which fonts would we need from it (we would then have to split it into fonts-smc-core and fonts-smc)?

I am not a native speaker of any of these languages so I need your help here.

[1] one serif and one sans-serif per language was the former criterion

Anivar Aravind (anivar) wrote :

For each Indian languages there are suggested default fonts in most of the GNU/Linux distros . These came up after many user suggestions over years . ttf-indic-fonts-core was earlier serving these default font sets. But many font versions changed after that and many new fonts came up . I request you to respect that

For Malayalam Meera is the suggested Sans Serif font(default font) and Rachana is the suggested Serif fonts . Almost alk the distros like Fedora , Debian etc uses it that way .

For Tamil , there is newly introduced font meera tamil http://packages.debian.org/en/sid/fonts-meera-taml which is asthetically better compared to lohit fonts .

Anivar Aravind (anivar) wrote :

I am adding Vasudev Kammath , maintainer of Debian fonts-indic to this bug . So he may able to suggest better default fonts

Anivar Aravind <email address hidden> writes:

> I am adding Vasudev Kammath , maintainer of Debian fonts-indic to this
> bug . So he may able to suggest better default fonts

In Debian especially from the installer part where we have different
tasksel packages, we decided to use fonts-lohit-* as fonts in this
package the main reason for this decision was lohit is the only foundry
which provides fonts for all Indian languages and they are consistent
with each other.

I would suggest you pick all fonts-lohit-* for supporting Indian
languages.

Hope that helps, keep me in Cc for future references as I'm not
subscribed to launchpad thread.

--
Vasudev Kamath
http://copyninja.info
Connect on ~friendica: copyninja@{frndk.de | vasudev.homelinux.net}
IRC nick: copyninja | vasudev {irc.oftc.net | irc.freenode.net}
GPG Key: C517 C25D E408 759D 98A4 C96B 6C8F 74AE 8770 0B7E

For Malayalam Lohit would be the bad choice because it is the least popular font for Malayalam among all other available fonts. It follows a reduced set orthography. Consistent glyphs with other Indic fonts is the main drawback of that font and its less popularity. All Indic scripts vary a lot and one design for all was not successful so far.

If size is a concern, you may split the fonts-smc package to fonts-smc-meera etc as Fedora does(https://apps.fedoraproject.org/packages/smc-meera-fonts)

Ubuntu 14.04 comes with many years old font package for all Indic language. See http://packages.ubuntu.com/trusty/all/ttf-indic-fonts-core/filelist

Changed in ttf-indic-fonts (Ubuntu):
status: Fix Released → Confirmed
Anivar Aravind (anivar) wrote :

Any effort to fix it before 15.04 ?

This is affecting all Indic Languages .

to be done : ttf-indic-fonts and all subpackages need to be replaced with fonts-indic and subpackages .

For Malayalam : fonts-smc need to be used instead of ttf-malayalam-fonts

Packages are already in debian upstream .

We are working on an Ubuntu PPA as well
https://launchpad.net/~smcproject/+archive/ubuntu/repo
(still in testing)

summary: - ttf-indic-fonts packages is not updated for last 2 years
+ ttf-indic-fonts packages are outdated

$ syncpackage fonts-beng
syncpackage: Error: Source package fonts-beng is blacklisted.
syncpackage: If this package needs a fakesync, use --fakesync
syncpackage: If you think this package shouldn't be blacklisted, please file a bug
syncpackage: explaining your reasoning and subscribe ~ubuntu-archive.
syncpackage: Blacklist Comments:
syncpackage: From sync-blacklist.txt:
syncpackage: # cjwatson, 2012-06-01
syncpackage: # Temporary blacklist entries for quantal, requiring manual resolution
syncpackage: due
syncpackage: # to conflicts with existing Ubuntu-versioned binaries.
syncpackage: alsa-base
syncpackage: fonts-beng

I don't know why these are blacklisted but it seems to me they should not be. Subscribed ~ubuntu-archive to do this.

fonts-deva, fonts-gujr, fonts-guru, fonts-knda, fonts-mlym, fonts-orya, fonts-pagul, fonts-taml, fonts-telu may also be blacklisted (haven't checked).

Robert Ancell (robert-ancell) wrote :

The fonts-* packages should now be available in vivid.

Robert Ancell (robert-ancell) wrote :

The libreoffice-l10n-in package recommends ttf-indic-fonts and should be updated to fonts-indic.

Happy to see someone working on this Bug . Thanks Robert-Ancell .

Matthias Klose (doko) wrote :

Robert, please follow the appropriate procedures for main inclusion requests

Changed in ttf-indic-fonts (Ubuntu):
importance: Wishlist → High
milestone: none → ubuntu-14.04.3
status: Confirmed → Incomplete
Robert Ancell (robert-ancell) wrote :

Matthias - the MIR bugs should be following the appropriate procedures. Is anything wrong?

Anivar Aravind (anivar) on 2015-03-16
Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in ttf-indic-fonts (Ubuntu):
status: Incomplete → Confirmed

Robert Ancell, Mathias Close ,

In which version these changes will be visible .
ttf-indic-fonts-core still contain outdated packages in 15.04 and ttf-malayalam-fonts contains old version of fonts . I think whole ttf-indic fonts and subpackages need to be converted as just migration packages pointing fonts-language* packages . In which version we can expect this ?

Adam Conrad (adconrad) on 2015-06-29
Changed in ttf-indic-fonts (Ubuntu):
milestone: ubuntu-14.04.3 → none

15.10 Also contains old(actually 6+ years old) fonts in ttf-indic-fonts-core package. Please update it. Because of this default installation of ubuntu is not giving correct rendering for Malayalam and hence all Ubuntu Malayalam users are affected

Robert Ancell (robert-ancell) wrote :

Santhosh - you should uninstall ttf-indic-fonts-core and install the fonts-* packages instead.

>git grep ttf-indic
finds nothing in the LibreOffice 5.1 package on xenial. => resolved.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
Robert Ancell (robert-ancell) wrote :

The correct solution is to remove ttf-indic-fonts and its dependencies from the archive.

Changed in ttf-indic-fonts (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → Triaged
summary: - ttf-indic-fonts packages are outdated
+ ttf-indic-fonts packages are outdated should be removed

 > Santhosh - you should uninstall ttf-indic-fonts-core and install the fonts-* packages instead.

Yeah, that is what we are asking - please remove it from ubuntu installer so that the users get correct fonts. After installing Ubuntu, people get fonts from ttf-indic-fonts-core package. Those fonts are outdated - in fact many years old. Asking every user of Ubuntu to uninstall that package and install fonts-* package is not the solution I expect here.

Either update ttf-indic-fonts-core package to latest version or use new package in ubuntu installer.

Robert Ancell (robert-ancell) wrote :

As far as I can tell the Ubuntu installer does not explicitly install ttf-indic-fonts-core. The ubuntu-desktop package depends on the new fonts. Do you mean fresh installs or those upgrading?

It does.

Steps to reproduce:

1. Get Ubuntu 15.10 Image and boot it. (I used virtualbox)
2. Once you get the desktop go to /usr/share/fonts/truetype/ttf-indic-fonts-core - Remember this was not additionally or explicitly installed. It came by default with OS.
3. You will see the years old fonts installed there as shown in screenshot attached. Some of these fonts are even abandoned by developers.
4. The impact: After ubuntu installed, not installing any extra packages, without any extra customization, the indic language rendering the user get is crappy. Majority of users are going to use ubuntu as such without bothering or not knowing customization and package management.

Since I am a developer of some of these fonts, I get this question every week from users- "Why am I seeing the crappy fonts in Ubuntu?"

Please please fix this before 16.04

balasankarc (c-balasankar) wrote :

> As far as I can tell the Ubuntu installer does not explicitly install ttf-indic-fonts-core

Check the manifest file of Wily ISO [1]. It does install ttf-indic-fonts-core .

[1] http://releases.ubuntu.com/wily/ubuntu-15.10-desktop-amd64.manifest

Ashik Salahudeen (aashiks) wrote :

I can confirm that 15.10 does indeed come with ttf-indic-fonts.

The fonts provided on Ubuntu 15.10 by default provides a suboptimal user experience for someone dealing with Indic content. These are VERY old fonts, and it is gross injustice to not include newer versions. The fix suggested seems simple enough, and I have no idea why this is taking years to be completed.

Hrishikesh.KB (hrishi-kb) wrote :

Whoa!! FOUR YEARS?? seriously ??

Matthias Klose (doko) on 2016-02-20
affects: libreoffice (Ubuntu) → libreoffice-l10n (Ubuntu)
Changed in libreoffice-l10n (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → High
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
milestone: none → ubuntu-16.02
Changed in ttf-indic-fonts (Ubuntu Xenial):
milestone: none → ubuntu-16.02
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:5.1.0-0ubuntu1

---------------
libreoffice-l10n (1:5.1.0-0ubuntu1) xenial; urgency=medium

  * finalize version, rc3 = 5.1.0
  * depend on libreoffice-sdbc-hsqldb from libreoffice-subsequentcheckbase for
    autopkgtests
  * add libreoffice-style-elementary from upstream (LP: #1483914)
  * continue building libreoffice-gtk3, but dont default-deploy (yet)
  * use system ucpp instead of bundling (LP: #1524638)
  * add google drive bits (LP: #1389936)
  * update indic fonts package names (LP: #958345)

 -- Bjoern Michaelsen <email address hidden> Sun, 21 Feb 2016 15:23:45 +0100

Changed in libreoffice-l10n (Ubuntu Xenial):
status: Triaged → Fix Released
Matthias Klose (doko) wrote :

removed for 16.04 LTS

Changed in ttf-indic-fonts (Ubuntu Xenial):
status: Triaged → Fix Released

This is not fixed. Just the ttf-indic-fonts package removed without alternatives. All indic languages broken now - no fonts at all. Some scripts falls back to FreeSans and it is horribly broken old version. Please re-open and fix immediately.

Kannada wikipedia seen in default ubuntu installation. All tofu because there is no font support Kannada.

Anivar Aravind (anivar) wrote :

Indian Language fonts are not Fixed in 17.10 Beta 2. There is no indian language fonts in default ISO & installer. Unmaintained fonts-freefont support few languages but produces broken rendering . Most languages are not suupported . There is a need of including installer support for indian languages .

Anivar Aravind (anivar) on 2017-09-29
summary: - ttf-indic-fonts packages are outdated should be removed
+ ttf-indic-fonts need to be replaced with fonts-indic
Changed in kubuntu-meta (Ubuntu Xenial):
status: New → Confirmed
Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Anivar, please open a new bug for that issue. You can file the bug against ubuntu-meta if your concern is about the default Ubuntu iso.

no longer affects: kubuntu-meta (Ubuntu)
no longer affects: kubuntu-meta (Ubuntu Xenial)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers