Terminal log is sometimes a mix of Kannada and English and unreadable

Bug #1065535 reported by Akhila on 2012-10-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ttf-indic-fonts (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Desktop i386 Kannada version running on VirtualBox. I had no problem with the logs of commands like 'sudo apt-get update' and '.. dist-upgrade'. When I tried executing 'hud-cli' the result was pretty much a mess of Kannada and English and was unreadable. Output was purely in English for just 'apt-get update' and there was some confusion again with the display language when I tried reporting a bug. Screenshots attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Casper:
 Generating locales...
   en_US.UTF-8... done
 Generation complete.
 pwconv: failed to change the mode of /etc/passwd- to 0600
 Adding 'diversion of /usr/bin/bluetooth-applet to /usr/bin/bluetooth-applet.orig by casper'
Date: Thu Oct 11 19:50:23 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta i386 (20121011)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=kn_IN
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Akhila (akhilahegde) wrote :
Akhila (akhilahegde) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1065535

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

ubiquity is the package for the installer and as this bug isn't about the installation process I'm going to remove the package from the bug report.

affects: ubiquity (Ubuntu) → ubuntu
Quinn Balazs (qbalazs) wrote :

Tentatively targeting indicator-appmenu, as is the provider of hud-cli.... Please change if this is found to be incorrect

affects: ubuntu → indicator-appmenu (Ubuntu)
Adolfo Jayme (fitojb) wrote :

The monospaced font should support Kannada script (so there's no character overlap) and there's a need of Kannada translators to complete the missing strings that appear in English. These are two issues stacked in one report--making it unworkable--, and the font problem is sadly the most difficult and expensive to solve. As the problem is caused by the use of a monospaced font in the terminal, maybe we could turn this report into a gnome-terminal bug? I think gnome-terminal should support normal (e.g. proportional) fonts for non-latin scripts.

Quinn Balazs (qbalazs) wrote :

Changing package to reflect an incomplete Kannada font package. Also, as this problem is known to exist in quantal, marking as confirmed. If you could verify whether or not this is still an issue in the latest Raring release that would be quite helpful.

Thanks,
  ~qbalazs

affects: indicator-appmenu (Ubuntu) → ttf-indic-fonts (Ubuntu)
Changed in ttf-indic-fonts (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers