"Sans Italic" is noticably thinner than "Sans"

Bug #176392 reported by Alexander Jones on 2007-12-14
2
Affects Status Importance Assigned to Milestone
ttf-dejavu (Ubuntu)
Medium
Arne Goetje

Bug Description

As of a recent update, It seems the "Sans" alias is a bit broken. It's supposed to map onto DejaVu Sans as far as I am aware, and while this is true for the "Regular" variant, the "Italic" variant seems to be using DejaVu Sans Condensed.

You can check this yourself by installing "specimen" and opening the "Sans" typeface. Now compare it with "DejaVu Sans".

ProblemType: Bug
Architecture: i386
Date: Fri Dec 14 16:50:00 2007
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: vmnet vmblock vmmon fglrx
Uname: Linux flash 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Alexander Jones (alex-weej) wrote :

I tried setting my desktop fonts all to DejaVu Sans to remove the ambiguity, but it seems that programs (in particular notification-daemon) are still using an italic form of Condensed rather than the Italic variant.

So maybe this is a bug in DejaVu Sans. I also notice that there is no Condensed Italic, and Condensed Bold is in fact listed twice. Strange!

Alexander Jones (alex-weej) wrote :

Using Bitstream Vera, there is no problem. (Sorry for the volume.)

Nanley Chery (nanoman) wrote :

Do you still have this problem? I have tried to reproduce it, but it seems like DejaVu Sans condensed is not in the font catalogue. And it also looks like Sans _is_ mapped onto DejaVu Sans.

Alexander Jones (alex-weej) wrote :

Still happening in Hardy at present.

Sans Regular may be mapped to DejaVu Sans Roman, but Sans Italic is mapped to DejaVu Sans *Condensed* Oblique or something.

Alexander Jones (alex-weej) wrote :

By the way, DejaVu Sans "Condensed" is not a separate face, it is part of DejaVu Sans.

Alexander Jones (alex-weej) wrote :

Still happening as of latest alpha

Alexander Jones (alex-weej) wrote :
Alexander Jones (alex-weej) wrote :

Here's a test case for Gecko.

Top to bottom:

"Sans"
"Bitstream Vera Sans"
"DejaVu Sans"

DejaVu Sans is broken (as is Sans, by proxy).

Alexander Jones (alex-weej) wrote :

I am really confused as to what is going on with the DejaVu Sans typeface.

Sans has four "styles" listed in the GTK font selector: Regular, Italic, Bold, Bold Italic.

Bitstream Vera has: Roman, Oblique, Bold, Bold Oblique.

DejaVu Sans has:

ExtraLight (works)
Condensed (works)
Book (works, i.e. Regular/Roman)
Oblique (works fine!)
Condensed Book (seems like it should be Condensed Oblique, as it is italicized)
Condensed Bold (works)
Condensed Bold (AGAIN? Also works, but strange that it appears twice)
Bold (works)
Bold Oblique (works)

So it's strange that there is no Condensed Oblique style, yet Condensed Book seems to fit the bill, and it is selected when you choose "DejaVu Sans", "Italic". I don't get it! :(

Alexander Jones (alex-weej) wrote :

I have noticed, when browsing /usr/share/fonts/truetype/ttf-dejavu, that the DejaVuSansCondensed-Oblique.ttf font (whose name suggests it is the "Condensed Oblique" type, has metadata describing it as being the "Condensed Book" face. The actual font itself is definitely Condensed Oblique, so it just looks like a metadata error.

Not sure if this is causing the problem, but it indicates that maybe the metadata needs checking over.

Bryce Harrington (bryce) wrote :

If I understand this bug report correctly, the issue with the test case is that on gutsy, this is correct:

Bryce Harrington (bryce) wrote :

...and this one on Hardy is incorrect.

Bryce Harrington (bryce) wrote :

On both gutsy and hardy, fc-match returns:

#Gutsy
$ fc-match sans
DejaVu-Sans.ttf: "DejaVu Sans" "Book"

#Hardy
$ fc-match sans
DejaVuSans.ttf: "DejaVu Sans" "Book"

Bryce Harrington (bryce) wrote :

#Gutsy
$ fc-match sans:italic
DejaVu-Sans-Oblique.ttf: "DejaVu Sans" "Oblique"

#Hardy
$ fc-match sans:italic
DejaVuSans.ttf: "DejaVu Sans" "Book"

Alexander Jones (alex-weej) wrote :

On my Hardy system:

alex@flash:~$ fc-match sans:italic
DejaVuSansCondensed-Oblique.ttf: "DejaVu Sans" "Condensed Book"

Weird?

Alexander Jones (alex-weej) wrote :

I have opened a bug about the metadata issue here https://bugs.launchpad.net/ubuntu/+source/ttf-dejavu/+bug/187098 though I'm not sure if a resolution there leads to a resolution here.

Bryce Harrington (bryce) wrote :

I notice the number of installed DejaVu fonts has changed from gutsy to hardy, and wonder if that may be contributing to the problem. Copying over the dejavu fonts from my gutsy box to my hardy box, and running `fc-cache -fv` made fc-match return the same as on Gutsy:

$ fc-match sans:italic
DejaVuSans-Oblique.ttf: "DejaVu Sans" "Oblique"

Yet firefox is still displaying the test case incorrectly, so it must be something else.

Bryce Harrington (bryce) wrote :

In comparing the source files for ttf-dejavu on gutsy and hardy, it appears the issue is that the debian/ttf-dejavu-extra.defoma-hints file for Gutsy had a fix from Arne to correct Oblique vs Italic for Serif fonts, which is missing on Hardy. On hardy it appears the package was sync'd to debian without merging the ubuntu patch.

Assigning to Arne to investigate further. It appears that the changes he made for Ubuntu in Gutsy need to be ported to the Hardy version of the package (and perhaps pushed back up to Debian).

$ diff -u /tmp/ttf-dejavu-extra.defoma-hints debian/ttf-dejavu-extra.defoma-hints
--- /tmp/ttf-dejavu-extra.defoma-hints 2008-01-29 09:39:16.110311167 -0800
+++ debian/ttf-dejavu-extra.defoma-hints 2008-01-29 09:35:07.000000000 -0800
@@ -116,7 +116,7 @@
   GeneralFamily = Roman
   Weight = Medium
   Width = Variable
- Shape = Serif Oblique
+ Shape = Serif Italic
   Foundry = DejaVu
   Priority = 20
 end
@@ -130,7 +130,7 @@
   GeneralFamily = Roman
   Weight = Bold
   Width = Variable
- Shape = Serif Oblique
+ Shape = Serif Italic
   Foundry = DejaVu
   Priority = 20
 end
@@ -175,7 +175,7 @@
   GeneralFamily = Roman
   Weight = Medium
   Width = Variable
- Shape = Serif Oblique Condensed
+ Shape = Serif Italic Condensed
   Foundry = DejaVu
   Priority = 20
 end
@@ -189,7 +189,7 @@
   GeneralFamily = Roman
   Weight = Bold
   Width = Variable
- Shape = Serif Oblique Condensed
+ Shape = Serif Italic Condensed
   Foundry = DejaVu
   Priority = 20
 end

Changed in fontconfig:
assignee: nobody → arnegoetje
Arne Goetje (arnegoetje) on 2008-01-31
Changed in fontconfig:
status: Confirmed → In Progress
Arne Goetje (arnegoetje) wrote :

Fixed in 2.23-1 (hardy).

Changed in ttf-dejavu:
status: In Progress → Fix Released

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bryce Harrington wrote:
> On both gutsy and hardy, fc-match returns:
>
> #Gutsy
> $ fc-match sans
> DejaVu-Sans.ttf: "DejaVu Sans" "Book"
>
> #Hardy
> $ fc-match sans
> DejaVuSans.ttf: "DejaVu Sans" "Book"
>
>
> ** Changed in: ubuntu
> Importance: Undecided => Low
>
Bryce: This bug has been fixed with the update to ttf-dejavu 2.23-1 in
Hardy. I have marked it as resolved already.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHqsUvbp/QbmhdHowRAhtbAKCN7rB+QjmyCGaUro+V986ZZvAk3wCg2oMF
ceHwhXFgIU7h29CFwGvEdHc=
=a04o
-----END PGP SIGNATURE-----

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers