Ubuntu

RFE: Replace Bitstream Vera with DejaVu

Reported by Данило Шеган on 2005-01-18
12
Affects Status Importance Assigned to Milestone
ttf-bitstream-vera (Ubuntu)
Wishlist
Jeff Waugh

Bug Description

DejaVu fonts are Vera-derivates which include many additional glyphs, making
them suitable for much more languages. In their 1.5 and soon-to-come (should be
today) 1.6 release, they support most of Latin-A region (meaning, most of
European Latin-based languages are supported already, if not all of them), and
entire basic Cyrillic region (so add-in all the Cyrillic languages there are,
including Russian, Ukrainian, Serbian, Belarusian, Bulgarian, Macedonian,...).

Maintainer Stepan Roh goes to extra trouble to keep them as good as Vera in
original glyphs (including hints, kerning, etc.), so there should be no
regressions. David Jez is starting to work on hinting for added glyphs, so they
will improve as well.

It's released monthly, which means that there's no long wait before new features
are available, and any bugs are fixed. DejaVu 1.6 release due today is mainly a
bug-fix release.

Read all about it at http://dejavu.sf.net/

And that's enough promotion for one day -- hope I convinced someone that it's a
big win :)

http://dejavu.sf.net/: http://dejavu.sf.net/

Johannes Gijsbers (johannes) wrote :

Note that Debian packages have already been prepared by Peter Cernak (RFP:
http://bugs.debian.org/281959). They are available on http://mentors.debian.net,
but haven't been uploaded into the main archive yet.

Those packages only have 1.5: 1.6 is a wild improvement over 1.4 (actually, 1.5
is, and 1.6 has lots of bug fixes for 1.5). DejaVu 1.6 was announced a couple of
hours back.

Martin Bajer (fict10n) wrote :

DejaVu is "must have" font for East European users.
Bitstream Vera is incomplete and de facto useless for East European users.

To be fair, Arev fonts (http://tavmjong.free.fr/FONTS/) also derive from Vera
(but there's only Sans in four styles), and they add Greek as well.

Dennis Kaarsemaker (dennis) wrote :

Breezy has the dejavu font

Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #5)
> Breezy has the dejavu font

It does, but Vera is still the default. DejaVu should be instead. Kubuntu
Breezy does use it as the default. Ubuntu should too.

In addition to all the other advantages previously mentioned, it's simply a more
stylish font as well.

Jeff Waugh (jdub) wrote :

We're now doing fontconfig fallbacks from Vera to DejaVu in dapper.

Tomáš Hudec (tommy-hudec) wrote :

Partial fixes:

This helps in kdm login screen - package kubuntu-default-settings:

sed -i 's/Bitstream Vera/DejaVu/g' /usr/share/apps/kdm/themes/kubuntu/kubuntu.xml

This makes fontconfig to default to other font than Bitstream Vera:
In the file "/etc/fonts/fonts.conf" in "<prefer>" section move Bitstream after DejaVu.

Ricardo Pérez López (ricardo) wrote :

DejaVu font renders text with incorrect kerning, as can be seen in Bug #35470. This could be due to a pango problem. I proposed to revert to Bitstream Vera by default, until that problem is fixed.

The DejaVuSans+Pango bug is fixed in DejaVu 2.4.1.
We'll try to make the font less tight for some character pairs for 2.6 in May.

Pascal de Bruijn (pmjdebruijn) wrote :

Can't Bitstream Vera be removed from the default install, to be replaced by DejaVu (LGC)?

The Fedora Project seems to already have done so:
http://fedoraproject.org/wiki/Fonts/DejaVu

Pascal de Bruijn (pmjdebruijn) wrote :

I did my own packages for dejavu which provides ttf-bitstream-vera, so uninstalling it won't pull OpenOffice.org with it.

It would be nice for this to become the default.

Bitstream Vera only clutters up the font list now.

hackel (hackel) wrote :

Why was this marked Fix Released? ubuntu-desktop still depends on ttf-bitstream-vera, thereby making it the default and impossible to remove. Perhaps the best solution is to follow Pascal's suggestion and add Provides and Conflicts ttf-bitstream-vera to the ttf-dejavu package so that we could at least uninstall ttf-bitstream-vera if we wanted to. Of course someone might want to have both fonts installed (no idea why), so really ubuntu-desktop should just depend on ttf-dejavu.

Changed in ttf-bitstream-vera:
status: Fix Released → Confirmed
Felix Geyer (debfx) wrote :

ttf-bitstream-vera has been removed from karmic.

Changed in ttf-bitstream-vera (Ubuntu):
status: Confirmed → Fix Released
Akkana Peck (akkzilla) wrote :

I just upgraded to karmic beta, and I'm having trouble figuring out how to use dejavu instead of vera for my terminal font. I had
XTerm*font: -bitstream-bitstream vera sans mono-bold-r-normal-*-12-*-*-*-c-*-iso10646-1
(I know that encoding probably wasn't ideal, but it was working) but it's not found in karmic.

If I use xfontsel, I can find dejavu sans mono r, but the only pxlsizes available are 0 and 17, neither of which are anywhere close to the vera sans mono 12.

Please help ... is there some package I'm missing to get dejavu to take the place of vera? I have ttf-dejavu, ttf-dejavu-core and ttf-dejavu-extra installed.

John B. (jbuncher) wrote :

I just wanted to request that the original bitstream vera fonts be made available, or that (if this is possible), a symlink is made that points bitstream to the deja vu fonts. Some programs may specifically look for bitstream fonts and not render correctly if they are not found. I ran into this on Mathematica 6.0.3. It took me forever to figure out which font it was trying to find on the system. Once I told it to do a font substitution on Bitstream Vera Sans, the problems went away. I think it would be a good idea to be able to still have the bitstream fonts installed.

Eric Hedekar (stochastic) wrote :

Why was this package removed from the repositories without even a transitional package put in its place? Many programs still depend upon ttf-bitstream-vera explicitly. This "fix" has broken many other packages.

Justine Tunney (jart) wrote :

I'd also like to express my frustration with this decision. I'm quite happy using DejaVu now, but I can't help but feel a little upset that I had to go to a good deal of trouble figuring out why my favorite programming font went away because someone else felt that its availability Vera did little more than clutter up their font list.

I support the rationale behind moving toward DejaVu, but I don't see any reason to not have the Vera available for those who choose to install it.

It would also be nice if apt-get/packages.ubuntu.com/etc. made it easier to find out why a package is missing, but this would probably be better discussed in another bug. (One simple fix I can think of is putting "bitstream vera" in the ttf-dejavu-* package descriptions so searching for "bitstream" will cause these fonts to show up in Synaptic)

Christian Quast (wildcart) wrote :

Hi I used Bitstream Vera for years now and I don't think that DejaVu is an adequate replacement. What I liked about Bistream Vera most is that it made a clear distinction of the letters lower case 'l' and upper case 'i' ('I') which look exactly the same in Dejavu. Also, the distinction between a zero charcter '0' and an upper case 'o' ('O') was more than just be the width of the character. I see the reasons why DejaVu fonts have been chosen over Bitstream Vera as 'default' fonts but I don't see why Bitstream Vera shouldn't be available in the repository, too?

Christian Quast (wildcart) wrote :

arghhh.... sorry... for unkown reasons I was comparing the Bitstream Vera Mono with DejaVu sans :(

never mind.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.