package should be split in daily use fonts and decoractive fonts

Bug #42922 reported by Denis Moyogo Jacquerye on 2006-05-04
16
Affects Status Importance Assigned to Milestone
ttf-arabeyes (Ubuntu)
Wishlist
Unassigned
ttf-bpg-georgian-fonts (Ubuntu)
Wishlist
Unassigned
ttf-kacst (Ubuntu)
Wishlist
Unassigned

Bug Description

ttf-arabeyes is currently installed by default with *ubuntu-desktop, this means 38 fonts are installed for Arabic script only.

Nothing wrong with that except many of them are purely decorative fonts and are not suited for daily use and even less for non Arabic script users. Cherry on the cake: most of the Latin characters included in the fonts look just like Bitstream Vera fonts or Nimbus Sans L, etc. leaving too many fonts that are identical for Latin script.

The decorative fonts provided by ttf-arabeyes should be in a different package so they are not installed by default just for the sake of fonts count.

Here's a sample of all arabeyes fonts, the name is in the font but with Latin characters (all obviously from Bitstream Vera fonts) with a sample string in Arabic.

Out of the 38 fonts which are useful on a daily basis to Arabic script users?

ttf-kacst has Arabic fonts (one with Farsi style), these could be alternatives to the default ttf-arabeyes fonts.

Unfortunately they all have Latin characters from URW BookmaL.
* URW Bookman L:
KacstArt
KacstBook
KacstDecorative
KacstDigital
KacstFarsi
KacstOne
KacstOneFixed
KacstPoster
KacstQurn
KacstTitle
* URW Bookman L (outline):
KacstTitleL

Vladimer Sichinava (alinux) wrote :

*fonts in ttf-bgp-georgian-fonts*

1. BPG_Chveulebrivi.ttf
 BPG_Chveulebrivi_Bold.ttf
2. BPG_Courier.ttf
 BPG_Courier_Bold.ttf
3. BPG_Elite.ttf
 BPG_Elite_Bold.ttf
4. BPG_Glaho.ttf
 BPG_Glaho_Bold.ttf
5. BPG_Rioni.ttf
 BPG_Rioni_Bold.ttf
 BPG_Unicode_Standard.ttf

1. Chveulebrivi family - can be considered as decorative font.

2. BPG_Courier.ttf(+ respective _Bold.ttf) are monospaced fonts
and are mostly suitable for Graphical Terminal applications.
Ex: gnome-terminal

3. BPG_Elite.ttf(+ respective _Bold.ttf) are Times New Roman style
fonts, and they are useful for Word Processors,on paper typing
and web surfing.

4. BPG_Glaho.ttf(+ respective _Bold.ttf) both delta hinted,
perfect for Word Processors and GUI(GTK,QT)

5. BPG_Rioni.ttf(+ respective _Bold.ttf) are PERFECT
for GUI environment.
Ex:
GNOME GDM:
http://gnome.inet.ge/alinux/ubuntu_screens/desktop/04_georgian_gdm_menu.png
GNOME desktop
http://gnome.inet.ge/alinux/ubuntu_screens/desktop/07_menu_oo.org.png
############################################################################
Things that should be improved for Georgian side in Ubuntu+1:

1)Ubiquity Live Installer

Actually ubiquity uses ttf-freefont's Georgian glyps
that aren't sutable for GUI, and are opaque (pallid) + not delta hinted.
http://www.teutonici.com/Alinux/ubiquity-feisty-georgian.png

So my proposal is to use, BPG_Rioni.ttf or BPG_Glaho.ttf
from ttf-bgp-georgian-fonts instead of ttf-freefont.
Is that possible ?

2)debian-installer
Suggestion is to use:
http://www.unifont.org/fontguide/downloads/fonts/New_Georgian_BDF_Fonts.tar.gz

Daniel T Chen (crimsun) on 2008-09-11
Changed in ttf-arabeyes:
importance: Medium → Wishlist
status: New → Confirmed
Changed in ttf-bpg-georgian-fonts:
importance: Medium → Wishlist
status: New → Confirmed
Changed in ttf-kacst:
importance: Medium → Wishlist
status: New → Confirmed
Jay S (topdownjimmy) wrote :

Is anything being done to address this one way or the other?

Personally I like that I am able to display Arabic characters should I find myself at an Arabic website, purely for aesthetic reasons (as I cannot read Arabic, but hate seeing hex blocks).

Still, ttf-arabeyes is the biggest offender here when it comes to font bloat. A new Ubuntu user who, upon opening OpenOffice.org, encounters dozens of fonts with cryptic names -- all of which look identical to FreeSans, and all of which are stacked at the top of the font list due to their names all beginning with "Al-" -- is bound to be confused. Surely we can get away with providing only one or several Arabic fonts by default, preferably named in such a way that it's clear what they're there for.

Arne Goetje (arnegoetje) wrote :

Starting from Lucid, we only have a single Arabic font installed by default for non-Arabic users, which is ttf-kacst-one. The other fonts of ttf-kacst and ttf-arabeyes can be considered as decorative fonts and are not installed by default anymore.

Regarding Georgian: currently we use the Georgian glyphs in DejaVu Sans by default. ttf-bgp-georgian-fonts is therefor not installed by default. Do we need to change anything here?

Changed in ttf-kacst (Ubuntu):
status: Confirmed → Fix Released
Changed in ttf-bpg-georgian-fonts (Ubuntu):
status: Confirmed → Incomplete
Changed in ttf-arabeyes (Ubuntu):
status: Confirmed → Incomplete
Arne Goetje (arnegoetje) wrote :

Closed, since the situation described in the original bug report is not valid anymore.

Changed in ttf-arabeyes (Ubuntu):
status: Incomplete → Invalid
Changed in ttf-bpg-georgian-fonts (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers