Tsung built with misconfigured paths

Bug #1634143 reported by Adam Lindberg
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tsung (Ubuntu)
Undecided
Unassigned

Bug Description

* Running Tsung requires it to find the path "../../../../../share/tsung/templates/style" in order to show the web UI
* Tsung binaries are installed to /usr/lib/x86_64-linux-gnu/erlang/lib/tsung_controller-1.6.0/ebin
* Share path is at /usr/share/tsung/templates/style/

Tsung assumes that there is no x86_64-linux-gnu folder in the path and therefore cannot find its shared files. This makes Tsung unable to start with the error:

    Can't start ! {error,
                      {{badmatch,{error,enoent}},
                       [{ts_controller_sup,start_inets,1,
                            [{file,"src/tsung_controller/ts_controller_sup.erl"},
                             {line,105}]},
                        {ts_controller_sup,init,1,
                            [{file,"src/tsung_controller/ts_controller_sup.erl"},
                             {line,91}]},
                        {supervisor,init,1,[{file,"supervisor.erl"},{line,287}]},
                        {gen_server,init_it,6,
                            [{file,"gen_server.erl"},{line,328}]},
                        {proc_lib,init_p_do_apply,3,
                            [{file,"proc_lib.erl"},{line,240}]}]}}

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: tsung 1.6.0-1
ProcVersionSignature: User Name 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
Date: Mon Oct 17 13:43:09 2016
Ec2AMI: ami-191de376
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-central-1b
Ec2InstanceType: t2.micro
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
SourcePackage: tsung
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Adam Lindberg (eproxus) wrote :
Revision history for this message
Adam Lindberg (eproxus) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tsung (Ubuntu):
status: New → Confirmed
Revision history for this message
Cameron (me-cameroncurrie) wrote :

The tsung_stats.pl file is also not available to the app in $PATH or in any of the valid script paths it searches: https://github.com/processone/tsung/blob/v1.6.0/src/tsung_controller/ts_web.erl#L94-L97

Revision history for this message
Rui (rui-doc) wrote :

Note: if you, like me, need to get this working, you can always create a soft link so the path matches:

$ cd /usr/lib
$ sudo ln -s /usr/share/ share

Result: /usr/share == /usr/lib/share

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tsung - 1.7.0-3

---------------
tsung (1.7.0-3) unstable; urgency=medium

  * debian/patches:
    - 03_correct_lib_path.diff: Fix relative path to
      `/usr/lib/$(DEB_HOST_MULTIARCH)/tsung/bin`
      (Closes: #873678) (LP: #1634143)

 -- Ignace Mouzannar <email address hidden> Thu, 16 Nov 2017 00:55:06 -0500

Changed in tsung (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers