Error message on ending VNC session

Bug #8422 reported by ChristofferS
98
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tsclient
Unknown
Unknown
tsclient (Ubuntu)
Medium
Unassigned
Nominated for Dapper by Daniel Hahler
Nominated for Jaunty by Xvani
Nominated for Karmic by Xvani

Bug Description

On ending a VNC session using tsclient - closing the window - , I get a very big
error message.

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

Created an attachment (id=188)
Screenshot of error message

Revision history for this message
Sebastien Bacher (seb128) wrote :

same problem here, upstream issue

Revision history for this message
Matt Zimmerman (mdz) wrote :

Is there a corresponding upstream bug report?

Revision history for this message
Sebastien Bacher (seb128) wrote :

(In reply to comment #3)
> Is there a corresponding upstream bug report?

no, tsclient upstreams don't have a bug report system afaik, only an homepage ...

Revision history for this message
趙惟倫 (chaoweilun) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

thanks, marking the bug PENDINGUPLOAD

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

What it the status of this?

It should have been uploaded by now, I suppose.

Revision history for this message
Sebastien Bacher (seb128) wrote :

it has been fixed with the current version

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

I still see the error when i close the VNC window.

Revision history for this message
Dennis Kaarsemaker (dennis) wrote :

Are you using tsclient 0.140-1ubuntu2 ?

Revision history for this message
ChristofferS (ubuntu-curo) wrote :

dpkg -l tsclient
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii tsclient 0.140-1ubuntu2 front-end for viewing of remote desktops in

yes, I am.

Are you not seeing this?

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

I have this problem as well on an up to date Dapper, almost a year after the bug was first reported..

What would be great is to have a clean way of ending the session. Clicking on the window's "X" isn't very graceful is it. What would be nice would be that when you click on the applet, under the single and lonely "New connection..." button, we would have an option/entry to close the session(s).

Applet
---------
New Connection...
End Session #1 : VNC connected to XXX
End Session #2 : RDP connected to YYY

something like that. Usability wise, that's what I was searching for initially anyway, before realising the only way was to click the "X" in the windows border.

Matt Zimmerman (mdz)
Changed in tsclient:
status: Unconfirmed → Confirmed
Revision history for this message
admarginem (admarginem) wrote :

yes, I can confirm this bug!

Revision history for this message
admarginem (admarginem) wrote :

it seems, that this bug is dupplicate of this:
https://launchpad.net/distros/ubuntu/+source/tsclient/+bug/22644

I

Revision history for this message
Phil Housley (undeconstructed) wrote :

I don't know what happened to the fix for this, but the problem is still there today, with exactly the same error message as when this was reported.

Revision history for this message
RK (rkrishc+ubuntu) wrote :

Still seeing this error.

XX@YY:~$ dpkg -l tsclient
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============- ============================================
ii tsclient 0.140-3ubuntu1 front-end for viewing of remote desktops in

Revision history for this message
Leo Howell (leo-howell) wrote :

vncviewer spews out lots of debug messages on stderr. The attached patch suppresses the error message whenever vncviewer returns successfully (exit status 0).

Revision history for this message
Jonh Wendell (wendell) wrote :

As illustrated on bug 74220, this also happens with a windows connection (rdesktop client), not only vnc.

I think we should change this bug title to
'Error message on ending remote session'

It seems that tsclient captures all output generated by its child processes (vncviewer, rdesktop) and thinks they are errors.

Revision history for this message
compucoder (roncr) wrote :

I can also confirm this happens on a RDC connection to a windows server. I am using Feisty Herd 4. This isn't a show stopper - just ugly and if easily fixed it should be. We don't error aestetics deterring new potential Linux users.

Revision history for this message
yop (yop) wrote :

Yes. I also do have this on RDP.

** (tsclient:15178): WARNING **:
X Error of failed request: BadAtom (invalid Atom parameter)
  Major opcode of failed request: 23 (X_GetSelectionOwner)
  Atom id in failed request: 0x0
  Serial number of failed request: 7445
  Current serial number in output stream: 7445

  Terminal Server Client for GNOME
  a frontend for rdesktop
  tsclient version 0.148

Linux ubuntu 2.6.17-11-generic #2 SMP Tue Mar 13 23:32:38 UTC 2007 i686 GNU/Linux

Revision history for this message
Jonh Wendell (wendell) wrote :

Fixed on upstream.

Changed in tsclient:
status: Confirmed → Fix Committed
Revision history for this message
Peter Matulis (petermatulis) wrote :

Any idea on when this fix will be appear in the update repositories?

Revision history for this message
Peter Matulis (petermatulis) wrote :

Confirm similar behaviour when connecting to WXP Pro via RDP with tsclient 0.148 (and rdesktop 1.5.0) on Feisty.

** (tsclient:7987): WARNING **:
Autoselected keyboard map en-us
X Error of failed request: BadAtom (invalid Atom parameter)
  Major opcode of failed request: 23 (X_GetSelectionOwner)
  Atom id in failed request: 0x0
  Serial number of failed request: 3853
  Current serial number in output stream: 3853

Revision history for this message
altaaa (altaaa) wrote :

If all you're getting is the keyboard error (for example, Autoselected keyboard map en-us), this can be fixed by selecting a keyboard language in Terminal Server Client under the Local Resources tab. Worked for me.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Upstream fixed it for the next version (probably 0.150).
The patch can be found at: http://tsclient.svn.sourceforge.net/viewvc/tsclient?view=rev&revision=17
In Gutsy we now have 0.148-3ubuntu1, which should still have this error.

Changed in tsclient:
status: Fix Committed → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

why did you change the bug settings?

Changed in tsclient:
status: Confirmed → Fix Committed
Revision history for this message
Daniel Hahler (blueyed) wrote :

Sorry.
I've changed the status, because it did not appear as "fix committed" to me (according to https://wiki.ubuntu.com/Bugs/Status).
But it's probably "For package maintainers, the changes are pending and to be uploaded soon (it's what PENDINGUPLOAD was in Bugzilla)" then.

Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

Fixed: hardy has 0.150-1

Changed in tsclient:
status: Fix Committed → Fix Released
Revision history for this message
libertyernie (libertyernie) wrote :

Not fixed! Hardy still has the same problem.

Daniel Hahler (blueyed)
Changed in tsclient:
status: Fix Released → Fix Committed
Revision history for this message
libertyernie (libertyernie) wrote :

Not fixed in hardy!

Changed in tsclient:
status: Fix Committed → Confirmed
Changed in tsclient:
assignee: seb128 → nobody
Revision history for this message
Jordan Erickson (lns) wrote :

Not sure about Hardy but I still encounter this issue (related to the keyboard map) in Gutsy. It doesn't seem to be rdesktop/vncviewer specific, as different errors (are they errors or just debug info?) occur at disconnect. See my two attachments for rdesktop and vncviewer sessions (via tsclient) respectively.

Revision history for this message
Jordan Erickson (lns) wrote :
Revision history for this message
MountainX (dave-mountain) wrote :

Can anyone confirm whether this problem is related to the problem in tsclient where a custom keyboard layout sends the wrong keys to the Windows server?

To reproduce (in Ubuntu Hardy beta using US english settings):
Go to System > Preferences > Keyboard
click Layouts tab and then click Layout Options button below
In the dialog window that opens, expand Ctrl key position
click "swap ctrl and CapsLock" (or probably any other non-default option)
test locally that the keys have been swapped
open tsclient and log on to Windows server
test the control key behavior. You should find that it is very screwed up. I have seen several different scenarios. My current one is that the old capslock (which is the ctrl key at the client now) is not the ctrl key nor the caps lock key at the server. The right ctrl key doesn't work on the server at all and the left ctrl key (which is correctly acting as the capslock on the client) is back to being a ctrl key on the remote server.

With other keyboard layout options (such as make capslock an addtitional ctrl key) I have found that none of the keys will send a ctrl signal to the server.

Revision history for this message
Kevin Zembower (kzembowe) wrote :

Still seems to be present in tsclient 0.150 in Hardy Heron 8.0.4, as of 30-July-2008.

Thanks for looking into this.

-Kevin

Revision history for this message
Tralalalala (tralalalala) wrote :

This bug is still present in Ubuntu 9.04 RC.

Revision history for this message
Xvani (fredrile+launchpad) wrote :

Present in Ubuntu 9.04 too. Tsclient 0.150

Revision history for this message
Tralalalala (tralalalala) wrote :

By default TSClient uses the protocol "RDP". This gives me an error everytime. After switching the protocol from "RDP" to "RDPv5" I haven't encountered anymore problems. I've been using "RDPv5" for more than a month now and everything works flawlessly.

Revision history for this message
Martin Koniczek (martin-koniczek) wrote :

9.04 / Tsclient 0.150 still seems to produce the "error dialog" box whenever there is any output from rdesktop.

Switching to RDPv5 reduced the number of lines being spit out by rdesktop, but I can not reduce them to zero: "Autoselected keyboard map en-us" still remains (connecting to a german windows xp), and tsclient wants to reconnect after 30 seconds.

There is also a feature request to be able turn of "Auto-Reconnect" on tsclient's source forge site, that would be another workaround.

Revision history for this message
ITCons (a-schmid) wrote :

Same error here on ubuntu karmic, 9.10
Running on an atom system with rdesktop

This is the exact error message:

WARNING: Remote desktop does not support colour depth 24; falling back to 16
X Error of failed request: BadAtom (invalid Atom parameter)
Major opcode of failed request: 23 (X_GetSelectionOwner)
Atom id in failed request: 0x0
Serial number of failed request: 1990
Current serial number in output stream: 1990

This was when starting rdesktop with RDP version 4, I am now testing if it is stable when starting with RDP version 5. Will report back.

Revision history for this message
Nigel Babu (nigelbabu) wrote :

If somone could confirm this bug happens on Maverick it would be great. I checked out the patch and it doesn't apply. Marking as patch-needswork

tags: added: patch-needswork
Changed in tsclient (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Ken Sharp (kennybobs) wrote :

Still present in Natty

Changed in tsclient (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
robbert (robbertvandendoorn) wrote :

Ken Sharp (kennybobs) wrote on 2011-09-27:
"Still present in Natty"

Of course it's still present. What did you expect? This bug to be fixed? Of course not. In the Linux world bugs it's common to not fix bugs. Just live with it or use another operating system. It's as easy as that.

Revision history for this message
Jordan Erickson (lns) wrote :

@robbert: s/Linux/Ubuntu/ ;)

Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

Closing this bug as tsclient is no longer in the Ubuntu archives (starting from Oneiric).
The default remote desktop client in Ubuntu is now Remmina.

Changed in tsclient (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.