tsclient should recognize Xephyr for XDMCP login

Bug #217798 reported by Pat Double on 2008-04-15
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
tsclient (Baltix)
Undecided
Unassigned
tsclient (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tsclient

Please forgive my ignorance if I am mistaken, but I believe Xephyr is a superior alternative to Xnest. I think tsclient should recognize Xephyr for XDMCP logins in addition to Xnest. I installed xserver-xephyr but tsclient did not recognize it. Unfortunately the arguments to Xnest and Xephyr are not the same.

LCID Fire (lcid-fire) wrote :

I second that. This would resolve my bug #228977

juicemansam (juicemansam) wrote :

I'd prefer the detection by tsclient, but this can be easily solved by making a link to Xephyr (ie. ln -s Xephyr Xnest).

Pat Double (patdouble) wrote :

Did you try making the link? I tried that at the time of the bug report and it did not work because the arguments to Xephyr and Xnest are different. See my initial comments.

Onno Benschop (onno-itmaze) wrote :

The arguments for Xephyr and Xnest appear to be mostly the same.

The call that tsclient makes is:
 Xnest :1 -once -geometry 1024x768 -query 127.0.0.1

The equivalent Xephyr call is:
 Xephyr :1 -once -screen 1024x768 -query 127.0.0.1

I'd not be surprised if there are other parameters that tsclient sends with different options. I've created a tiny bash script which substitutes geometry with screen.

To make this work, place the script in /usr/bin as Xnest (making sure you rename Xnest first (I use Xnest.bin)

David Ayers (ayers) wrote :

It seems that a newer upstream release (2.0.1) may support Xephyr yet I haven't been able to build it yet on Lucid:

http://sourceforge.net/projects/tsclient/

AtesComp (atescomp) wrote :

Here is a patch to use Xephyr. It worked well for me on Ubuntu 9.10. Not much to it.

tags: added: patch
AtesComp (atescomp) wrote :

Here is an updated patch for Maverick.
Apply all patches (tsclient/debian/patches/) in order to the Maverick branch, then this one.

Closing this bug as tsclient is no longer in the Ubuntu archives (starting from Oneiric).
The default remote desktop client in Ubuntu is now Remmina.

Changed in tsclient (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers