please drop build-dependency on g++-4.9

Bug #1452341 reported by Steve Langasek on 2015-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
trust-store (Ubuntu)
Critical
Thomas Voß

Bug Description

The trust-store package currently has a build-dependency on g++-4.9. This build-dependency is present because of the recommendations on https://wiki.ubuntu.com/cpp-11 about handling of C++11.

The C++11 ABI has now stabilized in gcc as of gcc 5; however, before we can switch to gcc 5, we first need to be able to do rebuild tests of the archive against this compiler.

To facilitate this, please drop the build-dependency on g++-4.9 from the package in wily. 4.9 will remain the default until all transition issues have been identified, so there is no risk of accidental ABI breakage here anymore.

Related branches

Steve Langasek (vorlon) on 2015-05-06
tags: added: lsd-cxx11
Matthias Klose (doko) wrote :

raising importance, prevents build using GCC 5, which will become the default at the end of July

Changed in trust-store (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-15.07
status: New → Confirmed
Changed in trust-store (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
Changed in trust-store (Ubuntu):
status: Confirmed → In Progress
Matthias Klose (doko) wrote :

now built in the silo16 PPA

Changed in trust-store (Ubuntu):
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2015-08-17
Changed in trust-store (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers