[CTA] Apps shown in permission list even when they have been uninstalled

Bug #1389775 reported by Ken VanDine on 2014-11-05
238
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
webapps-sprint
Critical
David Barth
click (Ubuntu)
High
Alexandre Abreu
trust-store (Ubuntu)
High
Thomas Voß
ubuntu-system-settings (Ubuntu)
Medium
Jonas G. Drange

Bug Description

If you uninstall an app that has used the location service, or any other permission, it still appears in the model but without a title or icon.

Per UX design and to meet certification requirements we will remove the entry from the trust store when the app is uninstalled.

These entries also occur when a framework becomes unsupported, any app requiring the deprecated framework becomes unregistered.

Tags: bq Edit Tag help

Related branches

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Matthew Paul Thomas (mpt) wrote :

Specification updated. <https://wiki.ubuntu.com/AccountPrivileges?action=diff&rev2=18&rev1=17> As briefly explained there, I disagree that we should remember trust-store records for uninstalled apps, for a couple of reasons. Most importantly, it's possible that you accidentally declined app access to something, and didn't realize or forgot that you did. In that case, uninstalling and reinstalling would give you a chance to correct your mistake. Also, a new version of an app might use a privilege for quite different reasons from the version you had installed years ago.

Changed in ubuntu-system-settings (Ubuntu):
importance: Low → Undecided
status: Confirmed → Triaged
Ken VanDine (ken-vandine) wrote :

The trust-store will need to remove it's record when a package is uninstalled.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in trust-store (Ubuntu):
status: New → Confirmed
tags: added: bq
Evan Wang (wsy324) wrote :

The issue still exist on latest image vivid r147.

$ system-image-cli -i
current build number: 147
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-10-10 02:00:44
version version: 147
version ubuntu: 20151009
version device: 20150821-736d127
version custom: 20150925-901-35-40-vivid

Pat McGowan (pat-mcgowan) wrote :

@thomas this yours?

Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → Medium
milestone: none → backlog
status: New → Confirmed
Changed in trust-store (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
Changed in trust-store (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Bill Filler (bfiller)
Bill Filler (bfiller) on 2016-03-15
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Thomas Voß (thomas-voss)
Pulsar33 (pulsar33-ubone) wrote :

Not limited to location permission. Camera permission is affected too.
Snapshot here : https://framapic.org/5Noqr82nn2aT/GLn4HpgeBdaH.png

Thomas Feldmann (thomas-wiw) wrote :

It is actually the case in all of the permissions pages on my phone.

description: updated
summary: - location access, shouldn't show apps in the list that have been
- uninstalled
+ Apps shown in permission list even when they have been uninstalled
Changed in canonical-devices-system-image:
milestone: backlog → 12
importance: Medium → Critical
description: updated
Changed in canonical-devices-system-image:
milestone: 12 → 12.1
Changed in canonical-devices-system-image:
assignee: Thomas Voß (thomas-voss) → David Barth (dbarth)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
summary: - Apps shown in permission list even when they have been uninstalled
+ [CTA] Apps shown in permission list even when they have been uninstalled
David Barth (dbarth) on 2016-07-05
Changed in webapps-sprint:
milestone: none → sprint-24
assignee: nobody → David Barth (dbarth)
importance: Undecided → Critical
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
David Barth (dbarth) on 2016-07-11
Changed in webapps-sprint:
status: New → In Progress
Changed in canonical-devices-system-image:
milestone: fi → 13
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in click (Ubuntu):
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → In Progress
Changed in trust-store (Ubuntu):
status: Confirmed → In Progress
Pat McGowan (pat-mcgowan) wrote :

Once this is fixed empty entries will no longer be possible but for existing trust.dbs in this state the settings app should not show records for apps it cannot find.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
importance: Undecided → Medium
status: Invalid → Confirmed
description: updated
Changed in canonical-devices-system-image:
milestone: 13 → cta
Remco H. (remco-hage) wrote :

this is also in security & privacy > program rights? > location

programs don't seem to be cleaned very well after installation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments