GNOME needs a "Trash Autopurge" functionality

Bug #150112 reported by antistress on 2007-10-07
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Wishlist
gnome-settings-daemon (Ubuntu)
Wishlist
Unassigned
trashapplet (Ubuntu)
Undecided
Unassigned

Bug Description

Trash purge is typically a function that could be automated.

Most applications propose such a functionnality (i.e. my webmail let me configure it to automatically delete messages in the trash after 7 days)

At present time lots of people get bored with emptying the trash so they prefer definitely delete files (shift+suppress)
But sometimes they make a mistake and regret it : they've lost the way to restore the file by refusing using the trash
See the paradox : the trash is a funtionnality that people want but refuse to use. It could be the sign that the fuctionnality has usability drawbacks and that it should be improve...

Moreover people doesn't want to empty the trash in real life : why would they enjoy doing it on their computer ?!

The improvement could consist in automatically suppressing the files in the trash can after a couple of days. It means that the system must know when each file has been moved to the trash can to be able to supress them selectively. Of course it should be optionnal

Changed in nautilus:
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :
Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Triaged
antistress (antistress) wrote :

yes, thanks

Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
status: Unknown → Confirmed
Inkwina (phsi) wrote :

tmpreaper offers some of the functionality sought here. Having the trash applet offer a gui interface for adding a cron entry for tmpreaper on .Trash could be part of the solution. But this would be based on access time not date when moved to trash.

Ideally an option to auto purge the trash based on the amount of disk space used should also be available.

antistress (antistress) wrote :

Could GVFS help to get Trash Autopurge based on date deletion ?

antistress (antistress) wrote :

here is a great mockup of what could be done http://jeff.ecchi.ca/blog/images/trash-individual-files-expiry.png

antistress (antistress) wrote :

(the above mockup is from that article : I Don’t Want to Care About Trash http://jeff.ecchi.ca/blog/?p=335 )

Daniel T Chen (crimsun) on 2008-11-27
Changed in trashapplet:
status: New → Invalid
kikl (kilian-klaiber) wrote :

I support the idea. If the file is older than a month, you probably have forgotten all about it. So deleting it automatically would probably be uncritical. It would be a great option for automatically managing the trash. In case you do need to untrash a file, it is more easily found. A true usability improvement in my mind.

Changed in nautilus:
status: Confirmed → Fix Released
antistress (antistress) wrote :

Now that gnome-bugs #89706 (which adds 'arrange by trash time' options in nautilus list and icon view) is fixed, shall i fill another bug specifically for the Trash Autopurge functionality ?

antistress (antistress) wrote :

(i mean : on bugzilla)

Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream.
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

@antistress: Yes , a new upstream bug would be better , else this bug would be a dup of lp Bug #301552 ;-)

Changed in nautilus (Ubuntu):
status: Triaged → Confirmed
Changed in nautilus:
importance: Unknown → Undecided
status: Fix Released → New
Vish (vish) wrote :

Both the upstream bugs were for a column in the trash folder , but not a auto-purge function , hence removing upstream bug

Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
tags: added: trash
Changed in nautilus:
status: Unknown → Confirmed
Vish (vish) wrote :

Thanks for finding the relevant upstream bug.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
summary: - GNOME needs a "Trash Autopurge" functionnality
+ GNOME needs a "Trash Autopurge" functionality
Sancho Panza (prashanthr) wrote :

@antistress: Please check if your new bug report is a dupe of the ones already in remote bug watch above.

antistress (antistress) wrote :

indeed

Changed in nautilus:
importance: Unknown → Wishlist
Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The feature is being added upstream for GNOME 3.8

affects: nautilus (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.