Package is incompatible with repository version of the main Transmission app's RPC

Bug #551526 reported by AllenS
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
transmissionrpc (Debian)
Fix Released
Unknown
transmissionrpc (Ubuntu)
Medium
Andrew Starr-Bochicchio

Bug Description

Binary package hint: python-transmissionrpc

Description:Ubuntu lucid (development branch)
Release: 10.04

python-transmissionrpc:
  Installed: 0.3-2
  Candidate: 0.3-2
  Version table:
 *** 0.3-2 0
        500 http://mirror.internode.on.net/pub/ubuntu/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

The squeeze version of python-transmissionrpc uses transmission RPC version 1.7x

The current version of transmission in squeeze is 1.92 which uses the newer trunk version - http://trac.transmissionbt.com/browser/trunk/doc/rpc-spec.txt

Unfortunately there has been a breaking change in the spec. Many attributes have been moved into the 'trackerStats' array - e.g. seederCount.

The following script will demonstrate the problem:

***
#!/usr/bin/python

import transmissionrpc

tc = transmissionrpc.Client('localhost', port=9091, user='transmission', password='transmission')

torrent = tc.info(1)[1]

print torrent.trackerStats[0]['seederCount']
***

Actual output:
Traceback (most recent call last):
  File "./transmission-control", line 9, in <module>
    print torrent.trackerStats[0]['seederCount']
  File "/usr/lib/pymodules/python2.5/transmissionrpc/transmission.py", line 86, in __getattr__
    raise AttributeError('No attribute %s' % name)
AttributeError: No attribute trackerStats

Expected output:
<an integer>

I have tried my test script with version 4.0 of transmissionrpc it works correctly.

Regards
AllenS

Changed in transmissionrpc (Debian):
status: Unknown → Fix Released
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

sorry, I guess I don't understand exactly what you're requesting? In particular, what (package) is broken at the moment, and which version from (debian?) would fix that?

Thanks,
   Stefan.

Changed in transmissionrpc (Ubuntu):
status: New → Incomplete
Revision history for this message
Christian Kampka (kampka) wrote :

Hi Stefan,

version 0.3 of python-transmissionrpc is not compatible with transmission 1.92 which is packed in Lucid. Thus, the package is simply not usable with a Lucid transmission installation.
Version 0.4 as available in Debian fixes this issue.
Since it is a pure python package, it can be easily imported from Debian.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Christian, thanks for clearing it up. Now it all makes sense.

FFe granted, please go ahead.

Changed in transmissionrpc (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

I uploaded 0.4 in Debian. New upstream version is compatible with transmission >= 1.8, while current one generates tracebacks as shown above. It definitely needs an update.

Changed in transmissionrpc (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
importance: Medium → Wishlist
importance: Wishlist → Medium
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote : Fwd: [ubuntu/lucid] transmissionrpc 0.4-1 (Waiting for approval)

---------- Forwarded message ----------
From: Ubuntu Installer <email address hidden>
Date: Sat, Apr 17, 2010 at 2:35 PM
Subject: [ubuntu/lucid] transmissionrpc 0.4-1 (Waiting for approval)
To: Andrew Starr-Bochicchio <email address hidden>

transmissionrpc (0.4-1) unstable; urgency=low

 [ Luca Falavigna ]
 * New upstream release.
   - Support for Transmission 1.8 and newer (Closes: #575897).
   - Do not raise an exception if the same torrent is being added twice,
     warn user instead (Closes: #569178).
 * Bump Standards-Version to 3.8.4, no changes required.

Date: Tue, 06 Apr 2010 22:44:05 +0200
Changed-By: Andrew Starr-Bochicchio <email address hidden>
Maintainer: Debian Python Modules Team
<email address hidden>
Origin: debian/unstable
https://launchpad.net/ubuntu/lucid/+source/transmissionrpc/0.4-1

==

Announcing to <email address hidden>

Thank you for your contribution to Ubuntu.

--
You are receiving this email because you are the uploader, maintainer or
signer of the above package.

Changed in transmissionrpc (Ubuntu):
status: In Progress → Fix Committed
Changed in transmissionrpc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.