New torrent file creation dialog should have a manual piece size selection option

Bug #986451 reported by Bob Bib on 2012-04-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Transmission
Won't Fix
Unknown
transmission (Debian)
Fix Released
Unknown
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

New torrent file creation dialog should have a manual piece size selection option (e.g. a drop-down list with "Auto" selected by default).
Automatic piece size decision looks to be optimal, but sometimes it is necessary to manually select the piece size.
If a torrent is created from a rather cumbersome structure of files and folders, it becomes rather big too, and some trackers don't like such big torrent files. As a workaround, user sometimes needs to create torrent files with other programs, because Transmission (including the CLI version) doesn't support the manual piece size selection.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: transmission-gtk 2.51-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Sat Apr 21 04:17:03 2012
SourcePackage: transmission
UpgradeStatus: Upgraded to precise on 2012-03-07 (44 days ago)

Bob Bib (bobbib) wrote :
Changed in transmission:
status: Unknown → Won't Fix
Changed in transmission (Debian):
status: Unknown → Confirmed

Closing the report as the suggestion was rejected upstream. If anybody still wants to pursue this idea, in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ it can be discussed, voted by the community and reviewed by developers.

Changed in transmission (Ubuntu):
status: New → Invalid
Omer Akram (om26er) wrote :

Closing this bug since the upstream decided not to fix it. Thanks for your report.

Changed in transmission (Ubuntu):
status: Invalid → Won't Fix
Changed in transmission (Debian):
status: Confirmed → Fix Released
Bob Bib (bobbib) wrote :

Fixed in transmission 2.80-0ubuntu1
(use the 'transmission-create' utility from a 'transmission-cli' package).

Bob Bib (bobbib) on 2013-07-09
affects: transmission (Ubuntu) → deluge
affects: deluge → transmission (Ubuntu)
no longer affects: transmission (Ubuntu)
Changed in transmission (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.