Error: Unable to save resume file: File name too long

Bug #788626 reported by Andy Owen on 2011-05-26
188
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Transmission
New
Unknown
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: transmission

I'm trying to download a torrent (from http://www.jamendo.com/en/album/48348) but I get the message:

"Error: Unable to save resume file: File name too long"

and I don't see that there is much I can do about that. It would be nice if transmission dealt with the problem itself and made up a shorter name for itself, as I have no idea how to shorten the name myself.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: transmission-gtk 2.05-0ubuntu0.2
Uname: Linux 2.6.37-rc4-fireworks2 x86_64
Architecture: amd64
Date: Fri May 27 00:06:46 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/transmission
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/usr/bin/zsh
SourcePackage: transmission

Andy Owen (the-new-andy) wrote :
teledyn (garym-teledyn) wrote :

Failure to comply with the directed wishes AND failure to emphatically notify the user of the problem is an unacceptable error; I only noticed this notification by accident today looking through my 'Paused' list, otherwise I would never have known what happened to these files.

Microsoft DOS is capable of truncating a too-long filename to fit in 8 Chars; even a Jolliet CD will still save the file simply (and abruptly) truncated to the limit. Surely a unix program should be at least as competent with limit conditions :)

Changed in transmission:
status: Unknown → Won't Fix
Stuart Bishop (stub) wrote :

Per Bug #344878, this is much more likely to be triggered with encrypted home directories.

Changed in transmission:
status: Won't Fix → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in transmission (Ubuntu):
status: New → Confirmed

I have a temporary workaround until this issue is fixed. It seems indeed that it occurs on encrypted home directories, so the solution is to move the files away from that. Note that the files you move away from your encrypted home directory are (obviously) no longer encrypted...

Anyway, this worked for me (execute in terminal):

# 1. exit Transmission (properly exit)
killall transmission
ps aux | grep transmission | grep -v grep # should yield nothing

# 2. move the resume directory (where transmission keeps the resume files) to a non-encrypted directory:
mv ~/.config/transmission/resume /tmp/transmission-resume

# 3. make a symbolic link from the original location to the new one:
ln -s /tmp/transmission-resume ~/.config/transmission/resume

Obviously, it's also a good idea to *save* these files with long file names in a non-encrypted directory.

Tina Russell (tinarussell) wrote :

Using Transmission 2.82, now there’s a feature where you can rename the file yourself in the torrent properties dialog... but, if it’s a single-file torrent and the name is too long (and, I would imagine, if the base folder in a multi-file torrent has a name that’s too long), that overly-long file name _still_ gets used for the resume file, and you’ll still get this blasted error message. What a pain...

Felix Moreno (info-justdust) wrote :

Still present in buntu 14.04 and transmission 2-82
example this torrent:
https://kickass.so/h264-mkv-ac3-eng-sub-ita-eng-guida-galattica-per-autostoppisti-hitchhiker-s-guide-to-the-galaxy-bbc-1981-s01e01-06-t6196446.html

The name of the torrent or magnet is too long, but not the files inside, so is not a problem of encrypted file system, is just that to download the torrent it tries to create a temporal file with the name of the torrent, even if the torrent has no long file names on it...

To fix it, in a crappy way, just edit the magnet link and remove a few chars, and the torrent will download.

So a fix for this kinf of error is just temporal torrent file to not be longer than for example 40 chars, is jsut a temporal name to start the donwloading.

I mean if the files inside the torrent are too long for a encrypted fs ok, (that I think is also a problen of ecryptfs), but if it's just the name of the torrent, why use it exactly as it was written (so often people creates long torrents name for search engines to be easily found like the one y pointed here), not necessary to allow users to create files just with the name, I imagine transmission takes care of this for security reasons and checks the name of the torrent, I hope no directory name inyection is possible playi8ng with transmission temporal file names...

Robert Tari (robert-tari) wrote :

This bug is still present in Ubuntu 15.10, Transmission 2.84 (14307)

Kip Warner (kip) wrote :

Hey Robert. I'm also observing this same bug with an encrypted home directory on Transmission 2.84 (14307) on Ubuntu 15.10 (amd64).

Ari Torhamo (ari-torhamo) wrote :

I'm experiencing this on Ubuntu 16.10. The file system is non-encrypted.

Thanks Felix Moreno for the "crappy" solution to get around the problem. It seems to work fine. I didn't see the solution offered in any any other discussions that I read around the web.

PabloAB (pabloab777) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.