Ubuntu

Transmission-gtk freezes on blocklist update

Reported by Juho Teperi on 2011-03-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
Transmission
Invalid
Unknown
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream bug: http://www.nvnews.net/vbulletin/showthread.php?p=2408692

When I start transmission it freezes completely after few seconds.
Freeze doesn't happen when I run transmission-gtk through gdb (with handle SIGPIPE nostop noprint pass) or when I run strace.
Doesn't happen in transmission-qt either.
Also happens with transmission 2.22 from ppa.

Attached gdb backtrace log, gdb attached to already frozen transmission-gtk with --pid.

Natty, transmission-2.13-0ubuntu4.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: transmission-gtk 2.13-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Mar 14 04:49:06 2011
ExecutablePath: /usr/bin/transmission-gtk
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LC_MESSAGES=en_GB.utf8
 LANG=fi_FI.utf8
 LANGUAGE=en
SourcePackage: transmission
UpgradeStatus: Upgraded to natty on 2011-02-06 (36 days ago)

Juho Teperi (deraen) wrote :

On Mon, Mar 14, 2011 at 3:57 AM, Juho Teperi <email address hidden> wrote:
> ** Attachment added: "Backtrace"
>   https://bugs.launchpad.net/bugs/734615/+attachment/1906990/+files/gdb-transmission.log
>
> --
> You received this bug notification because you are subscribed to
> transmission in ubuntu.
> https://bugs.launchpad.net/bugs/734615
>
> Title:
>  transmission freezes
>

Are you either using disk encryption (or home folder encryption) or
trying to save to NTFS partition?

No. Folder I'm using for torrents is ext4 on lvm volume on raid5.

Juho Teperi (deraen) wrote :

I found that freeze is caused by blocklist update.
I disabled blocklist automatic updates and transmission-gtk doesn't freeze after start.
Freeze happens still with manual update from preferences.

summary: - transmission freezes
+ Transmission-gtk freezes on blocklist update
Charles Kerr (charlesk) wrote :

I don't see how that backtrace can be correct:

> #0 0x00007fcd17fbf743 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #1 0x00007fcd15b9d84d in ?? () from /usr/lib/nvidia-current/tls/libnvidia-tls.so.270.30
> #2 0x0000000000464d26 in ?? ()
> #3 0x00000000004650fc in _tr_blocklistSetContent ()
> #4 0x0000000000452ada in tr_blocklistSetContent ()

libtransmission doesn't know anything at all about graphics drivers or GL.

Would it be possible for you to install a debuginfo version of Transmission so that we can get line numbers and more details in the backtraces?

Juho Teperi (deraen) wrote :

Here's backtrace with tranmission-dbg.

Anssi Hannula (anssi-hannula) wrote :

Regarding the appearance of libGL.so.1 in the backtrace:
I've seen similar cases in e.g. XBMC (not the same bug as this one, though, as the ones I've seen have been fixed already in the nvidia driver), and I think the nvidia GL library somehow taps into thread creation/destruction, running some of its own code on those occasions.

Charles Kerr (charlesk) wrote :

Juho, thanks for the log!

Other than the presence of nvidia and GL, the log doesn't seem so bad. However since a ticket's been filed, I'm guessing this isn't just a temporary freeze?

blocklistClose() only makes two function calls -- munmap() and close(). My guess is somehow munmap() is failing.

First I'd like to see if the nvidia driver really *is* interfering or if that's a red herring. If you try switching to a different video driver for a testing session, does Transmission still freeze?

Charles Kerr (charlesk) on 2011-03-22
Changed in transmission (Ubuntu):
status: New → Incomplete
Juho Teperi (deraen) wrote :

Yes freeze is permanent, I have left transmission running for long times and it hasn't recovered.

I already did some tests "without Nvidia" before reporting this, but couldn't manage to get Nouveau work then.
Apparently it wasn't enough to blacklist nvidia but had to also select right libGL with update-alternatives.
And indeed, with Nouveau freeze is not happening.

Changed in transmission (Ubuntu):
status: Incomplete → Invalid
affects: transmission (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Invalid → New
Juho Teperi (deraen) on 2011-03-22
Changed in transmission (Ubuntu):
status: New → Invalid
Juho Teperi (deraen) wrote :

Created thread on nv News forums in hopes that someone from Nvidia would notice it. http://www.nvnews.net/vbulletin/showthread.php?p=2408692

Bryce Harrington (bryce) on 2011-03-24
description: updated
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Andrew Tipton (kiwidrew) wrote :

Just wanted to add that I'm seeing similar behaviour. In my case, two of the transmission-gtk threads jump to 100% CPU usage each on my dual-core laptop with the proprietary NVIDIA drivers. Disabling the blocklist update (but leaving the blocklist processing enabled) allows transmission to work fine.

I'm likewise on Ubuntu 11.04 and can confirm that this happens with both 2.13 (in the Ubuntu archives) and 2.20 (from the PPA).

Juho Teperi (deraen) wrote :

I did some more testing as Nvidia's people could not reproduce problem.
I found that updates subsequent to update with invalid blocklist url (tested with http://www.example.com/blocklist and http://google.com) cause freeze.
I quess it's possible that real blocklist might cause same problem if they are down.
I also found that I'm able to reproduce this with Nouveau too so this probably isn't problem with Nvidia driver.

Here are tests I tried, I was able to reproduce both multiple times on both, nvidia and nouveau.
Clean transmission profile.
1. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> ok
2. http://www.example.com/blocklist and update -> ok
3. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> no freeze but stays on "Getting new blocklist"

Clean profile
1. Add 1 torrent (used http://releases.ubuntu.com/maverick/ubuntu-10.10-alternate-amd64.iso.torrent)
2. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> ok
3. http://www.example.com/blocklist and update -> ok
4. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> freeze
5. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> freeze
6. rm -r blocklists/ blocklist.txt.tmp
7. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> ok
8. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> ok
9. http://iblocklist.ottecomputers.com/files/bt_level1.gz and update -> ok
10. http://www.example.com/blocklist and update -> ok
11. http://www.example.com/blocklist and update -> freeze
12. rm -r blocklists/ blocklist.txt.tmp
13. http://www.example.com/blocklist and update -> ok
14. http://www.example.com/blocklist and update -> freeze
After each freeze I killed and relaunched transmission.

Juho Teperi (deraen) wrote :

Okay, forgot to run ldconfig -X after update-alternatives so the nvidia's libGL was still being used. After properly selecting the Mesa libGL and ldconfig, I could not reproduce this.

Changed in transmission:
status: Unknown → Invalid

I have same issue but I am not running nvidia.

This happens with both transmission-gtk and -qt.

Two things are actually happening, but not simultaneous:

1. Transmission freezes after a few minutes or Immediately after changing a preference. Any changes made to preferences revert after reboot.

2. If I can get it to run for awhile, I somehow end up with duplicate instances. Such as, when opening a new .torrent, it opens a new instance of transmission.

**Further note, when -gtk started freezing, I removed it and installed -qt. -Qt worked for awhile but then the duplicate instances started. Now I can get neither to run.

Also when transmission freezes, killall cannot stop process. process is locked in "do_exit". Only reboot works.

Correction:

After 11.04 upgrade both nvidia and nouveau are installed.

Bryce Harrington (bryce) wrote :

Hey deraen,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
Juho Teperi (deraen) wrote :

Couldn't reproduce this in oneiric. Might be because of newer nvidia driver.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Invalid
sandipt (sandipt) wrote :

Are you still facing this issue? Can you please test with latest 295 driver on Ubuntu "Natty Narwhal" ?

Juho Teperi (deraen) wrote :

No, I haven't faced this bug after I upgraded to oneiric. As I have since upgraded to precise and this bug can't be tested on VirtualBox I rather not test this in natty.

sandipt (sandipt) wrote :

Can somebody please test this issue with latest nvidia driver on Ubuntu "Natty Narwhal" and share feedback?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.