Transmissions fails with "too many open files"

Bug #661947 reported by Anders on 2010-10-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: transmission

This looks just like Bug #406486 for which a fix is supposed to have been released.

$ ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 20
file size (blocks, -f) unlimited
pending signals (-i) 16382
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) unlimited
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

Output of $ lsof -p `pidof transmission` > /tmp/lsof.transmission is attached

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: transmission-gtk 2.04-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CheckboxSubmission: afab8a4a6bea108b46a135d1f7175049
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Sun Oct 17 00:29:16 2010
ExecutablePath: /usr/bin/transmission
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: transmission

Related branches

Anders (andersja+launchpad-net) wrote :
Charles Kerr (charlesk) on 2011-01-13
Changed in transmission:
importance: Undecided → Unknown
status: New → Unknown
Charles Kerr (charlesk) wrote :

In the 2.0x series, I don't think the root cause is the same as #406486. Rather, I think this matches upstream ticket https://trac.transmissionbt.com/ticket/3504.

Charles Kerr (charlesk) on 2011-01-13
Changed in transmission (Ubuntu):
status: New → Triaged
Changed in transmission:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 2.13-0ubuntu5

---------------
transmission (2.13-0ubuntu5) natty; urgency=low

  * debian/patches/0105-murrine_high_cpu_workaround.patch: (LP: #655024)
    - Workaround the issue found in Murrine that causes high CPU usage
      in Transmission.
  * debian/patches/0106-avoid_descriptor_leak.patch (LP: #661947)
    - Avoid descriptor leakage that caused "Too many open files" error.
  * debian/patches/0107-handle_unsorted_blocklist_rules.patch
    - Handle overlapping/unsorted blocklist rules.
  * debian/patches/0104-add-scheme-handler.patch
    - update patch to remove attribute passed to transmission-gtk in Exec
 -- Krzysztof Klimonda <email address hidden> Wed, 16 Mar 2011 05:48:44 +0100

Changed in transmission (Ubuntu):
status: Triaged → Fix Released
Changed in transmission:
status: Fix Released → New
Changed in transmission:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.