Update to 1.90

Bug #522726 reported by Krzysztof Klimonda on 2010-02-16
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: transmission

=== Transmission 1.90 (2010/02/16) ===
[http://trac.transmissionbt.com/query?milestone=1.90&group=component&groupdesc=1&order=severity All tickets closed by this release]
==== All Platforms ====
  * Add an option to disable the .part suffix for incomplete files
  * Add priority selector to GUI clients' add torrent windows
  * Fix 1.81 bug that broke HTTP requests to sites that gave HTTP 301 redirects
  * Fix 1.8x bug in announcing "finished downloading" and "stopping" at the same time
  * Fix 1.8x bug in announcing partial seeds
  * Try harder to make announces finish, even if the tracker responds slowly
  * Fix bug that didn't honor download speed limits of 0
  * Use fallocate64() for fast file preallocation on systems that support it
  * Magnet link improvements
  * Don't let "Disk is full" errors cause loss of configuration files
  * Faster parsing of bencoded data, such as .torrent files
==== Mac ====
  * Display information for all selected transfers in the inspector's tracker and peer tabs
  * Add a filter to the message log
  * Fix potential crash when updating the blocklist
  * Fix bug that caused the speed limit scheduler to not be applied after sleep
  * Remove file selection for the per-torrent action menu
  * Smaller interface tweaks
==== GTK+ ====
  * Give more helpful error messages if "Set Location" or "Add Magnet Link" fail
  * Add optional support for libappindicator
  * Minor build fixes
==== Daemon ====
  * Add transmission-remote support for port testing and blocklist updating
  * Add transmission-daemon support for incomplete-dir, dht, and seedratio
  * If settings.json is corrupt, give an error telling where the problem is
  * Add option to specify where log messages should be written
==== Web Client ====
  * Add a tracker tab to the inspector
  * Fix 1.8x display error when showing magnet link information
==== Qt ====
  * Fix bug that prevented torrents from being added via web browsers

Changed in transmission (Ubuntu):
assignee: nobody → Krzysztof Klimonda (kklimonda)
status: New → Incomplete
Changed in transmission (Ubuntu):
assignee: Krzysztof Klimonda (kklimonda) → nobody
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.90-0ubuntu1

---------------
transmission (1.90-0ubuntu1) lucid; urgency=low

  [ Krzysztof Klimonda ]
  * New upstream release (LP: #522726)
  * Fixes bugs:
    - Support Application Indicators (LP: #497882)
    - Better file preallocation with fallocate() (LP: #445592)
    - Speed limit of 0 is not honored (LP: #473652)
    - incorrectly sent information (LP: #521140)
  * Refreshed 99_autoreconf.patch
  * debian/control:
    - Build-Depend on libappindicator-dev

  [ Chris Coulson ]
  * Add ${misc:Depends} in debian/control to make Lintian happy
  * Update Standards-Version to 3.8.4. No other changes necessary
 -- Krzysztof Klimonda <email address hidden> Tue, 16 Feb 2010 17:50:22 +0100

Changed in transmission (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers