transmission crashed with signal 5 in XListPixmapFormats()

Bug #517293 reported by Yann Dìnendal on 2010-02-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

Transmission and Firefox both crashed after I clicked on a magnet link. But usually, it successfully adds the torrent.

ProblemType: Crash
Architecture: i386
Date: Thu Feb 4 22:25:14 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/transmission
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: transmission-gtk 1.83-0ubuntu1
ProcCmdline: transmission
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
Signal: 5
SourcePackage: transmission
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libX11.so.6
 ?? () from /usr/lib/libX11.so.6
 ?? () from /usr/lib/libX11.so.6
 XListPixmapFormats () from /usr/lib/libX11.so.6
Title: transmission crashed with signal 5 in XListPixmapFormats()
Uname: Linux 2.6.32-12-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Yann Dìnendal (yannbreliere) wrote :
visibility: private → public
Charles Kerr (charlesk) wrote :

Hi Yann,

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately the crash that Ubuntu collected and attached to this ticket is singularly unhelpful. For Transmission to crash in an Xlib call, and for Firefox to crash too, are also red flags to me that this might be a configuration issue rather than a Transmission bug. But with the information that the bug report application collected, it's impossible to say yet.... Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in transmission (Ubuntu):
status: New → Incomplete

StacktraceTop:
 gdk_x_error (display=0x9da1168, error=0xbf9549cc)
 EnumLTable (table=0x9da1168, names=0x9f3f848,
 process_responses (dpy=<value optimized out>,
 ?? () at ../../../src/xlibi18n/XDefaultIMIF.c:364
 XListPixmapFormats (dpy=0x9da1168, count=0x9dac2c0)

Changed in transmission (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Charles Kerr (charlesk) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Yann Dìnendal (yannbreliere) wrote :

Hi,
In fact, I can't reproduce the bug, but my guess is that it might have been the bug #522692.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers