[Feature Request] Add Support for Magnet Links

Bug #479772 reported by Dylan Taylor on 2009-11-10
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by abra13b
Nominated for Lucid by abra13b

Bug Description

Binary package hint: transmission

Almost all popular torrent clients including Vuze and uTorrent support magnet links, but transmission still doesn't. Since transmission supports DHT, implementing this makes a lot of sense, to allow for torrent transfers without actual torrent files.

Changed in transmission:
status: Unknown → Confirmed
MarcRandolph (mrand) on 2009-11-11
Changed in transmission (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
DanFoxDavies (danfox) wrote :

I wish to point out that since today everybody's favourite torrent tracker removed support for torrent files themselves, the implementation of DHT Magnet Links should now be top priority for Transmission and other torrent clients. I refer to this article: http://torrentfreak.com/the-pirate-bay-tracker-shuts-down-for-good-091117/

This is now of Critical or High importance IMHO, the removal of trackers, in favour of DHT, has started.

Benja73 (73benja) wrote :

PLEASE try to fix, this is a critical bugg now!

Charles Kerr (charlesk) wrote :

This has already been milestoned for 1.80.

Charles Kerr (charlesk) wrote :

I see this ticket has been nominated for Karmic because of this morning's tpb announcement. :)

IMO this ticket is not a good fit with the SRU guidelines at https://wiki.ubuntu.com/StableReleaseUpdates. Unlike ticket #460620 -- which arguably could be SRUed -- this ticket has a much higher risk of side-effects.

Charles Kerr (charlesk) wrote :

Perhaps the most important point:

YOU CAN USE YOUR EXISTING VERSION OF TRANSMISSION WITH TPB

The *only* thing that's changed today is tpb-the-tracker is officially dead, rather than unofficially dead as it's been for the last month.

The TF article should have spelled this out more clearly.

Charles Kerr (charlesk) wrote :

Transmission now has magnet support in the nightly builds and in 1.80 beta 1.

For those interested, the nighly tarballs can be found at http://build.transmissionbt.com/job/trunk-linux/

Changed in transmission:
status: Confirmed → Fix Released
Krzysztof Klimonda (kklimonda) wrote :

1.80 beta1 has been uploaded to Lucid.

Changed in transmission (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.