Update Transmission to 1.80 beta1

Bug #460620 reported by Dylan Taylor on 2009-10-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Wishlist
Chris Coulson
Nominated for Karmic by Dylan Taylor

Bug Description

Binary package hint: transmission

Just Yesterday, Transmission 1.76 was released, and I think it would be a great idea to get it included in the final version of Ubuntu Karmic before 10-29-09. This is a bug fix release that solves many major crashes and data loss problems. Here is the full changelog taken from the transmission website:

Transmission 1.76 (2009/10/24)

 All tickets closed by this release
All Platforms

    * Fix possible data loss when moving torrents to where they already are
    * Fix minor protocol error that didn't send a port message to some peers
    * Fix manpage errors

Mac

    * Fix a potential crasher on Snow Leopard
    * When creating a torrent with multiple trackers, place each tracker into its own tier
    * Fix display glitch when changing sort to "Queue Order"

Daemon

    * Fix possible data loss when using "transmission-remote --find"
    * Fix ratio-limit bug on some uClibc systems
    * Fix invalid JSON "nan" error on optware

GTK+

    * Fix crash in the Preferences dialog when testing to see if the port is open
    * Fix crash on exit when a torrent's Properties dialog is open
    * Fix broken SIGINT (ctrl-c) handling
    * Fix tray menu's main window status when Transmission is started minimized
    * Fix 1.61 build failure on systems with new versions of glib but older versions of gtk
    * Fix tracker address display error in the torrent Properties dialog

Qt

    * Fix crash when removing expired torrents from the display
    * Fix client from closing, rather than closing to the system tray, when clicking X
    * Cannot open a torrent in KDE4 with right-clicking

Changed in transmission (Ubuntu):
status: New → Confirmed
John Dong (jdong) wrote :

Charles, do you have an opinion on this?

I'm not Charles but I can answer it. :)
It is too late to update to 1.76, a few of the most important patches (based
on a number of duplicates in launchpad or the severity of bugs) were applied
to 1.75 already.

On Oct 26, 2009 6:20 AM, "John Dong" <email address hidden> wrote:

Charles, do you have an opinion on this?

-- Transmission Version 1.76 is Available
https://bugs.launchpad.net/bugs/460620 You received this...

> Charles, do you have an opinion on this?

This is a bugfix only release so it would be nice if it got folded in at some point after Karmic is released. However there is no hurry at all. 1.75 is a solid release.

Charles Kerr (charlesk) wrote :

> This is a bug fix release that solves many major crashes and data loss problems.

Yes and no. Krzysztof applied the two most important patches already, and the steps to tickle most of these bugs were pretty esoteric. 1.76 is really just a clearinghouse of assorted bugfixes that we wanted to release before 1.80.

John Dong (jdong) wrote :

Ok, looking at the diff I agree with Charles -- we don't have any open bug reports that this corresponds to, but it is a strictly bugfix-only update. I've got no objections to including it, but there really is no rush to do it.

I'll the Desktop Team / Release Team make the call on this one, and should any of these bugs show up in the future this will be a no-brainer SRU.

Jcink (jcink2k) wrote :

I too would like to see this update applied if possible.

Personally I didn't find anything that wrong with 1.75. It is a solid release. But one extremely annoying thing is that all the private trackers I go to are now banning everything 1.75 and below... you're forced to upgrade. This is just something to consider.

If it can be slipped in before, or even in an update of sorts that would be great. My two cents.

Jonathon James (isamaranga) wrote :

Yes I am experiencing the same problem as Jcink. Is there a way to downgrade to a lower version if 1.76 is not being released?

Robert Collins (lifeless) wrote :

How would downgrading to a lower version help if private trackers are banning <=1.75

Charles Kerr (charlesk) wrote :

This is news to me -- I haven't heard of any trackers banning 1.75. There's no reason to, AFAIK. And if there is I'd like to hear which ones, and what their rationale is.

Hew (hew) on 2009-11-01
Changed in transmission (Ubuntu):
importance: Undecided → Wishlist

charles, some private trackers ban anything except the latest version of clients because they consider them still in beta phase.

You have to remember that these trackers are old ones that have been around to see many transformations in the client "swarm", and only a few clients that they have verified standing the test of time are granted full supported status.

No matter how stable Transmission is to the developers here, it won't be called "stable" by some of the bigger private trackers for another year or two at the least.

Until that time, it will be flagged as beta, which means anything except the latest release will be banned automatically by their admins.
I don't know if you're a Transmission developer, but don't take this personally, it applies to all clients.

In any case I'm not posting because I want to push 1.76 in any way, I was just simply responding to your comment #9.

Dylan Taylor (dylanmtaylor) wrote :

Seeing as 1.76 is really only a minor bug fix release, I see no reason not to push this update. I doubt that it will cause and regressions or problems not already present in 1.75

Krzysztof Klimonda (kklimonda) wrote :

I'm going to work on merge for Lucid this weekend

Changed in transmission (Ubuntu):
assignee: nobody → Krzysztof Klimonda (kklimonda)
John Dong (jdong) wrote :

Ok very nice. Once you get it merged into Lucid, let's take a look. I'd lean towards endorsing it as a SRU if it were as minimal as everyone claims it is.

tags: added: desktop-upgrade
Miguel Rodríguez (migrax) wrote :

Version 0.76 fixes a problem with my router. The fix is very unobtrusive, so I think it should be backported to karmic (if not the complete 0.76 release)

For reference the changeset is just http://trac.transmissionbt.com/changeset/9414/trunk/libtransmission

Miguel Rodríguez (migrax) wrote :

Obviously I meant 1.76. Sorry.

Krzysztof Klimonda (kklimonda) wrote :

Charles: As you are releasing 1.80 beta1 soon what is your opinion about getting 1.80 into 10.04? Do you think it's going to be ready for February/March? If so I'd opt to update to beta1 as soon as possible so early Lucid adopters can help us catch more bugs. It would be nice to get it as in the next 3 years the number of "magnet-link enabled" sites is probably only going to increase.

Charles Kerr (charlesk) wrote :

> what is your opinion about getting 1.80 into 10.04?

I think it would be an excellent idea, assuming we don't have 1.81 out by then ;)

> Do you think it's going to be ready for February/March?

Yes.

> If so I'd opt to update to beta1 as soon as possible so early Lucid adopters can help us catch more bugs.

I didn't realize there were that many Lucid uses already! That's interesting.

> It would be nice to get it as in the next 3 years the number of "magnet-link enabled" sites is probably only going to increase.

That definitely seems true right now. It's crazy the number of people who have asked about magnet support over the past two weeks. It's easily the most-viewed thread in our forums during that period.

summary: - Transmission Version 1.76 is Available
+ Update Transmission to 1.80 beta1
Chris Coulson (chrisccoulson) wrote :

Thanks kklimonda, I've pushed your changes to the ubuntu-desktop bzr branch now. I can upload this for you, but I'll do this after Alpha 1 is released now

Changed in transmission (Ubuntu):
assignee: Krzysztof Klimonda (kklimonda) → Chris Coulson (chrisccoulson)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.80~b1-0ubuntu1

---------------
transmission (1.80~b1-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #460620), rebased on debian unstable
    remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
        Can be removed in lucid+1
      + Added quilt, liblaunchpad-integration-dev and lsb-release to Build-Depends
    - debian/rules:
      + create a po template during package build.
    - debian/patches/01_lpi.patch:
      + integrate transmission with launchpad
    - debian/patches/20_add_x-ubuntu-gettext-domain.diff:
      + add x-ubuntu-gettext-domain to .desktop file.
    - debian/transmission-daemon.default:
      - remove --auth from OPTIONS
  * Fixes bugs:
    - tray menu shows wrong status for "main window" when started minimized
      (LP: #451415)
  * Refreshed patches:
    - dont_build_libevent.patch
    - 99_autoreconf.patch
  * Removed patches:
    - 21_onPortTested.diff, 23_tr_torrentNext.diff and
      24_tr_torrentDeleteLocalData_do_move.diff
  * debian/patches/21_fix_inhibition.patch:
    - The right value for suspend inhibition is 4
  * debian/control:
    - Build-Depend on libgconf2-dev to enable magnet link registration and on
      libcanberra-gtk-dev for notification sound.
  * debian/watch:
    - make it detect beta versions, to be removed after 1.80 is released.

transmission (1.76-1) unstable; urgency=low

  * new upstream release
  * debian/transmission-daemon.init: depend on $remote_fs (closes: #549241)
 -- Krzysztof Klimonda <email address hidden> Tue, 08 Dec 2009 10:49:11 +0100

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers