transmission crashed with SIGSEGV in tr_torrentNext()

Bug #451554 reported by Vasily on 2009-10-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

It was open a modal window property of torrent when closed with error

ProblemType: Crash
Architecture: i386
Date: Wed Oct 14 23:02:37 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/transmission
Package: transmission-gtk 1.75-0ubuntu1
ProcCmdline: transmission
ProcEnviron:
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SegvAnalysis:
 Segfault happened at: 0x809306c <tr_torrentNext+28>: mov 0x84(%eax),%eax
 PC (0x0809306c) ok
 source "0x84(%eax)" (0x00000084) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: transmission
StacktraceTop:
 tr_torrentNext ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
Title: transmission crashed with SIGSEGV in tr_torrentNext()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare vboxusers video
XsessionErrors:
 (gnome-settings-daemon:2282): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2282): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2342): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2377): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2475): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Vasily (piatachki) wrote :
visibility: private → public

StacktraceTop:tr_torrentNext (session=0x0, tor=0x1) at session.c:1896
refresh (data=0x1) at file-list.c:207
refreshModel (file_data=0x95ead78) at file-list.c:230
gdk_threads_dispatch (data=0x9619630)
?? () from /lib/libglib-2.0.so.0

Changed in transmission (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in transmission:
status: Unknown → Fix Released
Charles Kerr (charlesk) wrote :

This was fixed about a month ago upstream and is slated for 1.80. It hadn't been reported in Ubuntu yet. Thank you for taking the time to report this bug and helping to make Ubuntu better! Feel free to continue to report any other bugs you may find.

===

Question for the Ubuntu p2p packagers:

I'm a little confused about how best to submit bugfixes like this one for use in post-release 9.10. I understand there are many bigger fish to fry at this point and I'm happy to wait, but if possible I'd like to get some general advice on how the Transmission team should make these fixes available -- that is, which way is easiest for you to use.

One proposal has been a focused bugfix-only 1.76 addressing the tickets listed at http://transmission.pastebay.com/61186. The diff for this proposal is only about 300 lines long, http://transmission.pastebay.com/61200. Rolling a 1.76 release would be my preferred method, since it's easy to understand and easy for other distros and end users to grab.

If you'd prefer to do fixes a la carte, that's fine too. This ticket's fix is a very simple null pointer test before dereferencing the pointer, and the changeset can be found at <http://trac.transmissionbt.com/changeset/9143>

Changed in transmission (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.75-0ubuntu2

---------------
transmission (1.75-0ubuntu2) karmic; urgency=low

  * debian/transmission-daemon.default:
    - remove --auth from OPTIONS (LP: #444005)
  * debian/patches/21_onPortTested.diff:
    - crash in preferences dialog when testing to see if port is open/closed (LP: #407832)
  * debian/patches/23_tr_torrentNext.diff:
    - transmission crashed with SIGSEGV in tr_torrentNext() (LP: #451554)
  * debian/patches/24_tr_torrentDeleteLocalData_do_move.diff:
    - fix potential data loss.

 -- Krzysztof Klimonda <email address hidden> Mon, 05 Oct 2009 22:53:01 +0200

Changed in transmission (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.