tray menu shows wrong status for "main window" when started minimized

Bug #451415 reported by Martin Mai on 2009-10-14
12
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: transmission

The right click menu of transmission's tray icon shows a "main window" checkbox, which should be checked if the transmission windows is visible and unchecked if the window is minimized.

However, when transmission is started with the command line option "-m" to start minimized in the tray, the behavior of this checkbox switches so that it always represents the wrong status.

I have screenshots attached to demonstrate the wrong behavior.

ProblemType: Bug
Architecture: amd64
Date: Wed Oct 14 18:29:18 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/transmission
NonfreeKernelModules: nvidia
Package: transmission-gtk 1.75-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: transmission
Uname: Linux 2.6.31-13-generic x86_64

Changed in transmission (Ubuntu):
importance: Undecided → Low
Changed in transmission:
status: Unknown → New

Wow..that was awesome fast. Thank you very much, charles.

Changed in transmission (Ubuntu):
status: New → Triaged
status: Triaged → Fix Committed
Charles Kerr (charlesk) wrote :

I'm not sure this counts as "fix released" or not, since it's not been released in Ubuntu...?

The two-line diff for this ticket is at http://trac.transmissionbt.com/changeset/9308

Changed in transmission (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Changed in transmission:
status: New → Fix Released

Right, I doesn't count as "fix released" until it's in ubuntu. That is why I marked it as "fix commited", which is often used when the bug has been fixed uptream since the bugwatch may be out of sync.

Although the fix is very small it will not make it into karmic, because today was "FinalFreeze" and the issue is a cosmetic one.

Thanks again for the great work. This is how bug tracking makes fun.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.80~b1-0ubuntu1

---------------
transmission (1.80~b1-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #460620), rebased on debian unstable
    remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
        Can be removed in lucid+1
      + Added quilt, liblaunchpad-integration-dev and lsb-release to Build-Depends
    - debian/rules:
      + create a po template during package build.
    - debian/patches/01_lpi.patch:
      + integrate transmission with launchpad
    - debian/patches/20_add_x-ubuntu-gettext-domain.diff:
      + add x-ubuntu-gettext-domain to .desktop file.
    - debian/transmission-daemon.default:
      - remove --auth from OPTIONS
  * Fixes bugs:
    - tray menu shows wrong status for "main window" when started minimized
      (LP: #451415)
  * Refreshed patches:
    - dont_build_libevent.patch
    - 99_autoreconf.patch
  * Removed patches:
    - 21_onPortTested.diff, 23_tr_torrentNext.diff and
      24_tr_torrentDeleteLocalData_do_move.diff
  * debian/patches/21_fix_inhibition.patch:
    - The right value for suspend inhibition is 4
  * debian/control:
    - Build-Depend on libgconf2-dev to enable magnet link registration and on
      libcanberra-gtk-dev for notification sound.
  * debian/watch:
    - make it detect beta versions, to be removed after 1.80 is released.

transmission (1.76-1) unstable; urgency=low

  * new upstream release
  * debian/transmission-daemon.init: depend on $remote_fs (closes: #549241)
 -- Krzysztof Klimonda <email address hidden> Tue, 08 Dec 2009 10:49:11 +0100

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.