Transmission 1.75, a bugfix release, is available

Bug #429483 reported by Charles Kerr on 2009-09-14
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Wishlist
Unassigned
Declined for Karmic by Martin Pitt

Bug Description

Binary package hint: transmission

I've kept kklimonda and chris coulson informed about this, and 1.75 is finally out. Mindful of the freeze, this is first & foremost a bugfix release. This release fixes launchpad bugs #414129 and #418853 and several non-launchpad bugs described at http://trac.transmissionbt.com/query?milestone=1.75&group=component&groupdesc=1&order=severity.

There are two new translatable strings in this release. If this causes a problem with the freeze I can patch them out, but this will regress the fix to launchpad #418853.

Alex Lourie (alourie) on 2009-09-14
Changed in transmission (Ubuntu):
status: New → Confirmed
Changed in transmission (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
tags: added: desktop-upgrade
Martin Pitt (pitti) wrote :

Seems worthwhile for the bug fixes, and adding two new strings does not hurt us very much yet.

kklimonda told me they don't appear in the main window, but it's a new dialog. I subscribed the documentation team to get their ack whether they have screenshots/documentation about this at all.

Can you please describe more specifically when the new dialog appears and what it is for?

Thank you!

Krzysztof Klimonda (kklimonda) wrote :

A new dialog window was introduced to handle bug 418853 more gracefully. It's an edge case when Transmission freezes and user tries to open new window - currently when there is no response only following message is printed to the .xsession-errors/terminal:

** Message: err: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

It looks similar to the window displayed by Firefox when browser freezes and user clicks on a link or tries to open a new window.

As for the proper fix for a freeze problem there is not enough data at this time to fix it.

Krzysztof Klimonda (kklimonda) wrote :

Also "Donate" does appear in the main window, as a position in Help menu.

This happened after i upgraded from ubuntu 8.10lts to 9.01 from the
internet and then trying to scan a flashdrive by clamav. I couldnt n
the mesg appeared.

On 9/17/09, Martin Pitt <email address hidden> wrote:
> Seems worthwhile for the bug fixes, and adding two new strings does not
> hurt us very much yet.
>
> kklimonda told me they don't appear in the main window, but it's a new
> dialog. I subscribed the documentation team to get their ack whether
> they have screenshots/documentation about this at all.
>
> Can you please describe more specifically when the new dialog appears
> and what it is for?
>
> Thank you!
>
> --
> Transmission 1.75, a bugfix release, is available
> https://bugs.launchpad.net/bugs/429483
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
>

--
Sent from my mobile device

feel free to contact

Supratik

Charles Kerr (charlesk) wrote :

A screenshot of #418853's new error message can be found at
http://trac.transmissionbt.com/attachment/ticket/2387/lockfile-err.jpg

Martin Pitt wrote:
> kklimonda told me they don't appear in the main window, but it's a new
> dialog. I subscribed the documentation team to get their ack whether
> they have screenshots/documentation about this at all.

Fine to go ahead from the doc team.

thank you

On Sat, Sep 19, 2009 at 4:03 PM, Dean Sas <email address hidden> wrote:
> Martin Pitt wrote:
>> kklimonda told me they don't appear in the main window, but it's a new
>> dialog. I subscribed the documentation team to get their ack whether
>> they have screenshots/documentation about this at all.
>
> Fine to go ahead from the doc team.
>
> --
> Transmission 1.75, a bugfix release, is available
> https://bugs.launchpad.net/bugs/429483
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
>

--
feel free to contact

Supratik

Andrew (andrewabc) wrote :

Debian has updated to 1.75, so should make for easier update.
http://packages.debian.org/sid/transmission

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.75-0ubuntu1

---------------
transmission (1.75-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #429483)
    - Don't wait so long on unresponsive trackers if there are other trackers
      to try
    - Adding corrupt/invalid torrents could crash Transmission
    - Fix 1.74 bug that caused a high CPU load on startup
    - Fix 1.74 bug that stopped multitracker if a single tracker sent an error
      message
    - Fix bug in converting other charsets to UTF-8 (LP: #414129)
    - Handle HTTP redirects more gracefully
    - Faster verification of local data for torrents with small piece size
    - Fix 1.74 build error when compiling without DHT
    - Fix "sort by time remaining"
    - Fix the turtle toggle button on old versions of GTK+
    - Fix startup error if another copy of the Transmission GTK client is
      running (LP: #418853)
    - Fix clang build issue
  * Refreshed patches:
    - 99_autoreconf.patch

 -- Krzysztof Klimonda <email address hidden> Wed, 23 Sep 2009 10:01:22 +0200

Changed in transmission (Ubuntu):
status: Triaged → Fix Released

Hello Everybody,

SUBHO BIJOYAR PREETI O SUVECHCHAA.

Supratik

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.