transmission crashed with SIGSEGV in gtk_text_layout_get_line_display()

Bug #391995 reported by Kernel-1 on 2009-06-25
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

transmission crashed with SIGSEGV in gtk_text_layout_get_line_display()

ProblemType: Crash
Architecture: amd64
Date: Thu Jun 25 10:15:40 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/transmission
NonfreeKernelModules: nvidia
Package: transmission-gtk 1.71-1ubuntu1
ProcCmdline: transmission
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SegvAnalysis:
 Segfault happened at: 0x7ff5801c3c6f: mov 0x48(%rbp),%eax
 PC (0x7ff5801c3c6f) ok
 source "0x48(%rbp)" (0x00000048) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: transmission
StacktraceTop:
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 gtk_text_layout_get_line_display ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
Title: transmission crashed with SIGSEGV in gtk_text_layout_get_line_display()
Uname: Linux 2.6.30-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Kernel-1 (oligofrenolog) wrote :

StacktraceTop:set_para_values (layout=0x1e55600, base_dir=<value optimized out>,
IA__gtk_text_layout_get_line_display (
gtk_text_layout_real_wrap (layout=0x1e55600,
gtk_text_btree_node_validate (
_gtk_text_btree_validate (tree=0x1b89750,

Changed in transmission (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Hew (hew) on 2009-06-27
visibility: private → public
Charles Kerr (charlesk) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Charles Kerr (charlesk) on 2009-06-29
Changed in transmission (Ubuntu):
status: New → Incomplete
Charles Kerr (charlesk) wrote :

Looking over the retrace, I think I've figured out this crash.

It was a little tricky because there's not actually any Transmission source code in the retrace, but the behavior being shown only happens in one part of Transmission: thread 1 is refreshing a handful of widgets, and thread 2 has about 60 steps of tearing down widgets. The only place we do anything of that nature is during shutdown. So I think the problem is that we don't get a GDK lock before putting up the "Sending totals to tracker..." prompt.

Changed in transmission (Ubuntu):
status: Incomplete → Fix Committed
Changed in transmission:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.73-1ubuntu1

---------------
transmission (1.73-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable: (LP: #401578)
    - Fixes bugs (LP: #318249) (LP: #388348) (LP: #391995) (LP: #394080) (LP: #374013)
    - Remaing changes same as in 1.72-1ubuntu1
  * debian/control:
    - Added BZR link

 -- Robert Ancell <email address hidden> Mon, 20 Jul 2009 15:28:53 +1000

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.