transmission crashed with SIGSEGV in gtk_widget_set_sensitive()

Bug #388348 reported by Eyad Salah on 2009-06-17
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

I was trying to test a port

ProblemType: Crash
Architecture: i386
Date: Wed Jun 17 12:10:38 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/transmission
NonfreeKernelModules: nvidia
Package: transmission-gtk 1.71-1ubuntu1
ProcCmdline: transmission
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
SegvAnalysis:
 Segfault happened at: 0xe8c7d2 <gtk_widget_set_sensitive+34>: mov (%esi),%eax
 PC (0x00e8c7d2) ok
 source "(%esi)" (0x3ff00000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: transmission
StacktraceTop:
 gtk_widget_set_sensitive ()
 ?? ()
 g_cclosure_marshal_VOID__BOOLEAN ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: transmission crashed with SIGSEGV in gtk_widget_set_sensitive()
Uname: Linux 2.6.30-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Eyad Salah (eyad-salah) wrote :

StacktraceTop:IA__gtk_widget_set_sensitive (widget=0x3ff00000,
onPortTested (core=0x86c9660, isOpen=0, vdata=0x8bd8440)
IA__g_cclosure_marshal_VOID__BOOLEAN (closure=0x8bd8cd0,
IA__g_closure_invoke (closure=0x8bd8cd0, return_value=0x0,
signal_emit_unlocked_R (node=<value optimized out>,

Changed in transmission (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Hew (hew) on 2009-06-17
visibility: private → public
Charles Kerr (charlesk) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I'm not able to reproduce this problem in either 1.71 or 1.72. When you say "I was trying to test a port", do you mean this crash happened after pressing the "Test Port" button in Edit > Preferences > Network? Also, is this something that happens every time for you?

Changed in transmission (Ubuntu):
status: New → Incomplete
Charles Kerr (charlesk) wrote :

I'm not able to reproduce this, but after reading through the retrace I'm pretty sure I see what's going on. In short there is an idle callback func that's invoked when we find out the incoming peer port's status, and that callback needs to get a gdk thread lock before it modifies any of the preference dialogs' widgets.

I've fixed this bug upstream in r8757 for 1.73 and am marking this ticket as "Fix Committed". ComputerJy, you might want to update from the Transmission nightly build PPA to confirm.

Changed in transmission (Ubuntu):
status: Incomplete → Fix Committed
Changed in transmission:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.73-1ubuntu1

---------------
transmission (1.73-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable: (LP: #401578)
    - Fixes bugs (LP: #318249) (LP: #388348) (LP: #391995) (LP: #394080) (LP: #374013)
    - Remaing changes same as in 1.72-1ubuntu1
  * debian/control:
    - Added BZR link

 -- Robert Ancell <email address hidden> Mon, 20 Jul 2009 15:28:53 +1000

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
gnufreex (gnufreex) wrote :

Same here, I was trying to test port and it crashed. Using Karmic, x86-64.

uname -a

2.6.31-11-generic #36-Ubuntu SMP Fri Sep 25 06:37:23 UTC 2009 x86_64 GNU/Linux

gnufreex (gnufreex) wrote :

Using Transmission 1.75 (9117) which came with Karmic.

Krzysztof Klimonda (kklimonda) wrote :

Thanks for your comment. Next time, when a crash occur, open new bug report. This way we'll get more data from your crash and see if it's indeed the same problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.