[karmic] removing download items makes property window useless

Bug #385334 reported by Asif Youssuff on 2009-06-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

removing download items makes property window useless, by removing options for the selected torrent

Steps to reproduce:

1. Begin downloading a torrent
2. Switch to "Downloading" section of transmission (of All, Active, Downloading... etc)
3. Select torrent, open properties window (right click, properties)
4. Switch to files tab
5. Remove all files from download

What happens

The properties window seems to become detached from the torrent -- the titlebar changes, the widgets disappear, etc.

Expected behavior

User should be able to continue using the properties dialog even if they have chosen to not download everything -- they may simply want to select one item, and are attempting to unselect all the items, and then select the one item that they want.

ProblemType: Bug
Architecture: i386
Date: Tue Jun 9 15:15:23 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: transmission (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: transmission
Uname: Linux 2.6.30-8-generic i686

Asif Youssuff (yoasif) wrote :
Changed in transmission:
status: Unknown → Confirmed
Charles Kerr (charlesk) on 2009-06-09
Changed in transmission (Ubuntu):
status: New → Confirmed
Changed in transmission (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: regression-potential
Charles Kerr (charlesk) wrote :

Fixed upstream in r8666 for 1.72

Changed in transmission:
status: Confirmed → Fix Released
Asif Youssuff (yoasif) on 2009-06-11
tags: added: hundredpapercuts
Asif Youssuff (yoasif) on 2009-06-11
tags: removed: hundredpapercuts
Charles Kerr (charlesk) on 2009-06-11
Changed in transmission (Ubuntu):
status: Triaged → Fix Committed
Vitaliy Kulikov (slonua) wrote :

It's not a bug !!! I know that some changes have been provided in 1.72.
According to attached video .. U must just change tab to 'All' after unselect all files for downloading !!!
Please revert changes with NOT one window for torrent properties =)

Steve Beattie (sbeattie) wrote :

Attached is the svn commit r8666 from upstream to address the issue (as mentioned in the upstream bug report). Would someone like to verify that it applies and turn it into a debdiff? Thanks.

.On Fri, Jun 19, 2009 at 8:19 AM, Steve Beattie<email address hidden> wrote:
> Attached is the svn commit r8666 from upstream to address the issue (as
> mentioned in the upstream bug report). Would someone like to verify that
> it applies and turn it into a debdiff? Thanks.
It is fixed in Transmission 1.72 which will be merged shortly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.72-1ubuntu1

---------------
transmission (1.72-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #388377), remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
      + add quilt, liblaunchpad-integration and libtool to Build-Depends
    - debian/rules:
      + Create a PO template during package build.
      + re-enable quilt
      + run autoreconf for launchpad-integration
    - debian/patches/01_lpi.patch:
      + Integrate Transmission with Launchpad
    - debian/patches/20_add_X-Ubuntu-Gettext-Domain.diff:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
  * Closes Launchpad bugs:
    - Use tooltip to notify user of added torrent (LP: #217171)
    - Transmission forgets torrent when adding several (LP: #259123)
    - Unable to sort files in torrent by Progress, Download nor Priority.
      (LP: #300359)
    - "Revert" and "Remove" uses same alt-key in Torrent Tracker Details
      (LP: #311064)
    - transmission crashed with SIGSEGV in g_closure_invoke() (LP: #334104)
    - Bring transmission to the top when adding a torrent (LP: #353777)
    - Focus should not be on "Don't ask me again" when I quit Transmission
      (LP: #359268)
    - [karmic] removing download items makes property window useless
      (LP: #385334)
    - transmission doesn't remember maximized state (LP: #385982)
    - Transmission 1.71 (8646) crashes when changing download speed
      (LP: #386877)
    - transmission: event.c:875: timeout_next: Assertion `tv->tv_usec >= 0'
      failed. (LP: #387564)

transmission (1.72-1) unstable; urgency=low

  * new upstream release: (closes:#533423)
    - Can now sort the file list by priority, download, and completeness
      (closes: #517872)
    - fixed race condition adding file from browser (closes: #500195)
  * debian/control: policy 3.8.2 (no changes)

 -- Krzysztof Klimonda <email address hidden> Tue, 16 Jun 2009 02:41:48 +0200

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.