Please merge transmission 1.71-1 (main) from Debian unstable (main)

Bug #384215 reported by Hew on 2009-06-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
transmission (Debian)
Fix Released
Unknown
transmission (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: transmission

Transmission 1.70 has been released, with a number of new features and bugfixes included.

All Platforms

    * Distributed hash table (DHT) support for public torrents
    * Add option for moving and finding a torrent's data on the disk
    * JSON RPC messages can be ~85% shorter, saving bandwidth and CPU
    * When available, use the system's copy of libevent instead of building one
    * Automatically pause torrents when verifying
    * Fix small bugs and memory leaks

Web Client

    * Big speed improvements, especially with large torrents
    * Fix 1.61 bug that broke adding torrents via the web client
    * Add the ability to upload multiple torrents at once
    * Torrents added by URL were always paused, regardless of preferences
    * Comments and announce addresses were cut off in the inspector
    * The "data remaining" field wasn't updated when the number reached 0
    * Smaller design adjustments

GTK+

    * Fix intltool build problem
    * Make it clearer that the status bar's ratio mode button is a button
    * Torrent comment box did not scroll, so long comments were partially hidden

Closed tickets (since 1.61): http://trac.transmissionbt.com/query?milestone=1.70&group=component&groupdesc=1&order=severity
Source: http://mirrors.m0k.org/transmission/files/transmission-1.70.tar.bz2

Hew (hew) on 2009-06-06
Changed in transmission (Ubuntu):
importance: Undecided → Wishlist
Krzysztof Klimonda (kklimonda) wrote :

I have been waiting for Debian to update it first but maybe there is no point.
First patch is diff of debian/ directory between 1.60-2ubuntu1 and 1.70-0ubuntu1.
There is some file movement (I have renamed launchpad_integration.patch to 01_lpi.patch)
Also I have made 1.70 depend on libevent-1.4-2 - It is part of main repository, I think that it make sense to enable it if upstream developer make it possible. It is still early enough that we can test it and roll back to bundled library if problems occur.

Krzysztof Klimonda (kklimonda) wrote :

And here goes a builder log.
I'm not attaching full patch as it's 4MB in size.

Krzysztof Klimonda (kklimonda) wrote :

Heh, I think it's not a good idea to modify old changelog entries (sorry about that, I have generated it from my bzr repository and it seems that I was messing with it lately).

Changed in transmission (Debian):
status: Unknown → New
Krzysztof Klimonda (kklimonda) wrote :

1.71 will be released soon (i.e. in the next 24 hours or so) so I'm marking it's incomplete - there is no point of doing two concurrent upgrades.

Changed in transmission (Ubuntu):
status: New → Incomplete
summary: - Please upgrade to transmission 1.70
+ Please upgrade to transmission 1.71

1.71 (2009/06/07)
<http://trac.transmissionbt.com/query?milestone=1.71&group=component&groupdesc=1&order=severity>
- All Platforms
   + Fix 1.70 bug that caused high CPU use in high-peer swarms
   + Fix 1.70 build problems with DHT and libevent
- Daemon
   + Fix watchdir issue on OSes that don't have inotify
- GTK+
   + Fix 1.70 intltool build problem
   + Fix crash when the OS's stock mime-type icons are misconfigured
   + Handle very long torrent file lists faster
- Web Client
   + Fix 1.70 bug where some torrents appeared to be duplicates

Changed in transmission (Ubuntu):
status: Incomplete → New
Krzysztof Klimonda (kklimonda) wrote :

a Patch against current Karmic version (1.61-2ubuntu1).
I have renamed launchpad_integration.patch to 01_lpi.patch so it's a bit bigger but frankly nothing else changes exception version.

Changed in transmission (Debian):
status: New → Fix Released
Hew (hew) wrote :

Transmission 1.71-1 is now in Debian sid. It would be nice if a merge could be performed instead.

Changed in transmission (Ubuntu):
status: New → Incomplete

Indeed, it would be the best option. I'm without access to computer
with internet connection until sunday so feel free to prepare merge.
Also it would be nice to ask Charles when is 1 .72 going to be
released as it contains few fixes for launchpad bugs.

On 6/11/09, Hew McLachlan <email address hidden> wrote:
> Transmission 1.71-1 is now in Debian sid. It would be nice if a merge
> could be performed instead.
>
> ** Changed in: transmission (Ubuntu)
> Status: New => Incomplete
>
> --
> Please upgrade to transmission 1.71
> https://bugs.launchpad.net/bugs/384215
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Debdiff from 1.71-1 attached.

Debdiff from 1.61-2ubuntu1 available on request.

Changed in transmission (Ubuntu):
status: Incomplete → Confirmed
Hew (hew) on 2009-06-13
summary: - Please upgrade to transmission 1.71
+ Please merge transmission 1.71-1 (main) from Debian unstable (main)
Charles Kerr (charlesk) wrote :

> Also it would be nice to ask Charles when is 1 .72 going to be
> released as it contains few fixes for launchpad bugs.

1.72 will be out sometime this weekend. It closes 9 or 10 launchpad bugs! :)

Krzysztof Klimonda (kklimonda) wrote :

So... 1.72 was released.. Anybody has the slightest idea what to do now? ;)
Should we prepare update and ignore merge in debian/changelog, wait for debian to catch up and prepare next merge or what.. ?

Hew (hew) wrote :

There's no point holding off for work on yet another Transmission release, otherwise we'll end up in the same situation with 1.73 ;-). 1.71 is a big improvement over 1.61 which is currently in the archive, so it's still ready to upload.

As for the 1.72 upgrade my preference is to wait for Debian so we can merge. If this happens before 1.71 gets uploaded I'm happy to redo the merge debdiff.

Krzysztof Klimonda (kklimonda) wrote :

I have refreshed 01_lpi.patch so it can be applied on 1.72 source - It's available from lp:~kklimonda/transmission/ubuntu

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.71-1ubuntu1

---------------
transmission (1.71-1ubuntu1) karmic; urgency=low

  [ Hew McLachlan ]
  * Merge from debian unstable (LP: #384215), remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
      + add quilt, liblaunchpad-integration and libtool to Build-Depends
    - debian/rules:
      + Create a PO template during package build.
      + re-enable quilt
      + run autoreconf for launchpad-integration
    - debian/patches/01_lpi.patch:
      + Integrate Transmission with Launchpad
    - debian/patches/20_add_X-Ubuntu-Gettext-Domain.diff:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
  * Closes Launchpad bugs:
    - debian/transmission-daemon.default: comment typo (LP: #317576)
    - transmission crashed with SIGSEGV in g_main_context_dispatch() (LP: #359319)

  [ Krzysztof Klimonda ]
    - Rename launchpad_integration.patch to 01_lpi.patch

transmission (1.71-1) unstable; urgency=low

  * new upstream release: (closes:#532007)
    - uses system-wide libevent, if available (closes: #529372)
    - transmission-remote now returns !0 on error (closes: #526703)
    - fixed torrent adding in the web interface (closes: #529717)
    - fix properties screen (closes: #530669)
    - javascript speed fixes (closes: #531162)
  * debian/transmission-daemon.default: comment typo (closes: #528253)

 -- Hew McLachlan <email address hidden> Fri, 12 Jun 2009 22:41:35 +1000

Changed in transmission (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.