Bring transmission to the top when adding a torrent

Bug #353777 reported by David Prieto on 2009-04-02
2
Affects Status Importance Assigned to Milestone
Transmission
Invalid
Unknown
transmission (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: transmission

When I click on a torrent file in my browser, transmission stays behind it and only the flashing taskbar button implies that there's something going on with it. Please make transmission bring its main window to the top and catch the user's eye.

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: transmission None [modified: /var/lib/dpkg/info/transmission.list]
PackageArchitecture: all
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: transmission
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: Este no es un paquete Ubuntu genuino

Changed in transmission (Ubuntu):
importance: Undecided → Wishlist
Changed in transmission (Ubuntu):
status: New → Confirmed
Changed in transmission:
status: Unknown → New
Charles Kerr (charlesk) wrote :

This is the scenario that gtk_window_set_urgency_hint() was created for, and that's what Transmission already uses.

My gut feeling is that forcing a window raise as suggested here would make a couple of users happy, and annoy everyone else.

If there is "prior art" about this with other official Gnome applications[1], I'd be happy to reconsider this decision to make Transmission behave in a manner consistent with other Gnome apps.

http://en.wikipedia.org/wiki/List_of_GNOME_applications#Official_applications

Changed in transmission:
status: New → Invalid

Yes, raising Transmission's main window might not be such a good idea. Then again, how about only raising the options window? That window is the most similar thing to a "Save as" dialogue, since it's where you specify where you want to download your torrent to, and what specific files you want to include. It's the kind of thing you do expect to pop up.

That shouldn't annoy anyone, for two reasons:

-Users who have the options window enabled now have to actively search for it before the download actually starts, so we're saving them that work.
-Users who just want the download to start on the background so they can keep doing what they're doing probably have the options window disabled, so they wouldn't even notice.

Charles Kerr (charlesk) wrote :

I like that better, but I don't think it's possible to raise a child window without raising its parent window too.

In addition, I think ticket #217171 would satisfy David's request to add something to catch the user's eye when adding a torrent.

Charles Kerr (charlesk) wrote :

I stand corrected, The behavior requested by David is already present in svn trunk. :)

Actually, in that screencast the options window appears behind the terminal and not on top of everything. It does appear on top of Firefox tho, not just on top of Transmission. Is there a reason for that? I'm kinda puzzled.

Charles Kerr (charlesk) wrote :

the option window's been raised, but hasn't grabbed focus away from the terminal.

Changed in transmission (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.72-1ubuntu1

---------------
transmission (1.72-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #388377), remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
      + add quilt, liblaunchpad-integration and libtool to Build-Depends
    - debian/rules:
      + Create a PO template during package build.
      + re-enable quilt
      + run autoreconf for launchpad-integration
    - debian/patches/01_lpi.patch:
      + Integrate Transmission with Launchpad
    - debian/patches/20_add_X-Ubuntu-Gettext-Domain.diff:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
  * Closes Launchpad bugs:
    - Use tooltip to notify user of added torrent (LP: #217171)
    - Transmission forgets torrent when adding several (LP: #259123)
    - Unable to sort files in torrent by Progress, Download nor Priority.
      (LP: #300359)
    - "Revert" and "Remove" uses same alt-key in Torrent Tracker Details
      (LP: #311064)
    - transmission crashed with SIGSEGV in g_closure_invoke() (LP: #334104)
    - Bring transmission to the top when adding a torrent (LP: #353777)
    - Focus should not be on "Don't ask me again" when I quit Transmission
      (LP: #359268)
    - [karmic] removing download items makes property window useless
      (LP: #385334)
    - transmission doesn't remember maximized state (LP: #385982)
    - Transmission 1.71 (8646) crashes when changing download speed
      (LP: #386877)
    - transmission: event.c:875: timeout_next: Assertion `tv->tv_usec >= 0'
      failed. (LP: #387564)

transmission (1.72-1) unstable; urgency=low

  * new upstream release: (closes:#533423)
    - Can now sort the file list by priority, download, and completeness
      (closes: #517872)
    - fixed race condition adding file from browser (closes: #500195)
  * debian/control: policy 3.8.2 (no changes)

 -- Krzysztof Klimonda <email address hidden> Tue, 16 Jun 2009 02:41:48 +0200

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
Stefan Brink (brefan) wrote :

When adding a torrent from the webbrowser, the options window still doesnt raise to top, since the webbrowser has the focus. I would like to suggest to steal the focus, i.e. raise it really to top, if the currently focused window is the one, which initiated the download of the torrent.

Also (somewhat related), when clicking "Show Transmission" in the notification area, I expect to be shown the transmission window, which is not the case if the currently focused window is maximized. I don't have a suggestion for better behaviour in this case though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.