total download speed reported by transmission-remote incorrect

Bug #343255 reported by Courtney Bane on 2009-03-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Transmission
Confirmed
Unknown
transmission (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: transmission

I am using the 1.51-0ubuntu1 packages from jaunty, and the total download rate reported by transmission-remote is incorrect. It reports the same value as the total upload rate. I looked through the source, and found the cause of the problem, and I have attached a patch that should fix it. This same bug exists in the upstream version; I'm going to report it to them as well.

Courtney Bane (cbane) wrote :
Brian Murray (brian-murray) wrote :

Courtney - Did you end up reporting this to upstream? If so do you have a remote bug number that we could link to? Thanks in advance.

Changed in transmission (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Brian Murray (brian-murray) wrote :

I've incorporated your patch into a debdiff so we can get the fix included in transmission for Jaunty. Thanks for your contribution!

David Futcher (bobbo) on 2009-03-19
Changed in transmission (Ubuntu):
assignee: nobody → bobbo
status: Triaged → In Progress
David Futcher (bobbo) wrote :

Transmission is in Main so I can't upload. Debdiff looks fine and builds correctly in an updated pbuilder, though. Subscribing Main sponsors.

Changed in transmission (Ubuntu):
assignee: bobbo → nobody
status: In Progress → Triaged
Courtney Bane (cbane) wrote :

I did report it to upstream as bug #1928 (http://trac.transmissionbt.com/ticket/1928). They had already found and fixed it, so my bug got closed really quickly. From my looking at their repository, it looks like version 1.52 (whenever that comes out) should have the fix incorporated, so the patch can be dropped then.

Changed in transmission:
status: Unknown → Confirmed
Martin Pitt (pitti) wrote :

Sponsored with a minor fix, I added the patch name to the changelog:

transmission (1.51-0ubuntu2) jaunty; urgency=low

  * 30_transmission_total_download.diff: Transmission-remote reports download
    speed incorrectly. Thanks to Courtney Bane for the patch. (LP: #343255)

 -- Brian Murray <email address hidden> Thu, 19 Mar 2009 12:54:17 -0700

Changed in transmission (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.51-0ubuntu2

---------------
transmission (1.51-0ubuntu2) jaunty; urgency=low

  * 30_transmission_total_download.diff: Transmission-remote reports download
    speed incorrectly. Thanks to Courtney Bane for the patch. (LP: #343255)

 -- Brian Murray <email address hidden> Thu, 19 Mar 2009 12:54:17 -0700

Changed in transmission:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.